I'm still having hid issues
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 8 of 8
Cadillac Escalade, EXT and ESV Forum - 1999 - 2006 Discussion, I'm still having hid issues in Cadillac Escalade Forums; So I bought an hid kit for my 02 escalade 6.0 I noticed the flickering. So looking at the forum ...
  1. #1
    bigjeff626 is offline Cadillac Owners Member
    Automobile(s): 2002 escalade 6.0
    Join Date
    Feb 2013
    Age
    30
    Posts
    3

    I'm still having hid issues

    So I bought an hid kit for my 02 escalade 6.0 I noticed the flickering. So looking at the forum was recommended to buy an hid harness kit. I bought one from amazon installed it and still the same issue! I checked the ground lines everything looks good .any advise would help as the lights are starting to annoy me

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,434
    Quote Originally Posted by bigjeff626
    So I bought an hid kit for my 02 escalade 6.0 I noticed the flickering. So looking at the forum was recommended to buy an hid harness kit. I bought one from amazon installed it and still the same issue! I checked the ground lines everything looks good .any advise would help as the lights are starting to annoy me
    Is it only one coming on when the auto headlights kick on or are they like kicking on then off in a cycle?
    If its the first one then its a issue that won't be fixable(due to the nature of the auto headlight system)
    If its the second one then its most likely a bad kit(I got one like that 6000k bulbs slim ballasts only to find out the ballasts were bad and it ruined the bulbs(they can't be used on another ballast)

  4. #3
    Silent_Assasin's Avatar
    Silent_Assasin is offline Cadillac Owners Fanatic
    Automobile(s): 2005 Escalade EXT - Rip Tide Blue
    Join Date
    Mar 2013
    Age
    27
    Posts
    129

    Re: I'm still having hid issues

    Quote Originally Posted by bigjeff626 View Post
    So I bought an hid kit for my 02 escalade 6.0 I noticed the flickering. So looking at the forum was recommended to buy an hid harness kit. I bought one from amazon installed it and still the same issue! I checked the ground lines everything looks good .any advise would help as the lights are starting to annoy me
    ...Its the quality of the kit, some specifically say they are no flicker garentee! where did you buy your hid kit?

  5. #4
    bigjeff626 is offline Cadillac Owners Member
    Automobile(s): 2002 escalade 6.0
    Join Date
    Feb 2013
    Age
    30
    Posts
    3

    Re: I'm still having hid issues

    Quote Originally Posted by the cadillac man View Post
    Is it only one coming on when the auto headlights kick on or are they like kicking on then off in a cycle?
    If its the first one then its a issue that won't be fixable(due to the nature of the auto headlight system)
    If its the second one then its most likely a bad kit(I got one like that 6000k bulbs slim ballasts only to find out the ballasts were bad and it ruined the bulbs(they can't be used on another ballast)
    Its only the left side headlight that flickers, ive tried using the trick on engageing the parking break then turning on the headlights manually then disengageing the parking breaks also flipping the highbeams on then off still same issue ive tried 2 diffrent sets still same issue on the keft side headlight

  6. #5
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,434
    Quote Originally Posted by bigjeff626

    Its only the left side headlight that flickers, ive tried using the trick on engageing the parking break then turning on the headlights manually then disengageing the parking breaks also flipping the highbeams on then off still same issue ive tried 2 diffrent sets still same issue on the keft side headlight
    If you have tried two different (working) ballasts and still have the issue it sounds like a wiring issue(need a multimeter to test for a solid voltage reading)while wiggling the wiring harness for that bulb
    Also try a halogen bulb(I know how it sounds but it may work) and see if it comes on and stays on

  7. #6
    Silent_Assasin's Avatar
    Silent_Assasin is offline Cadillac Owners Fanatic
    Automobile(s): 2005 Escalade EXT - Rip Tide Blue
    Join Date
    Mar 2013
    Age
    27
    Posts
    129

    Re: I'm still having hid issues

    Quote Originally Posted by bigjeff626 View Post
    Its only the left side headlight that flickers, ive tried using the trick on engageing the parking break then turning on the headlights manually then disengageing the parking breaks also flipping the highbeams on then off still same issue ive tried 2 diffrent sets still same issue on the keft side headlight
    Must not mean much to you, but I have installed many hid kits in my vehicles in the past, gf's car, friends and familys vehicles.... I still say it is the quality of the kit your buying!....I have had great luck with DDMtuning ...they stand behind their products and have never had a flickering kit from them!...I would put my money on the ballast you are buying are just bad quality! ....do not buy hid kits off ebay!

  8. #7
    bigjeff626 is offline Cadillac Owners Member
    Automobile(s): 2002 escalade 6.0
    Join Date
    Feb 2013
    Age
    30
    Posts
    3

    Re: I'm still having hid issues

    Hey guys I'm still having issues with my aftermarket hid kit I check all lines everything looks good could my relay be the wrong type? Also it's both sides that have been flickering
    image.jpg

  9. #8
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,434
    Quote Originally Posted by bigjeff626
    Hey guys I'm still having issues with my aftermarket hid kit I check all lines everything looks good could my relay be the wrong type? Also it's both sides that have been flickering
    <img src="http://www.cadillacforums.com/forums/attachment.php?attachmentid=122858"/>
    I would say the ballasts are bad and need replacing
    I had this happen with a kit I had it also made the bulbs have a heavy blue tint from them
    One of the ballasts had a high voltage leak(not good)

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting