Escalade Left Channel Speakers not working
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 6 of 6
Cadillac Escalade, EXT and ESV Forum - 1999 - 2006 Discussion, Escalade Left Channel Speakers not working in Cadillac Escalade Forums; Hey guys, my driver's side speakers don't seem to be working as loud as the other speakers. I have to ...
  1. #1
    af908 is offline Cadillac Owners Member
    Automobile(s): Escalade
    Join Date
    Apr 2013
    Age
    28
    Posts
    13

    Escalade Left Channel Speakers not working

    Hey guys, my driver's side speakers don't seem to be working as loud as the other speakers. I have to move the fade almost all the way to the left for it to sound balanced. Any idea where to start? I'm thinking it might be the factory amp going bad maybe?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,656
    Quote Originally Posted by af908
    Hey guys, my driver's side speakers don't seem to be working as loud as the other speakers. I have to move the fade almost all the way to the left for it to sound balanced. Any idea where to start? I'm thinking it might be the factory amp going bad maybe?
    If you are getting chimes then most likely its the radio
    If no chimes its in the amp

  4. #3
    af908 is offline Cadillac Owners Member
    Automobile(s): Escalade
    Join Date
    Apr 2013
    Age
    28
    Posts
    13

    Re: Escalade Left Channel Speakers not working

    Well, i thought i had chimes, but upon further investigation i dont. I also noticed that it is just the drivers side door speaker not working... all other speakers on that side work. I swear that door speaker had some sound at one point though. What speaker is the chime supposed to come from? Is it the driver's side door speaker only?

  5. #4
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,656
    Quote Originally Posted by af908
    Well, i thought i had chimes, but upon further investigation i dont. I also noticed that it is just the drivers side door speaker not working... all other speakers on that side work. I swear that door speaker had some sound at one point though. What speaker is the chime supposed to come from? Is it the driver's side door speaker only?
    The chimes work from the left front channel only(driver door speaker and a pillar tweeter)
    If you want I can tell you how to remove the door panel to check the speaker

  6. #5
    af908 is offline Cadillac Owners Member
    Automobile(s): Escalade
    Join Date
    Apr 2013
    Age
    28
    Posts
    13

    Re: Escalade Left Channel Speakers not working

    Quote Originally Posted by the cadillac man View Post
    The chimes work from the left front channel only(driver door speaker and a pillar tweeter)
    If you want I can tell you how to remove the door panel to check the speaker
    Ahh, well my apillar speaker IS working, and no chimes. Tried door open, keys in ignition, ignition off. Car running, in drive, door open - nothing.

    Since that speaker is working and yet i have no chimes, according to what you say i must have a bad amp then right?

  7. #6
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,656
    Quote Originally Posted by af908

    Ahh, well my apillar speaker IS working, and no chimes. Tried door open, keys in ignition, ignition off. Car running, in drive, door open - nothing.

    Since that speaker is working and yet i have no chimes, according to what you say i must have a bad amp then right?
    Bad speaker(the a piller tweeter and drivers door speaker are on the same channel)

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting