P0161 engine code
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 8 of 8
Cadillac Escalade, EXT and ESV Forum - 1999 - 2006 Discussion, P0161 engine code in Cadillac Escalade Forums; My caddy has tripped this code. From a google search looks like o2 sensor. Does anyone have any experience with ...
  1. #1
    CaddyEscalade is offline Cadillac Owners Fanatic
    Automobile(s): Escalade
    Join Date
    May 2010
    Posts
    223

    P0161 engine code

    My caddy has tripped this code. From a google search looks like o2 sensor. Does anyone have any experience with this? I have stock exhaust system, what sensor do I need to replace? Is there a way to test them?

    Thanks!

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,995
    Quote Originally Posted by CaddyEscalade
    My caddy has tripped this code. From a google search looks like o2 sensor. Does anyone have any experience with this? I have stock exhaust system, what sensor do I need to replace? Is there a way to test them?

    Thanks!
    I think there is four o2 sensors you will need to find out which one it is that needs replacing
    Try unplugging them one at a time and if there is a extra code or not

  4. #3
    Sentinelist's Avatar
    Sentinelist is offline Cadillac Owners Fanatic
    Automobile(s): 2007 Escalade ESV, Black Raven/black, Platinum wheels, 97k
    Join Date
    Mar 2012
    Location
    Dallas, TX
    Posts
    117

    Re: P0161 engine code

    A quick search looks like your Bank 2 Sensor 2 sensor. I'm going through this myself (see other thread)... not sure which side this is on yet myself, but they are easily accessible under the truck.

  5. #4
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,995
    Quote Originally Posted by Sentinelist
    A quick search looks like your Bank 2 Sensor 2 sensor. I'm going through this myself (see other thread)... not sure which side this is on yet myself, but they are easily accessible under the truck.
    Bank 2 is right side bank 1 is left side

  6. #5
    CaddyEscalade is offline Cadillac Owners Fanatic
    Automobile(s): Escalade
    Join Date
    May 2010
    Posts
    223
    Thread Starter

    Re: P0161 engine code

    I reset the code and will see how long it takes to come back, are the o2 sensors important? Maybe they should all be replaced? I have about 170k kms. Are they all the same? Thanks for the help!

  7. #6
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,995
    Quote Originally Posted by CaddyEscalade
    I reset the code and will see how long it takes to come back, are the o2 sensors important? Maybe they should all be replaced? I have about 170k kms. Are they all the same? Thanks for the help!
    If you want to you can replace all four (as far as them being the same I am not sure as I have never had to replace one)

  8. #7
    CaddyEscalade is offline Cadillac Owners Fanatic
    Automobile(s): Escalade
    Join Date
    May 2010
    Posts
    223
    Thread Starter

    Re: P0161 engine code

    Update... It was just a broken wire on passenger side rear o2 sensor.

  9. #8
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,995
    Quote Originally Posted by CaddyEscalade
    Update... It was just a broken wire on passenger side rear o2 sensor.
    Wow simple and cheap fix
    Glad to hear you got it fixed

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting