02 Escalade-Service Stability System light, tow/haul & stabilitrak buttons don't work
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 9 of 9
Cadillac Escalade, EXT and ESV Forum - 1999 - 2006 Discussion, 02 Escalade-Service Stability System light, tow/haul & stabilitrak buttons don't work in Cadillac Escalade Forums; Hey guys, got a few questions about the Escalade that my wife and I just picked up last month (to ...
  1. #1
    RoadrunnerRod's Avatar
    RoadrunnerRod is offline Cadillac Owners Member
    Automobile(s): 01 Deville, 02 Escalade
    Join Date
    Mar 2008
    Location
    Davey, NE
    Age
    36
    Posts
    9

    Question 02 Escalade-Service Stability System light, tow/haul & stabilitrak buttons don't work

    Hey guys, got a few questions about the Escalade that my wife and I just picked up last month (to replace our totalled 01 Tahoe.) Really loving the truck, that 6.0 really scoots! And the ride, very comfortable! But anyways, it did come with a couple problems (which is why we got it so cheap.) It's an 02 awd base, with 100,000 miles. The prior owner said the Service Stability System light has been on the whole time he's owned it (3-4 years.) It seems to ride and corner great though, so I'm guessing maybe it's just a bad sensor or connection somewhere? The shocks and compressor seem to work fine, as far as I can tell. Haven't really had any time to check it out much, though (been pretty cold here in Nebraska, but getting better! Plus, we've got 2 daughters, one is 1 1/2 and the other is 4 months old, so I don't get much garage time anymore! lol) I've got one of those cheapie $50 code scanners from walmart, haven't used it yet on the Escalade, but I'm assuming it wouldn't read codes for the suspension. Maybe taking it to Autozone and having them pull the codes might tell me what to look for?

    Also, I noticed the tow/haul button doesn't seem to work (I've owned a few silverados and a tahoe, so I know when you press it an indicator light on the gauge cluster comes on, and it'll shift differently.) I've tried it a few times and so far, nothing. Also, the button on the dash that turns the Stabilitrak on and off doesn't seem to work (at least that I've noticed.) Would all these problems possibly be related to eachother? Just thought I'd see if anyone on here had some info I could use, or has been through similar problems (I don't want to start buying parts and replacing things that are working fine, with two babies the ole wallet is a lot lighter anymore!) lol

    Other than that, and a hail damaged hood (which I'll get to eventually, I used to do autobody on the side), we love this truck!

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,646
    Quote Originally Posted by RoadrunnerRod
    Hey guys, got a few questions about the Escalade that my wife and I just picked up last month (to replace our totalled 01 Tahoe.) Really loving the truck, that 6.0 really scoots! And the ride, very comfortable! But anyways, it did come with a couple problems (which is why we got it so cheap.) It's an 02 awd base, with 100,000 miles. The prior owner said the Service Stability System light has been on the whole time he's owned it (3-4 years.) It seems to ride and corner great though, so I'm guessing maybe it's just a bad sensor or connection somewhere? The shocks and compressor seem to work fine, as far as I can tell. Haven't really had any time to check it out much, though (been pretty cold here in Nebraska, but getting better! Plus, we've got 2 daughters, one is 1 1/2 and the other is 4 months old, so I don't get much garage time anymore! lol) I've got one of those cheapie $50 code scanners from walmart, haven't used it yet on the Escalade, but I'm assuming it wouldn't read codes for the suspension. Maybe taking it to Autozone and having them pull the codes might tell me what to look for?

    Also, I noticed the tow/haul button doesn't seem to work (I've owned a few silverados and a tahoe, so I know when you press it an indicator light on the gauge cluster comes on, and it'll shift differently.) I've tried it a few times and so far, nothing. Also, the button on the dash that turns the Stabilitrak on and off doesn't seem to work (at least that I've noticed.) Would all these problems possibly be related to eachother? Just thought I'd see if anyone on here had some info I could use, or has been through similar problems (I don't want to start buying parts and replacing things that are working fine, with two babies the ole wallet is a lot lighter anymore!) lol

    Other than that, and a hail damaged hood (which I'll get to eventually, I used to do autobody on the side), we love this truck!
    The service stability system message is because of a wheel speed sensor
    Not sure on the tow/haul button but I would check the fuses before doing anything that has to do with electrical

  4. #3
    RoadrunnerRod's Avatar
    RoadrunnerRod is offline Cadillac Owners Member
    Automobile(s): 01 Deville, 02 Escalade
    Join Date
    Mar 2008
    Location
    Davey, NE
    Age
    36
    Posts
    9

    Re: 02 Escalade-Service Stability System light, tow/haul & stabilitrak buttons don't

    Well, just noticed another problem. Went out to pick up the mail, and then afterwards I grabbed my code scanner and plugged it into the escalade. It wouldn't light up or anything! Figured maybe the scanner broke, so I plugged it into my Ford Ranger, but it worked just fine on there. Looked up a few things about the scanner port and it said it could be just a fuse blown or something... guess I'll have to check that out, too, when I get some more time! lol Man, I hate electrical problems

  5. #4
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,646
    Quote Originally Posted by RoadrunnerRod
    Well, just noticed another problem. Went out to pick up the mail, and then afterwards I grabbed my code scanner and plugged it into the escalade. It wouldn't light up or anything! Figured maybe the scanner broke, so I plugged it into my Ford Ranger, but it worked just fine on there. Looked up a few things about the scanner port and it said it could be just a fuse blown or something... guess I'll have to check that out, too, when I get some more time! lol Man, I hate electrical problems
    Check the cigar fuse in the under hood fuse box maybe its blown(it works that) if the power outlets has a coin in one then there is the reason for the obd port not working

  6. #5
    RoadrunnerRod's Avatar
    RoadrunnerRod is offline Cadillac Owners Member
    Automobile(s): 01 Deville, 02 Escalade
    Join Date
    Mar 2008
    Location
    Davey, NE
    Age
    36
    Posts
    9

    Re: 02 Escalade-Service Stability System light, tow/haul & stabilitrak buttons don't

    Thanks for the tip... checked all the power outlets, no coins or anything. Popped the hood and checked the fuse box... the cigar fuse was blown! Replaced it with a good one and now the scanner port works! Had to run back inside the house since it's time to feed our 4 month old, but at least one problem got fixed on the Escalade!

  7. #6
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,646
    Quote Originally Posted by RoadrunnerRod
    Thanks for the tip... checked all the power outlets, no coins or anything. Popped the hood and checked the fuse box... the cigar fuse was blown! Replaced it with a good one and now the scanner port works! Had to run back inside the house since it's time to feed our 4 month old, but at least one problem got fixed on the Escalade!
    That's great news keep us posted when you get the codes

  8. #7
    RoadrunnerRod's Avatar
    RoadrunnerRod is offline Cadillac Owners Member
    Automobile(s): 01 Deville, 02 Escalade
    Join Date
    Mar 2008
    Location
    Davey, NE
    Age
    36
    Posts
    9

    Re: 02 Escalade-Service Stability System light, tow/haul & stabilitrak buttons don't

    Well, my cheapie scanner didn't pull any codes (I believe it only reads engine problem codes, which is also good, meaning at least engine wise this truck is fine!) Just got the babies to sleep and went for a little drive, noticed that if I start the Escalade and press the Stabilitrak off button it does turn off, but if I turn it back on and drive a little that Service Stability System light comes back on. Also noticed that if I come to a stop and shift down to first gear I'm able to press the Tow/Haul button and that works! But strangely I can't turn it back off, unless I come to a stop again and shift back down to first and press it again. Is this how all Escalades are? I know on our Tahoe and my former Silverados I could turn Tow/Haul on and off anytime, in any gear... kinda weird, but at least it basically works if anything

  9. #8
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,646
    Quote Originally Posted by RoadrunnerRod
    Well, my cheapie scanner didn't pull any codes (I believe it only reads engine problem codes, which is also good, meaning at least engine wise this truck is fine!) Just got the babies to sleep and went for a little drive, noticed that if I start the Escalade and press the Stabilitrak off button it does turn off, but if I turn it back on and drive a little that Service Stability System light comes back on. Also noticed that if I come to a stop and shift down to first gear I'm able to press the Tow/Haul button and that works! But strangely I can't turn it back off, unless I come to a stop again and shift back down to first and press it again. Is this how all Escalades are? I know on our Tahoe and my former Silverados I could turn Tow/Haul on and off anytime, in any gear... kinda weird, but at least it basically works if anything
    Sounds like something isn't right
    The service stability system message is possibly a wheel sensor

    The tow haul mode button is not normal as on my 03 you can turn it on and off regardless of gear position(I have the service manual for ours trucks and will look into the wiring for that to see what it goes to as it seems that it is tied into the transmission along with the suspension system(don't ask long story) and the power steering system

  10. #9
    codyt03 is offline Cadillac Owners Member
    Automobile(s): 2002 Escalade
    Join Date
    Jun 2013
    Age
    30
    Posts
    2

    Re: 02 Escalade-Service Stability System light, tow/haul & stabilitrak buttons don't

    Your Tow/Haul button should work no matter what gear you are in, moving or not, my 02 escalade does. You probably have a bad wire in the gear shifter that makes connection when you pull it down into first gear. I changed the gear shift handle on my brothers 02 durmax and it fixed his not working button. not to difficult, same setup.

    On the service stability part, my 02 escalade has the light come on also. The compressor comes on for a few seconds after reaching 5 mph, then it pauses for a few seconds then back on for a few seconds then off, then the light immediatly come on, same sequence without fail everytime i drive. to clear the light i turn the engine of and then back on. See if this the same as yours, and any help will be appreciated by me also.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting