buttons not work...2004 Escalade NAV
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 5 of 5
Cadillac Escalade, EXT and ESV Forum - 1999 - 2006 Discussion, buttons not work...2004 Escalade NAV in Cadillac Escalade Forums; All side buttons on navigation system are lock on my 04 escalade???? Can help me.......
  1. #1
    raleman is offline Cadillac Owners Member
    Join Date
    Feb 2013
    Posts
    1

    buttons not work...2004 Escalade NAV

    All side buttons on navigation system are lock on my 04 escalade???? Can help me....

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Submariner409's Avatar
    Submariner409 is offline If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    45,086

    Re: buttons not work...

    Wrong forum. Cadillac Customer Care is for warranty and dealer work problems on newer model cars. Moved to Escalade.

  4. #3
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,691
    Quote Originally Posted by raleman
    All side buttons on navigation system are lock on my 04 escalade???? Can help me....
    Try removing the radio fuse for a few minutes

  5. #4
    ibkruzen is offline Cadillac Owners Member
    Automobile(s): 1964 Coupe De Ville Convertable
    Join Date
    Apr 2013
    Age
    50
    Posts
    1

    Re: buttons not work...2004 Escalade NAV

    Did removing the fuse(s) work I am having the same issue with my radio as well. Have pulled the fuses (nothing) and removed the radio, the pads look good for the buttons. The only other issue i saw was the Ribbon cable going to the display looked loose but made sure it was tight when I put it all back together. BUT the problem still exists. Any help would be huge at this time.

    Thx in advance

  6. #5
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,691
    Quote Originally Posted by ibkruzen
    Did removing the fuse(s) work I am having the same issue with my radio as well. Have pulled the fuses (nothing) and removed the radio, the pads look good for the buttons. The only other issue i saw was the Ribbon cable going to the display looked loose but made sure it was tight when I put it all back together. BUT the problem still exists. Any help would be huge at this time.

    Thx in advance
    Winds like the radio is failing due to age

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting