2004 Escalade windshield washer not working please help
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 5 of 5
Cadillac Escalade, EXT and ESV Forum - 1999 - 2006 Discussion, 2004 Escalade windshield washer not working please help in Cadillac Escalade Forums; So I had my radio controls fixed on the steering wheel the other day and now my wind shield washer ...
  1. #1
    112motorsports is offline Cadillac Owners Member
    Join Date
    Aug 2012
    Age
    33
    Posts
    10

    2004 Escalade windshield washer not working please help

    So I had my radio controls fixed on the steering wheel the other day and now my wind shield washer will not work. If you push the switch the wipers cycle as they should but the pump does not pump any fluid. the pump works as it will disperse fluid to the rear window but not the front. Could the shop have possibly messed up something causing this issue? Please help as I hate electrical issues. Thank you for your time and help.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,559
    Quote Originally Posted by 112motorsports
    So I had my radio controls fixed on the steering wheel the other day and now my wind shield washer will not work. If you push the switch the wipers cycle as they should but the pump does not pump any fluid. the pump works as it will disperse fluid to the rear window but not the front. Could the shop have possibly messed up something causing this issue? Please help as I hate electrical issues. Thank you for your time and help.
    Either the pump has failed or battery acid has ate the hose(it happened to mine both front and rear)

    Try working the washer controls with the key in run(engine off) and see if it makes a puddle and you hear the pump if yes then the line needs replacing
    If you don't hear the pump then it may need replacing

  4. #3
    112motorsports is offline Cadillac Owners Member
    Join Date
    Aug 2012
    Age
    33
    Posts
    10

    Re: 2004 Escalade windshield washer not working please help

    The pump is working. If I depress the switch for the rear window the pump turns on and fluid is dispensed into the rear window. However when I try the front the pump does not turn on and no fluid is dispensed. the puzzling thing is it worked when it went into the shop to have the radio switches replaced and now it doesn't work. It my be a fluke but I am lost and upset as it isn't working.

  5. #4
    PITT M3 RR's Avatar
    PITT M3 RR is offline Cadillac Owners Member
    Automobile(s): 04 Escalade
    Join Date
    Sep 2012
    Location
    Pittsburgh, PA
    Age
    29
    Posts
    35

    Re: 2004 Escalade windshield washer not working please help

    Fisrt call the shop and see what they say. Then check your fuses.

    Then find the fluid pump on the bottle, remove it and test it with 12V, if it kicks on in your hand you're good to go and just need to follow the wiring back to the dash/switch. If not its dead and replace from ebay. This should be easy to find unless the shop hacked a wire in which case, the first option should cover it.

  6. #5
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,559
    Quote Originally Posted by 112motorsports
    The pump is working. If I depress the switch for the rear window the pump turns on and fluid is dispensed into the rear window. However when I try the front the pump does not turn on and no fluid is dispensed. the puzzling thing is it worked when it went into the shop to have the radio switches replaced and now it doesn't work. It my be a fluke but I am lost and upset as it isn't working.
    There is two pumps on for rear one for front if it was me I'd go back and tell them (I know how you feel I had auto zone fry my rear seat DVD player and I am having a time with that I was worried it might mess something else in my truck up(eg the truck body controller) till I can get the codes pulled from it(that is if my dealer will do it as they think it may go to court and don't want to be liable) it sucks when someone tears up something and don't take responsibility for it

    The whole problem I am having could have been avoided if the guy listened to me when I told I could put the battery in myself but he didn't.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting