03 Escalade AWD 6.0L V8 AC stops working abruptly
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 3 of 3
Cadillac Escalade, EXT and ESV Forum - 1999 - 2006 Discussion, 03 Escalade AWD 6.0L V8 AC stops working abruptly in Cadillac Escalade Forums; When I start my first time in a day AC works great. Cold air everything is fine. After I park ...
  1. #1
    vmm2012 is offline Cadillac Owners Member
    Automobile(s): 2003 Escalade AWD
    Join Date
    Jun 2012
    Posts
    1

    03 Escalade AWD 6.0L V8 AC stops working abruptly

    When I start my first time in a day AC works great. Cold air everything is fine.
    After I park my car somewhere and restart AC stop (no cold air) Air blower is on but no cooling.

    Same thing happens on hot summer days and when car is driven above 3.5K RPM

    Please advice.

    Thanks in advance.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,861

    Re: 03 Escalade AWD 6.0L V8 AC stops working abruptly

    have the ac checked cause there is a low pressure switch and high pressure switch and either one can make the system not work plus low freon can cause this at times.
    most likely it is one of the switches gone nutty given what you said.

  4. #3
    gmercedesbenz's Avatar
    gmercedesbenz is offline Cadillac Owners Fanatic
    Automobile(s): 2002 Escalade
    Join Date
    Jun 2010
    Location
    Washington D.C.
    Posts
    169

    Re: 03 Escalade AWD 6.0L V8 AC stops working abruptly

    Have you recently had the system re-charged or have you attempted to add freon yourself? Touching off what thecaddilacman said, incorrect freon levels can sometimes be the cause of this.

    I recently had my A/C compressor replaced, as I was getting the dreaded "sludging" issue that GM has a TSB out for. The day after having it replaced, I was sitting in traffic and my A/C was warm. As soon as traffic opened up again and I got up to about 40 mph or so, it got ICE cold. Stop and go traffic again, not-so-cold-warm again. After some research, I took it back as I suspected there was a freon pressure issue. Sure enough, the tech had over-pressurized the system by about a pound. After a de-charge and re-charge with the correct pressure, works perfectly.

    Over-pressurized or under-pressurized systems trip the low/high pressure switches that control the compressor, thus leading to the compressor turning off when it shouldn't. If you haven't had the system recently serviced, you could possibly have a leak in the lines. When it is working correctly, is it ice cold or just somewhat cold?

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting