Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 2 of 2

Thread: 2000 windshield washer pump not working

  1. #1
    Lumps74374 is offline Cadillac Owners Member
    Automobile(s): 2000 Escalade
    Join Date
    May 2011
    Posts
    3

    2000 windshield washer pump not working

    The windshield washer pump on my wifes 2000 does not work when the switch on steering column is pushed, but when I apply 12 volts at the harness connector under hood near fluid reservoir, the pump runs normally. Member SK7 responded to a similar question on 1/19/10, which provided me with a schematic and some direction, but unlike that situation (wipers didn't operate when washer switch was pushed), in my case the wipers do run.
    Based on that (and my analysis of the schematic), I think that I can rule out the switch inside the column, as the wiper control board must be geting a signal to run the wipers when the wash switch is pushed. One other symptom possibly related is that the wipers are operating erratically as far as where they stop, and (my wife reports) erratic delay times.
    Can anyone confirm that my analysis and the erratic operation I've described pinpoint the problem to the wiper control board?


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners 10000+ Posts
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    11,884

    Re: 2000 windshield washer pump not working

    does the rear wiper work fine or not if it acts up it might be in the control board if not i would say you a bad multi function switch and it will had to be replaced but before you do anything check the fuses i don't know for sure if the fluid pumps have a separate fuse or not while your at it check to make sure the connection don't have any corrosion it can happen


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum