Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 5 of 5

Thread: 2000 Escalade, loss of power and runs horribly

  1. #1
    pimpin88's Avatar
    pimpin88 is offline Cadillac Owners Connoisseur
    Automobile(s): 01 STS, 92 Roadmaster, 01 SLS-sold, 88 Brougham-crushed
    Join Date
    Nov 2004
    Location
    northeast ohio
    Age
    28
    Posts
    1,392

    2000 Escalade, loss of power and runs horribly

    2000 Escalade, 115,000 miles.

    On the way home yesterday, hour and a half trip, it started running horribly all of a sudden. Had hardly any power and we had to drive on the shoulder because at times we couldn't keep the truck over 25mph.

    There is no check engine light. The truck will run perfectly, and then cut out and start shaking and having no power. If you let it sit and idle for a minute, it will start running normally again, and then you can drive for a few minutes and it will be fine. Then the sputtering and shaking start all over again and you have to either pull over or really try hard to keep the truck going at about 45mph.

    Any ideas? I believe the guy said it happened to him once before but the truck actually stalled and wouldn't restart.


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    pimpin88's Avatar
    pimpin88 is offline Cadillac Owners Connoisseur
    Automobile(s): 01 STS, 92 Roadmaster, 01 SLS-sold, 88 Brougham-crushed
    Join Date
    Nov 2004
    Location
    northeast ohio
    Age
    28
    Posts
    1,392

    Re: 2000 Escalade, loss of power and runs horribly

    Also, the fuel gauge is all over the place. It will go from the actual level of fuel straight to empty, then back up for a few seconds, and straight back to empty. It does this constantly whether the car is running correctly or not.

  4. #3
    EROCK1 is offline Cadillac Owners Member
    Automobile(s): 2005 Escalade EXT
    Join Date
    Jan 2011
    Age
    35
    Posts
    15

    Re: 2000 Escalade, loss of power and runs horribly

    Sounds like it's time to replace your fuel pump. I would replace the filter as well

  5. #4
    smowre is offline Cadillac Owners Member
    Automobile(s): 2000 Escalade
    Join Date
    Mar 2011
    Posts
    7

    Re: 2000 Escalade, loss of power and runs horribly

    What corrected your problem?

  6. #5
    pcguy760 is offline Cadillac Owners Enthusiast
    Automobile(s): '01 Pearl White - Sold 10/11, '09 Raven Black :)
    Join Date
    Feb 2009
    Posts
    730

    Re: 2000 Escalade, loss of power and runs horribly

    I am curious too what was the cause of this??? So many things I can think of ... wonder what codes a scanner would have gave hmmmm....


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum