Service Stability System AND abs Pump issue
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 23
Cadillac Escalade, EXT and ESV Forum - 1999 - 2006 Discussion, Service Stability System AND abs Pump issue in Cadillac Escalade Forums; I have an 02 Escalade, and just replaced the ABS valve control assembly because of a leak. We put it ...
  1. #1
    ptippett is offline Cadillac Owners Member
    Automobile(s): Escalade
    Join Date
    Jun 2009
    Posts
    14

    Service Stability System AND abs Pump issue

    I have an 02 Escalade, and just replaced the ABS valve control assembly because of a leak. We put it all back together and all was well for 3 weeks. We only replaced the ABS valve assembly and not the computer module controller.

    The issue I have now is when I start to drive, the ABS runs a system test. Normally you hear the ABS motor run for about a second and go off. Now the ABS turns on and off six times, each time running for about four seconds. After the sixth test cycle the Service Stability system comes on, and I have no ABS brakes.

    Has any one experienced this? I have blead the complete system, and no air at all. For some reason the ABS pump is not passing the start up test.

    Any help would be appreciated.


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    pcguy760 is offline Cadillac Owners Enthusiast
    Automobile(s): 02 Diamond White Pearl Escalade - Sold 10/11
    Join Date
    Feb 2009
    Location
    IL, USA
    Posts
    675

    Re: Service Stability System AND abs Pump issue

    What codes are you throwing? By a long shot I would say it is your EBCM probably but first lets see what codes you are throwing...

  4. #3
    ptippett is offline Cadillac Owners Member
    Automobile(s): Escalade
    Join Date
    Jun 2009
    Posts
    14

    Re: Service Stability System AND abs Pump issue

    I have not had the codes pulled. The dealer wanted $110 to pull them, which is robbery to read a code. I was hoping someone would have had a similar issue, and could direct me to the issue.

  5. #4
    sk7's Avatar
    sk7
    sk7 is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 Escalade AWD
    Join Date
    Nov 2008
    Location
    Québec, Canada
    Age
    45
    Posts
    1,025

    Re: Service Stability System AND abs Pump issue

    Ewill mentioned that whenever you remove the ABS valve assembly, a special bleeding procedure needs to be performed by the dealership with the GM tech 2 scanner. Pcguy has done the job without this procedure, maybe it needs to be done in your case? Have you cleaned the ground to the body for the EBCM?

  6. #5
    pcguy760 is offline Cadillac Owners Enthusiast
    Automobile(s): 02 Diamond White Pearl Escalade - Sold 10/11
    Join Date
    Feb 2009
    Location
    IL, USA
    Posts
    675

    Re: Service Stability System AND abs Pump issue

    Sk, something told me you would chime in on this thread lol since we had our fair share of this. Yeah I did not bleed the pump yet but I bet it needs to be done because my brakes feel a liiiiiitle less responsive - nothing to put me in a bad situation though. Hey aren't there like 3 grounds or something? Sk how is your 'Lade coming along?

  7. #6
    sk7's Avatar
    sk7
    sk7 is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 Escalade AWD
    Join Date
    Nov 2008
    Location
    Québec, Canada
    Age
    45
    Posts
    1,025

    Re: Service Stability System AND abs Pump issue

    According to the service manual there's only one main ground, there's a TSB on the issue that EBCM were replaced and problems were caused by the ground being corroded. Since I couldn't figure out which one it is from the manual, I did the two on the drivers side. One close to the front cab support, the other in the center. Pics are in your post about PCM indicated malfunction. Only ABS light is on now, will take care of it tuesday (day off). Other than that trucks runs good, no more issues. Getting ready to install winter tires and change the front diff to Amsoil.

  8. #7
    ptippett is offline Cadillac Owners Member
    Automobile(s): Escalade
    Join Date
    Jun 2009
    Posts
    14

    Re: Service Stability System AND abs Pump issue

    SK7 I did not see a ground for the ECBM! Where is it located? I assumed that the ground was one of the wires off of the main harness. The pump is running well, so I would think it has a good ground.

  9. #8
    sk7's Avatar
    sk7
    sk7 is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 Escalade AWD
    Join Date
    Nov 2008
    Location
    Québec, Canada
    Age
    45
    Posts
    1,025

    Re: Service Stability System AND abs Pump issue

    Pics of the grounds can be found here:

    http://www.cadillacforums.com/forums...242-pcm-2.html

    The ground issue had to do with the ABS pump motor. Corrosion would point to failed diagnostic of the EBCM module. Did you disconnect the battery before reinstalling the module? Sometimes the current spike when plugging it in can cause gremlins.

  10. #9
    bpc87 is offline Cadillac Owners Fanatic
    Automobile(s): Cadillac
    Join Date
    Oct 2008
    Posts
    116

    Re: Service Stability System AND abs Pump issue

    hey i am having the same service stability system problem does the abs pump coming on sound like a loud whining sound because that is what my truck does the same amount of times then the service stability system light comes on and when i press on the brakes while its doing it it will stop until i let off???

  11. #10
    EZEXT is offline Cadillac Owners Member
    Automobile(s): 2002 escalade ext, 2008 cts 3.6
    Join Date
    Jun 2010
    Age
    35
    Posts
    34

    Re: Service Stability System AND abs Pump issue

    SK7 is the man!! when it come to troubleshooting !!! he help me with the service stability control

  12. #11
    ewill3rd is offline Cadillac Technician
    Automobile(s): none
    Join Date
    Nov 2005
    Location
    WOODBRIDGE, VA
    Age
    46
    Posts
    11,062

    Re: Service Stability System AND abs Pump issue

    You need to find out what code is setting and go from there.

  13. #12
    sk7's Avatar
    sk7
    sk7 is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 Escalade AWD
    Join Date
    Nov 2008
    Location
    Québec, Canada
    Age
    45
    Posts
    1,025

    Re: Service Stability System AND abs Pump issue

    Bpc87, it sure sounds like the ABS pump going into self test mode. The EBCM is right under the drivers seat, attached to the frame. I'll tell you the same advice I gave to ezext, those modules are prone to failure, and a pita to remove. And even if the repair is successfull, then there's always the front bearings that are also a weak link, and the steering position sensor... Bypass the unit and live happly ever after! ATE wasnt able to fix my EBCM. I'ts ur call! You can find some info into a thread that pcguy wrote on his EBCM (codes, pics, etc); I forget the exact title...

  14. #13
    02caddilade is offline Cadillac Owners Member
    Automobile(s): 2002 escalade awd 6.0
    Join Date
    Aug 2010
    Age
    35
    Posts
    48

    Re: Service Stability System AND abs Pump issue

    i have a 02 also and when my pump/modual went bad my caddy kept stopping itself dead in the road, $2500 just for the parts from the dealer

  15. #14
    pro1motors is offline Cadillac Owners Member
    Automobile(s): 2002 escalade
    Join Date
    Sep 2010
    Posts
    1

    Re: Service Stability System AND abs Pump issue

    hi, new guy here..i have a 2002 and when you start to go, there is no light on... when you start to move you here the abs go... and then the stability like comes on... my mechanic told me there wasa code co286 abs indicator short to battery voltage..can anyone help??

  16. #15
    sk7's Avatar
    sk7
    sk7 is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 Escalade AWD
    Join Date
    Nov 2008
    Location
    Québec, Canada
    Age
    45
    Posts
    1,025

    Re: Service Stability System AND abs Pump issue

    I'm pretty sure the code C0286 is a dead EBCM code. I'll have a look at the FSM and get back to you later today.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting