URPA Control Module on 2005 ESV - Page 3
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 31 to 45 of 47
Cadillac Escalade, EXT and ESV Forum - 1999 - 2006 Discussion, URPA Control Module on 2005 ESV in Cadillac Escalade Forums; glad you got it working!...
  1. #31
    pilot-werx's Avatar
    pilot-werx is offline Cadillac Owners Fanatic
    Automobile(s): none
    Join Date
    Jun 2009
    Posts
    134
    Thread Starter

    Re: URPA Control Module on 2005 ESV

    glad you got it working!

  2. #32
    fly170s's Avatar
    fly170s is offline Cadillac Owners Member
    Automobile(s): 2002 esclade
    Join Date
    Jan 2010
    Posts
    7

    Re: URPA Control Module on 2005 ESV

    I have a 2002 esclade..plane ole esclade, not long.. not a truck.. no 4 wheel drive.. one sensor on passenger side.. light comes on.. no chime no blinking.. just one light is lit.. where do i start? Ive read these forums and they go back and forth between diff mods..very confusing..

  3. #33
    sk7's Avatar
    sk7
    sk7 is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 Escalade AWD
    Join Date
    Nov 2008
    Location
    Québec, Canada
    Age
    45
    Posts
    1,025

    Re: URPA Control Module on 2005 ESV

    The diag connector is very easy to find on the base model 02. Right under the URPA module itself (taped to the harness) passenger side under back seat. Once you have it you can diagnose the problem very easily with instructions above.

  4. #34
    Jack Gates is offline Cadillac Owners Member
    Automobile(s): Escalade Eldorado
    Join Date
    Mar 2011
    Posts
    5

    Re: URPA Control Module on 2005 ESV

    I know this an OLD thread but...I'm desperate! LOL

    My RPA quit working on my standard 2005 Escalade. The red light flashes.
    I can't find the diagnostic connector. It is NOT close to the module on the floor beneath the rear passenger seat. I called the dealer and a tech said it was behind the dash close to the steering column. Huh?

    Help!
    Please?

  5. #35
    gpiquer is offline Cadillac Owners Member
    Automobile(s): Escalade ESV 2007
    Join Date
    Oct 2011
    Location
    Calgary
    Age
    46
    Posts
    10

    Re: URPA Control Module on 2005 ESV

    Hi all ,

    Anyone knows where the URPA module is located in a Escalade ESV 2007 ? and where I suppose to see the flashing lights ?? "Telltale" ? I also there is connector that I need to shortcut to start the diagnostic mode , where is located ??

    There is a lot of questions that I hope someone over there is willing to answer .

    Thanks a lot .

  6. #36
    2storm's Avatar
    2storm is offline Cadillac Owners Fanatic
    Automobile(s): 09 escalade ext, 03 base
    Join Date
    Dec 2008
    Location
    Edmonton, Alberta
    Age
    47
    Posts
    102

    Re: URPA Control Module on 2005 ESV

    i bought a used 03 base. urpa inop.
    diagnostics say 2 sensors. does anyone have the pinout from the block to sensor harness??
    the block is the 4 connector grey board on the right quarter paNEL above exhaust.
    i had to replace it to get rear lighting up and running, amongst a billion other things...
    also would anyone have the 3 position pinout of the sensors and what the operational range is?
    im gonna take out the harness and test all wires for impedance. but i wanna check sensors individually without
    playing the sensor shell swap game/.....

  7. #37
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    8,051
    Quote Originally Posted by 2storm
    i bought a used 03 base. urpa inop. diagnostics say 2 sensors. does anyone have the pinout from the block to sensor harness?? the block is the 4 connector grey board on the right quarter paNEL above exhaust. i had to replace it to get rear lighting up and running, amongst a billion other things... also would anyone have the 3 position pinout of the sensors and what the operational range is? im gonna take out the harness and test all wires for impedance. but i wanna check sensors individually without playing the sensor shell swap game/.....
    It won't work like your thinking

    What is the codes and I can help more

  8. #38
    2storm's Avatar
    2storm is offline Cadillac Owners Fanatic
    Automobile(s): 09 escalade ext, 03 base
    Join Date
    Dec 2008
    Location
    Edmonton, Alberta
    Age
    47
    Posts
    102

    Re: URPA Control Module on 2005 ESV

    i finally found a thread.....
    i showed 3 sensors bad, but earlier i had unhooked one to try and see a part number...then tried
    reverse to see what changed. just a blinking red.
    once i found the thread, i showed 3 sensors bad, so i cleared em and then i still showed 2 bad.
    obviously the one i took out is good.
    now i show 2 ambers, then a red. so from memory thats middle right and left outter are bad.
    you say i cant test the sensors? surely i can test the wiring.

    thx for chiming in caddyman.

  9. #39
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    8,051
    Quote Originally Posted by 2storm
    i finally found a thread..... i showed 3 sensors bad, but earlier i had unhooked one to try and see a part number...then tried reverse to see what changed. just a blinking red. once i found the thread, i showed 3 sensors bad, so i cleared em and then i still showed 2 bad. obviously the one i took out is good. now i show 2 ambers, then a red. so from memory thats middle right and left outter are bad. you say i cant test the sensors? surely i can test the wiring. thx for chiming in caddyman.
    Replace the sensors and it should fix the issue
    Normally it will flash a different error if the wiring is truly at fault

    You can probe the wiring but if the system isn't throwing the code for the wiring I wouldn't mess with it

    Check the harness to make sure its fully seated as if the little clip is broke it will make a loose connection with the sensor(had it happen to me and I almost replaced a working sensor because of it)

    The sensor codes are as they are in the bumper(eg left corner sensor is the drivers outside sensor)

    Remember once you replace the sensors you will need to drive the truck at least 15mph in drive to clear the codes in the system(with the jumper removed)

  10. #40
    2storm's Avatar
    2storm is offline Cadillac Owners Fanatic
    Automobile(s): 09 escalade ext, 03 base
    Join Date
    Dec 2008
    Location
    Edmonton, Alberta
    Age
    47
    Posts
    102

    Re: URPA Control Module on 2005 ESV

    okay caddyman...
    I played musical sensors and determined that 3 of the sensors work in mid left or right positions in bumper.
    1 sensor won't work in any position, and none work in the left or mid right spots. I do not get a blinking yellow.
    I have not ohm tested wires. sounds to me like I need 1 sensor and a harness (or repair).??????????
    what's your opinion. Ps I lubed the plug housings with a lil dielectric grease so the rubber weather barrier can slide in and seat well.

    ----------

    oh to clarify... I was running under the assumption that eg. red light means drivers outside sensor. right?

  11. #41
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    8,051
    The sensors are indicated like this

    Left corner sensor
    Red outside led only
    Left middle sensor
    Red outside and middle amber LEDs
    Right middle sensor Both amber LEDs
    Right outside sensor Outside amber led

    If one sensor errors no matter where its at then its bad

    It sounds likely you need a wiring harness given how it the sensors won't work in certain spots

    If you want pm me and I can provide a wiring diagram for this to help out better

  12. #42
    2storm's Avatar
    2storm is offline Cadillac Owners Fanatic
    Automobile(s): 09 escalade ext, 03 base
    Join Date
    Dec 2008
    Location
    Edmonton, Alberta
    Age
    47
    Posts
    102

    Re: URPA Control Module on 2005 ESV

    k, I was reading the lights right. knew I shoulda checked the wires..... ill hit you up for the schematic
    .

    ----------

    oh to clarify... I was running under the assumption that eg. red light means drivers outside sensor. right?

  13. #43
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    8,051
    Quote Originally Posted by 2storm
    k, I was reading the lights right. knew I shoulda checked the wires..... ill hit you up for the schematic . ---------- oh to clarify... I was running under the assumption that eg. red light means drivers outside sensor. right?
    Correct

  14. #44
    nisse81 is offline Cadillac Owners Member
    Join Date
    Aug 2013
    Posts
    7
    Hi
    Does anybody know if the parking sensors on escalade 2002-2006 is the same as the ones on srx 05-06? They sure look the same but will they work on a escalade? My URPA system is failing and it always bugs me when i look in the rear view mirror and see the flashing red light. I've done the diagnostics. Appreciate it/ Nils

  15. #45
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    8,051
    If they are the same part number then yes they will work if they are not the same number then they won't work

    You can disable the park sensor system via the button on the dash(I need a new sensor for my 03)

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting