Motor mount going bad?
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 11 of 11
Like Tree2Likes
  • 1 Post By ltdltc
  • 1 Post By ltdltc
Cadillac DTS Forum - 2006 through 2012 Discussion, Motor mount going bad? in Past Cadillac Vehicle Discussion; I'm not too engine savvy, but I have what appears to be an engine mount or engine vibration dampener going ...
  1. #1
    beauimpala is offline Cadillac Owners Member
    Automobile(s): 2006 DTS 1985 Seville
    Join Date
    Sep 2013
    Location
    SW Washington
    Posts
    18

    Motor mount going bad?

    I'm not too engine savvy, but I have what appears to be an engine mount or engine vibration dampener going bad? You can see in the picture it is all cracked and has actually separated from the nut completely cracking all the way through from top to bottom. Is this easy to change? Is it as simple as taking off the nut on the top and replacing with a new one? Any advice would be greatly appreciated.
    Attached Images

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    ltdltc's Avatar
    ltdltc is offline Cadillac Owners Fanatic
    Automobile(s): 2010 CTS4 Performance Sport Wagon
    Join Date
    Jun 2003
    Location
    MA
    Age
    33
    Posts
    438

    Re: Motor mount going bad?

    You need to unbolt the coolant expansion tank. Once you unmount the expansion tank you can unbolt that torque strut.

    Mine was cracked but still seemed to be doing its job. I had a vibration and it was the lower engine mount and once replaced the vibration ceased.
    tjwhite721 likes this.

  4. #3
    hbrigiii is offline Cadillac Owners Member
    Automobile(s): Cadillac 2006 DTS
    Join Date
    Dec 2006
    Location
    Rockport, Texas
    Posts
    30

    Re: Motor mount going bad?

    Sure looks like it's time to replace it. Mine on my 2006 DTS failed just like yours at about 100,000 mi. I had it replace while I waited at the shop. Didnt seem to long to do. I think
    they charged me about one hour. If this upper one has failed, be sure to check the lowers. This one being broken will have put undue strain on the lowers which are just as old.
    Good luck.

  5. #4
    thomas.jain1 is offline Cadillac Owners Member
    Join Date
    Jul 2014
    Age
    34
    Posts
    2

    Re: Motor mount going bad?

    Bad motor mount or something else?

    i have an 1981 cutlass periodically i experience a derate from the trans it seems out of nowhere i can feel the engine jump a little then it become hard to accelerate then eventually it'll go back to normal i doubt its the trans because its been taking place for quite some time it feels like its slipping but it only happens every so often(jump in and out of gear as it feels that way)what can cause this? and what type of affects do u see from a bad mount besides the added vibrations?

    LED billboard truck

  6. #5
    Abecadillac2009's Avatar
    Abecadillac2009 is offline Cadillac Owners Member
    Automobile(s): DTS
    Join Date
    Jun 2014
    Posts
    11
    Does the vibration happen when you are idling while waiting for the light to change.
    I have a similar situation but I am not sure what is causing it.

  7. #6
    beauimpala is offline Cadillac Owners Member
    Automobile(s): 2006 DTS 1985 Seville
    Join Date
    Sep 2013
    Location
    SW Washington
    Posts
    18
    Thread Starter

    Re: Motor mount going bad?

    I actually feel no vibration at all. Just noticed the cracking on top and knew it was going to lead to other problems if not taken care of.

  8. #7
    beauimpala is offline Cadillac Owners Member
    Automobile(s): 2006 DTS 1985 Seville
    Join Date
    Sep 2013
    Location
    SW Washington
    Posts
    18
    Thread Starter

    Re: Motor mount going bad?

    Got the part. I checked around 3 places and all of them were in the $65 to $70 range on these. Prices must have gone up. Anyways I went to tackle this and found it to be very easy. I don't know why somebody said you have to take the wheel off and the splash gaurd. It can easily be done all on the top. There were 2 bolts actually holding the mount in place. Then I removoed 2 10mm bolts holding the coolant expansion tank down. When these 2 nuts were removed it gave me plenty of clearance to remove the torque strut out of there and install the new one. There was one other cross brace holding the actual torque strut down and that is a brace located just above expansion tank. Took me about 20 minutes to remove the 3 nuts and 2 bolts and replace the new one.

  9. #8
    beauimpala is offline Cadillac Owners Member
    Automobile(s): 2006 DTS 1985 Seville
    Join Date
    Sep 2013
    Location
    SW Washington
    Posts
    18
    Thread Starter

    Re: Motor mount going bad?

    1st top bolt of torque strut
    cad1 (1).jpg
    Rear torque strut bolt with brace.
    rsz_cad2.jpg
    Brace bolt that attaches on top of torque strut rear
    rsz_cad5.jpg
    10mm bolt on overflow tank
    rsz_1cad4.jpg
    2nd 10mm bolt on overflow tank. Remove these 2 bolts and you can easily pull out the torque strut and have clearance.
    rsz_cad3.jpg

  10. #9
    ltdltc's Avatar
    ltdltc is offline Cadillac Owners Fanatic
    Automobile(s): 2010 CTS4 Performance Sport Wagon
    Join Date
    Jun 2003
    Location
    MA
    Age
    33
    Posts
    438

    Re: Motor mount going bad?

    Quote Originally Posted by beauimpala View Post
    I don't know why somebody said you have to take the wheel off and the splash gaurd. It can easily be done all on the top. There were 2 bolts actually holding the mount in place. Then I removoed 2 10mm bolts holding the coolant expansion tank down. When these 2 nuts were removed it gave me plenty of clearance to remove the torque strut out of there and install the new one. There was one other cross brace holding the actual torque strut down and that is a brace located just above expansion tank. Took me about 20 minutes to remove the 3 nuts and 2 bolts and replace the new one.
    That was me I was thinking of the serpentine belt replacement. With that you need to remove the wheel and inner splash shield.

    Edited my post so no one gets bad info.

    beauimpala likes this.

  11. #10
    tjwhite721's Avatar
    tjwhite721 is offline Cadillac Owners Fanatic
    Automobile(s): 2006 Cadillac DTS, 1999 Cadillac Seville
    Join Date
    Jul 2008
    Location
    Bloomsburg,PA
    Posts
    240

    Re: Motor mount going bad?

    Quote Originally Posted by ltdltc View Post
    You need to unbolt the coolant expansion tank. Once you unmount the expansion tank you can unbolt that torque strut.

    Mine was cracked but still seemed to be doing its job. I had a vibration and it was the lower engine mount and once replaced the vibration ceased.
    Do you mean the rear engine mount, trans mount, or front mount that you changed as well?

  12. #11
    Glen773 is offline Cadillac Owners Member
    Automobile(s): 2007 DTS
    Join Date
    Oct 2014
    Location
    KY
    Age
    59
    Posts
    12

    Re: Motor mount going bad?

    What is the right name for the torque strut in the first post? I need one and have found 3 different names for it. I have found a "front, left, and rear. I found one at RockAuto.com that looks like it and they call it the right one. I need the one on the right side of the car on top of the engine.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting