Weird problem - Page 3
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 3 of 6 FirstFirst 1 2 3 4 5 6 LastLast
Results 31 to 45 of 87
Like Tree4Likes
Cadillac DTS Forum - 2006 through 2012 Discussion, Weird problem in Past Cadillac Vehicle Discussion; all that might be better taking it to the dlr at least you will find the problem 1st shot you ...
  1. #31
    BIGDADDYCADDY07 is offline Cadillac Owners Fanatic
    Automobile(s): 07 dts 1986 fleetwood brougham d'elegance
    Join Date
    Jun 2011
    Location
    BROCKTON MA
    Posts
    136

    Re: Weird problem

    all that might be better taking it to the dlr at least you will find the problem 1st shot you can go on forever replacing parts that dont need it

  2. #32
    Dadillac's Avatar
    Dadillac is offline Cadillac Owners Connoisseur
    Automobile(s): 2011 Kia Optima SX 2013 Kia Optima SXL
    Join Date
    Nov 2004
    Location
    Woodbridge NJ
    Age
    48
    Posts
    2,779

    Re: Weird problem

    Quote Originally Posted by BIGDADDYCADDY07 View Post
    all that might be better taking it to the dlr at least you will find the problem 1st shot you can go on forever replacing parts that dont need it
    I don't want to sound unappreciative but am I the only person who has read about multiple paid dealer visits due to misdiagnosis and replacing good parts out. I will not consider having a mechanic touch my car until I have done the work listed. Even then I may search more.

    Don

  3. #33
    BIGDADDYCADDY07 is offline Cadillac Owners Fanatic
    Automobile(s): 07 dts 1986 fleetwood brougham d'elegance
    Join Date
    Jun 2011
    Location
    BROCKTON MA
    Posts
    136

    Re: Weird problem

    Quote Originally Posted by Dadillac View Post
    I don't want to sound unappreciative but am I the only person who has read about multiple paid dealer visits due to misdiagnosis and replacing good parts out. I will not consider having a mechanic touch my car until I have done the work listed. Even then I may search more.

    Don
    dont blame you i got some of the same issues but getting kind of tired of it changed all gaskets trottle body cleaned egr still same issues but i know its sonmething stupid and easy just cant seem to place it no your not the only one im the same way..... nice to meet you i had some dlr warranty work done but they were sloppy mechanics go figure

  4. #34
    Dadillac's Avatar
    Dadillac is offline Cadillac Owners Connoisseur
    Automobile(s): 2011 Kia Optima SX 2013 Kia Optima SXL
    Join Date
    Nov 2004
    Location
    Woodbridge NJ
    Age
    48
    Posts
    2,779

    Re: Weird problem

    I figure that at the dealers $115 per hour labor rate I can change out a lot of parts and still be cheaper than what they would charge me to replace the knock sensors and the crank sensor. that job would be three hours minimum. One hour for diagnosis and at least two hours for repairs. So that job alone would run me $500 minimum including parts. I am far less than that into this so far.

    Oh I removed and cleaned the EGR this morning. EGR looked fine and no change with the cleaning. Once the harness arrives (should be by Tuesday) I will do all the other work.

    Don

  5. #35
    mike5514 is offline Cadillac Owners Enthusiast
    Automobile(s): 97sls,06dts
    Join Date
    Jun 2004
    Age
    76
    Posts
    867

    Re: Weird problem

    You might want to check for a vacuum leak if you have a tester that will help. Mike

  6. #36
    Dadillac's Avatar
    Dadillac is offline Cadillac Owners Connoisseur
    Automobile(s): 2011 Kia Optima SX 2013 Kia Optima SXL
    Join Date
    Nov 2004
    Location
    Woodbridge NJ
    Age
    48
    Posts
    2,779

    Re: Weird problem

    I think I am covering the bases for vacuum leaks with the intake overhaul. Aside form the intake the only other vacuum line I see is the brake booster. There doesn't appear to be any of those emissions tubes anywhere. The wiring harness arrived today so I am going to do this job tomorrow morning. Fingers crossed

    Don

  7. #37
    BIGDADDYCADDY07 is offline Cadillac Owners Fanatic
    Automobile(s): 07 dts 1986 fleetwood brougham d'elegance
    Join Date
    Jun 2011
    Location
    BROCKTON MA
    Posts
    136

    Re: Weird problem

    good luck on your mission fingers crossed

  8. #38
    Dadillac's Avatar
    Dadillac is offline Cadillac Owners Connoisseur
    Automobile(s): 2011 Kia Optima SX 2013 Kia Optima SXL
    Join Date
    Nov 2004
    Location
    Woodbridge NJ
    Age
    48
    Posts
    2,779

    Re: Weird problem

    Okay here goes. This morning I removed the intake manifold. Cleaned the mating surfaces and installed new gaskets. Replace the plenum. Replaced both knock sensors, the crankshaft position sensor, the camshaft positiin sensor, replaced the wiring harness for these sensors and thoroughly cleaned the throttle body. Problem solved. Hopefully this isuue doesn't return.

    Don

  9. #39
    Superjim's Avatar
    Superjim is offline Cadillac Owners Connoisseur
    Automobile(s): 2011 DTS Platinum
    Join Date
    Jun 2006
    Location
    Ft. Worth
    Age
    69
    Posts
    4,480

    Re: Weird problem


  10. #40
    Dadillac's Avatar
    Dadillac is offline Cadillac Owners Connoisseur
    Automobile(s): 2011 Kia Optima SX 2013 Kia Optima SXL
    Join Date
    Nov 2004
    Location
    Woodbridge NJ
    Age
    48
    Posts
    2,779

    Re: Weird problem

    So this morning I am driving to breakfast and I notice my issue is still there. But it is way less than before. Before it would "surge" about every ten seconds or so. Now it is sporadic at best. When I say surge I mean a drivetrain surge not an engine surge. The RPM's do not raise when this is happening. If anything the RPM's might be dropping a little. But it isn't visual on the tach. So I decided to clean the MAF since I hadn't done that. After cleaning still no change. So the only thing I am left with is maybe an injector issue or maybe a transmission issue. I might just bring the car to my local $$$$dealer$$$$ to get a diagnosis done.

    Don

  11. #41
    BIGDADDYCADDY07 is offline Cadillac Owners Fanatic
    Automobile(s): 07 dts 1986 fleetwood brougham d'elegance
    Join Date
    Jun 2011
    Location
    BROCKTON MA
    Posts
    136

    Re: Weird problem

    Quote Originally Posted by Dadillac View Post
    Okay here goes. This morning I removed the intake manifold. Cleaned the mating surfaces and installed new gaskets. Replace the plenum. Replaced both knock sensors, the crankshaft position sensor, the camshaft positiin sensor, replaced the wiring harness for these sensors and thoroughly cleaned the throttle body. Problem solved. Hopefully this isuue doesn't return.

    Don
    so what do you think it was causing your problem/?

  12. #42
    danog is offline Cadillac Owners Fanatic
    Automobile(s): 1936 cadillac 05 deville 08 DTS
    Join Date
    Nov 2011
    Posts
    254

    Re: Weird problem

    Don

    Can your scanner do IAC counts, throttle angle? Check the IAC counts, throttle angle and map cold and hot. Match them up.
    If the IAC counts and map are high or throttle angle is open excessively in comparison this may be a result of high engine load
    and a torque converter and or stator support shaft may be a problem.

    Can your scanner read trans temp. The trans oil cooler outlet line (the upper one to the rad cooler)
    Is it real hot also do you loss of power when it happens?

    One other thing have you done a Crankshaft Position Variation Learn?

  13. #43
    Dadillac's Avatar
    Dadillac is offline Cadillac Owners Connoisseur
    Automobile(s): 2011 Kia Optima SX 2013 Kia Optima SXL
    Join Date
    Nov 2004
    Location
    Woodbridge NJ
    Age
    48
    Posts
    2,779

    Re: Weird problem

    Unfortunately my scanner doesn't cover those. I read up on the crankshaft position sensor learn procedure and it basically said to let the car idle for a bit, wide open throttle it until the cut off kicks in, and let it idle a bit before turning the engine off. I did this with my '02 Seville a long time ago and never had an issue with the sensors. So I assume all is well with that. I hate to do it but I think the dealer is my only hope. I would buy new injectors and see if they fix it but the cheapest price I found was about $30 apiece. If it is an injector I would assume the dealer will be able to pinpoint which one it is. Plus I guess they can make the Tech 2 force the sensors to do what they do. And if that doesn't work then I guess it would be a bad part. I will sleep on this and figure out what action I should take. I definitely will not be taking the car to the dealer before Saturday

    Don

    ----------

    Oh and I do not lose power at all. Aside from the issue the car runs as it should. The issue is only at idle. Once the throttle is pressed all is well again. Even when I am driving at speed and I lift off the throttle I do not feel any issue

    Don

  14. #44
    Cadillac Cust Svc's Avatar
    Cadillac Cust Svc is online now Cadillac Customer Service
    Automobile(s): All Cadillac vehicles!
    Join Date
    Mar 2010
    Location
    Michigan
    Posts
    11,329

    Re: Weird problem

    Quote Originally Posted by Dadillac View Post
    So this morning I am driving to breakfast and I notice my issue is still there. But it is way less than before. Before it would "surge" about every ten seconds or so. Now it is sporadic at best. When I say surge I mean a drivetrain surge not an engine surge. The RPM's do not raise when this is happening. If anything the RPM's might be dropping a little. But it isn't visual on the tach. So I decided to clean the MAF since I hadn't done that. After cleaning still no change. So the only thing I am left with is maybe an injector issue or maybe a transmission issue. I might just bring the car to my local $$$$dealer$$$$ to get a diagnosis done.

    Don
    Hello Don,

    Sorry your vehicle is experiencing issues still. Please keep us updated with your vehicle progress and if there are questions you have, reach out to us via private message.

    Regards,

    Laura M.
    Cadillac Customer Service

  15. #45
    Dadillac's Avatar
    Dadillac is offline Cadillac Owners Connoisseur
    Automobile(s): 2011 Kia Optima SX 2013 Kia Optima SXL
    Join Date
    Nov 2004
    Location
    Woodbridge NJ
    Age
    48
    Posts
    2,779

    Re: Weird problem

    I have changed everything but the throttle body gasket. The throttle body is mounted to the crossover. Does coolant run through the throttle body? Is there a possibility that the gasket is shot and allowing some coolant into the engine? Just a thought

    Don

    ----------

    Okay after seeing the throttle body gasket my idea seems ridiculous. But I guess that changing the gasket may not be a bad idea. It just might be the cheap thing that has been causing the issue. I always seem to forget the cheap simple things. I will update after the install

    Don

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting