1979 Coupe Problems
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 20
Cadillac DeVille 1985 to 2005 including:
1985-1992 Fleetwood, 1993 Sixty Special, All FWD Forum Discussion, 1979 Coupe Problems in Past Cadillac Vehicle Discussion; Ok here is my question. What is the Oil Capicity of the 425 engines? I am asking cause I see ...
  1. #1
    ceddyb30 is offline Cadillac Owners Member
    Join Date
    Jun 2003
    Location
    Rancho Cucamonga
    Age
    42
    Posts
    20

    1979 Coupe Problems

    Ok here is my question. What is the Oil Capicity of the 425 engines? I am asking cause I see on my dipstick that it says 4 quarts. Now I went to WalMart and had them do an oil Change they put 4.5 quarts of oil and a bottle of Slick 50. Now I have blown my Rear main Seal and need to know if 4 quarts is right so I can go after em.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    MMNineInchNails's Avatar
    MMNineInchNails is offline Cadillac Owners Enthusiast
    Join Date
    Jul 2003
    Location
    San Clemente, CA
    Age
    27
    Posts
    989

    Re: 1979 Coupe Problems

    they probably put 4.5 quarts so the oil filter could fill up. The oil filter is a big one. The seal always goes out. Both my cars have a leaking rear main seal. The nissan has been replaced a few times, but it's age and milage that does it. I hvae a new rear main seal on the seat of the caddy so I'm going to replace it too. I don't think walmart did it. Anyways why did you go to walmart to get your oil changed anyways?

  4. #3
    ceddyb30 is offline Cadillac Owners Member
    Join Date
    Jun 2003
    Location
    Rancho Cucamonga
    Age
    42
    Posts
    20
    Thread Starter

    Re: 1979 Coupe Problems

    just happened to be there. I think my piston ring is blown got to get a new motor

  5. #4
    RBraczyk's Avatar
    RBraczyk is offline Cadillac Owners Connoisseur
    Join Date
    Jan 2004
    Location
    Amherst, NH
    Age
    27
    Posts
    4,178

    Re: 1979 Coupe Problems

    you can replace the ring yourself, you need to to open the motor up and find out which ring it is on which piston.

  6. #5
    MMNineInchNails's Avatar
    MMNineInchNails is offline Cadillac Owners Enthusiast
    Join Date
    Jul 2003
    Location
    San Clemente, CA
    Age
    27
    Posts
    989

    Re: 1979 Coupe Problems

    wait what? it's your rear main seal or you piston ring? which are you talking about

  7. #6
    inmycadillac's Avatar
    inmycadillac is offline Cadillac Owners Enthusiast
    Automobile(s): 06 DTS Luxury II-?, 98 Eldorado-Crimson Pearl
    Join Date
    Jan 2004
    Location
    North Dakota
    Age
    37
    Posts
    511

    Re: 1979 Coupe Problems

    I had a 79 Deville, 425, and it holds 4.5 quarts. My rear seal leaked as well. Never seen a Cad around those years that don't leak.

  8. #7
    brougham is offline Cadillac Owners Master
    Automobile(s): 1991 Cadillac Brougham D'Elegance 5.7 Litre
    Join Date
    Jun 2003
    Location
    Canada
    Posts
    5,642

    Re: 1979 Coupe Problems

    Quote Originally Posted by MMNineInchNails
    wait what? it's your rear main seal or you piston ring? which are you talking about
    That's what I was wondering.

    If you got a piston right problem you're right about getting a new motor. Either that or getting yours rebuilt. You don't juwst start throwing new parts like that in an engine

  9. #8
    ceddyb30 is offline Cadillac Owners Member
    Join Date
    Jun 2003
    Location
    Rancho Cucamonga
    Age
    42
    Posts
    20
    Thread Starter

    Wink Re: 1979 Coupe Problems

    It is both. I bought the car 2 months ago guy had all the seals replaced. (got Recipts on it). Then last week I was driving and felt the pressure like my Cat was clogged but it is not new cat. I took it to the shop and they said it dropped 2 quarts of oil.I changed the oil messing around and saw oil coming up through the Air cleaner as well as shooting out of the back hitting the flywheel. I am looking to put a new engine in it maybe a 350 or another 425. any suggestions?

  10. #9
    inmycadillac's Avatar
    inmycadillac is offline Cadillac Owners Enthusiast
    Automobile(s): 06 DTS Luxury II-?, 98 Eldorado-Crimson Pearl
    Join Date
    Jan 2004
    Location
    North Dakota
    Age
    37
    Posts
    511

    Talking Re: 1979 Coupe Problems

    Quote Originally Posted by ceddyb30
    It is both. I bought the car 2 months ago guy had all the seals replaced. (got Recipts on it). Then last week I was driving and felt the pressure like my Cat was clogged but it is not new cat. I took it to the shop and they said it dropped 2 quarts of oil.I changed the oil messing around and saw oil coming up through the Air cleaner as well as shooting out of the back hitting the flywheel. I am looking to put a new engine in it maybe a 350 or another 425. any suggestions?
    Is the rest of the car in good shape? Thats too bad that happened right after buying it . Those engines are a dime a dozen tho so you should be allright. Better luck this time.:coolgleam

  11. #10
    ceddyb30 is offline Cadillac Owners Member
    Join Date
    Jun 2003
    Location
    Rancho Cucamonga
    Age
    42
    Posts
    20
    Thread Starter

    Re: 1979 Coupe Problems

    The car is in good shape to be 25 years old. I need a paint job and a new hat for the top. I have not figured out if I am going to put a new hat on it or just leave it as a hard top yet. Got to buy the fillers in the back. Looking for metal so if anyuone knows where to get em let me know. and the Interior is better then my 1985 Deville which needs an engine as well. will go get an 4.5 for that one as well.

  12. #11
    ceddyb30 is offline Cadillac Owners Member
    Join Date
    Jun 2003
    Location
    Rancho Cucamonga
    Age
    42
    Posts
    20
    Thread Starter

    Re: 1979 Coupe Problems

    I was lucky. Found a Used 425 for 450. And i am getting it put in for 550 so it is not to bad will see what happens when it gets done.

  13. #12
    inmycadillac's Avatar
    inmycadillac is offline Cadillac Owners Enthusiast
    Automobile(s): 06 DTS Luxury II-?, 98 Eldorado-Crimson Pearl
    Join Date
    Jan 2004
    Location
    North Dakota
    Age
    37
    Posts
    511

    Re: 1979 Coupe Problems

    Quote Originally Posted by ceddyb30
    I was lucky. Found a Used 425 for 450. And i am getting it put in for 550 so it is not to bad will see what happens when it gets done.
    Good Luck.

  14. #13
    ceddyb30 is offline Cadillac Owners Member
    Join Date
    Jun 2003
    Location
    Rancho Cucamonga
    Age
    42
    Posts
    20
    Thread Starter

    Re: 1979 Coupe Problems

    Well here I go again. Got the engine put in and runs cool but Carb is messed up will have to have it rebuilt. The Fuel pump or something is not reading the gas in the tank have no clue worked before they changed the engine. Bad water pump have to get a new one then everythiong should work well. LOL I cant win for losing but will soon.....

  15. #14
    MMNineInchNails's Avatar
    MMNineInchNails is offline Cadillac Owners Enthusiast
    Join Date
    Jul 2003
    Location
    San Clemente, CA
    Age
    27
    Posts
    989

    Re: 1979 Coupe Problems

    Does the fuel gauge read empty all the time? If so it's most likely your float having a pin hole in it. What are the conditions of the carb acting up? Not getting enough fuel, out of tune, flooding, etc.?

  16. #15
    ceddyb30 is offline Cadillac Owners Member
    Join Date
    Jun 2003
    Location
    Rancho Cucamonga
    Age
    42
    Posts
    20
    Thread Starter

    Re: 1979 Coupe Problems

    Ok here I go guys slowly getting there. I replaced the Carb (good thing) Car still runs rough though and now I cant get a strong enough current in my system to put the electric choke on the Carb so it idles like I am a Drag racer at the stop light. I have to set the timing should make it run better change the Oil out of the car and run some type of additive. Got the Water Pump on that was a good thing cause it is getting hot out here in So Cal. The Fuel gauge was a blown fuse replaced it and it works now. The Carb was old and when I replaced it it is now saving me gas go figure. Will post more next week when I get my Electrical looked at.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting