Bad Loss of power - 2003 Deville
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 8 of 8
Cadillac DeVille 1985 to 2005 including:
1985-1992 Fleetwood, 1993 Sixty Special, All FWD Forum Discussion, Bad Loss of power - 2003 Deville in Past Cadillac Vehicle Discussion; Over the last week especially, I'm experiencing very slow acceleration to the point where as thou , I'm having a ...
  1. #1
    cadillac griff is offline Cadillac Owners Fanatic
    Automobile(s): Deville 03
    Join Date
    Aug 2013
    Location
    Baltimore
    Posts
    177

    Bad Loss of power - 2003 Deville

    Over the last week especially, I'm experiencing very slow acceleration to the point where as thou , I'm having a hard time goin from 2-4 gear! Even with my foot all the way down on the pedal ! Checked codes n got PCM 0410 n a rfa code which I discovered was for tire sensor ! Will a misfired spark plug show up on the dash! ? Thx


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    maeng9981's Avatar
    maeng9981 is offline Cadillac Owners Connoisseur
    Automobile(s): 14 SRX, 00 SLS, 99 Deville 50-year Anniversary
    Join Date
    Mar 2009
    Location
    Dallas, TX
    Age
    25
    Posts
    3,993

    Re: Bad Loss of power

    Yes, a misfire will be detected by the PCM and will set P0300. A misfire would be obvious to feel though.

    If you are not able to speed up above certain point, you might be dealing with a clogged CAT. Clogged one doesn't always set codes. It's a very wild guess though.

  4. #3
    Submariner409's Avatar
    Submariner409 is offline If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS - 67,500 miles, 2014 Explorer XLT FWD
    Join Date
    Feb 2006
    Location
    MD Eastern Shore, Kent Island
    Age
    77
    Posts
    57,174

    Re: Bad Loss of power

    Disconnect the exhaust system at the 4-bolt flange at the flex section. Wire it out of the way and go for a (loud) drive. Better performance ??? Clogged cat (from snake oil and slow driving). Replace it with either a Walker weld-on or an Eastern Catalytic direct fit model.

    The P 0410 says there's something going on with the A.I.R. system (emissions problem). Here in Maryland that's an emissions fail.

  5. Remove Advertisements
    Cadillac Forums
    Advertisements
     

  6. #4
    Ranger's Avatar
    Ranger is online now Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    69
    Posts
    82,396

    Re: Bad Loss of power

    I'm putt'in my money on the CAT.

  7. #5
    cadillac griff is offline Cadillac Owners Fanatic
    Automobile(s): Deville 03
    Join Date
    Aug 2013
    Location
    Baltimore
    Posts
    177
    Thread Starter
    While just on my way home, my car couldn't pick up speed whatsoever , I really mashed it this time n the speed started decreasing! While on the side of the road an officer pulled over n offered to follow so I did that(surprisingly) lol... But when I started to make my way home , the car started goin ape chit! Lots of hesitation n jerking , took forever to get to 50mph... Despite all that I finally made it n went to mr tire where they said 117 for the diagnostic... Oh hold on that's s Northstar, oh no we don't mess with them, smh! But my car is parked now at my house n I checked the codes again n still PCM p0410 is all I got! Plz help !!!!! Oh yea, n did I mention as I was headed home that infamous glass shattering pop coming from the regulator but that's light right now, I'm more concerned bout not being able to drive!

  8. #6
    Submariner409's Avatar
    Submariner409 is offline If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS - 67,500 miles, 2014 Explorer XLT FWD
    Join Date
    Feb 2006
    Location
    MD Eastern Shore, Kent Island
    Age
    77
    Posts
    57,174

    Re: Bad Loss of power

    Do as advised in posts 2,3,4 - disconnect the cat at the flex pipe and see if that "fixes" the problem. If so, clogged cat.

    EDIT: Please define "glass shattering pop from the regulator".

  9. #7
    cadillac griff is offline Cadillac Owners Fanatic
    Automobile(s): Deville 03
    Join Date
    Aug 2013
    Location
    Baltimore
    Posts
    177
    Thread Starter
    Will do thx

  10. #8
    maeng9981's Avatar
    maeng9981 is offline Cadillac Owners Connoisseur
    Automobile(s): 14 SRX, 00 SLS, 99 Deville 50-year Anniversary
    Join Date
    Mar 2009
    Location
    Dallas, TX
    Age
    25
    Posts
    3,993

    Re: Bad Loss of power

    Quote Originally Posted by Submariner409 View Post
    EDIT: Please define "glass shattering pop from the regulator".
    That has to be the infamous pop 'n drop windows.

  11. Remove Advertisements
    Cadillac Forums
    Advertisements
     

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

What Cadillac(s) do you own? (Or type NONE)

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •