1997 deville 4.6 northstar EBTCM problem need assistance please
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 3 of 3
Cadillac DeVille 1985 to 2005 including:
1985-1992 Fleetwood, 1993 Sixty Special, All FWD Forum Discussion, 1997 deville 4.6 northstar EBTCM problem need assistance please in Past Cadillac Vehicle Discussion; K now this mite e a very dumb question but I am getting a no TCS data when I try ...
  1. #1
    pucci420 is offline Cadillac Owners Member
    Automobile(s): 1997 Deville
    Join Date
    Jan 2014
    Location
    None
    Posts
    22

    1997 deville 4.6 northstar EBTCM problem need assistance please

    K now this mite e a very dumb question but I am getting a no TCS data when I try and pull codes so I was just gonna replace the ebtcm because I am at a loss and believe it needs replacing, so now here the stupid question, do I need to purchase a ebtcm ,for a 1997 deville 4.6 L, that has an "active brake control" or do I need to purchase one without it??? Sorry first caddy and leaning as I go but mechanically inclined! Thanks so much for the response or any input at all is greatly appreciated thanks

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    rodnok01's Avatar
    rodnok01 is online now Cadillac Owners Connoisseur
    Automobile(s): 98 DeVille, 97 DeVille d'Elegance
    Join Date
    Feb 2012
    Location
    NC
    Posts
    4,225

    Re: 1997 deville 4.6 northstar EBTCM problem need assistance please

    Have you tried disconnecting and reconnecting the connections at EBTCM? sometimes they corrode.

  4. #3
    pucci420 is offline Cadillac Owners Member
    Automobile(s): 1997 Deville
    Join Date
    Jan 2014
    Location
    None
    Posts
    22
    Thread Starter
    No I havnt, u think that is a possibility cuz for awhile it was giving me c1225 code am eventually it just went to no tcs data so, but I will try that, should I spray some electronic cleaner u think too, how does that come out u lift the tab and then just pull the connector out correct???

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting