Electrical Problem
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 3 of 3
Cadillac DeVille 1985 to 2005 including:
1985-1992 Fleetwood, 1993 Sixty Special, All FWD Forum Discussion, Electrical Problem in Past Cadillac Vehicle Discussion; I have a 1993 Cadillac Deville Sixty Special... Under the hood there are max fuses. The one that goes to ...
  1. #1
    Bryson City is offline Cadillac Owners Member
    Automobile(s): 1993 sedan Deville Sixty Special
    Join Date
    Mar 2014
    Posts
    2

    QuestionElectrical Problem

    I have a 1993 Cadillac Deville Sixty Special... Under the hood there are max fuses. The one that goes to the ignition switch is a 60 amp. When you go to crank the car, it blows that fuse. Any suggestions for a fix?


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    77CDV's Avatar
    77CDV is offline Cadillac Owners 10000+ Posts
    Automobile(s): 77 CDV, 06 DTS III, 69 FWB
    Join Date
    Mar 2006
    Location
    Newbury Park, CA
    Age
    45
    Posts
    10,022

    Re: Electrical Problem

    Love those 89-93 Sixty Specials! You may want to post your question in the FWD section for a better response to your problem, or a moderator will likely be along soon to move it for you. Good luck with your problem! Hope it get's sorted out quick!

  4. #3
    basscatt's Avatar
    basscatt is offline Cadillac Owners 10000+ Posts
    Automobile(s): 2003 DHS - two-2002 DHS's, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
    Join Date
    Feb 2004
    Location
    Minnesota
    Age
    65
    Posts
    15,850

    Re: Electrical Problem

    Quote Originally Posted by Bryson City View Post
    I have a 1993 Cadillac Deville Sixty Special... Under the hood there are max fuses. The one that goes to the ignition switch is a 60 amp. When you go to crank the car, it blows that fuse. Any suggestions for a fix?
    --------------------

    does it blow when you go to the ON position -

    OR does it blow JUST when you go to the START position?

    if it blows immediately in START position -
    it could be a bad starter switch -
    or a bad starter -
    more likely a dead short at the starter solenoid -

  5. Remove Advertisements
    Cadillac Forums
    Advertisements
     

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

What Cadillac(s) do you own? (Or type NONE)

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •