Charging System
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By MoistCabbage
Cadillac DeVille 1985 to 2005 including:
1985-1992 Fleetwood, 1993 Sixty Special, All FWD Forum Discussion, Charging System in Past Cadillac Vehicle Discussion; We have a 1996 Cadillac DeVille and it has a frustrating charging system error. When the issue started, the car ...
  1. #1
    Caddy96Deville is offline Cadillac Owners Member
    Automobile(s): 1996 Cadillac Deville
    Join Date
    Oct 2013
    Posts
    3

    Charging System

    We have a 1996 Cadillac DeVille and it has a frustrating charging system error. When the issue started, the car would start fine cold, and the volts would fluctuate between 10.6 and 13.8. As the car would heat up, the charging system error would display and the car would almost die. We would pull over and it would slowly charge back up again while idling. Drive would cause that cycle to repeat.

    We took it to AZone to have the alternator tested, as well as the battery. The batter tested fine and they charged it back up. The alternator had diode issues so we replaced it. We assumed that would solve the issue, but now it's WORSE.

    After we replaced the alternator, cleaned the battery posts, checked the battery wires, and put everything back together, the car now drains the battery entirely.

    If anyone has any insight, we would really appreciate it.

    Thank you.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Submariner409's Avatar
    Submariner409 is offline If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,279

    Re: Charging System

    Hmmmmmm........... Use the proper model/year section of the sticky thread just above this one - "How to pull codes" from your car's built-in code reader/scanner/memory. Get any stored DTCs , return to the sticky and open the link to OBD-II (OBD2) diagnostic code definitions. Post the codes, whether each is Current or History, and the definitions here.

    Either some electrical connector is bad, a cable terminal is bad, or there's a faulty module (there are MANY) controlling something that has gone haywire.

    Normal indicated system voltage should be between 14.0 - 14.8 volts, normal engine speeds, normal electrical loads. Perhaps somewhat less at idle.

    Even with the battery test, don't rule out a dead cell. Will the battery hold some charge after being idle for 3 - 5 days ?

  4. #3
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,033
    Is the new alternator a Duralast?
    bigm57ict likes this.

  5. #4
    brougham is offline Cadillac Owners Master
    Automobile(s): 1991 Cadillac Brougham D'Elegance 5.7 Litre
    Join Date
    Jun 2003
    Location
    Canada
    Posts
    5,479

    Re: Charging System

    How old is the battery? Charging problems can kill a battery especially if it isn't new. Did you get the new alternator checked? Just because it's new doesn't mean it's good.

  6. #5
    Caddy96Deville is offline Cadillac Owners Member
    Automobile(s): 1996 Cadillac Deville
    Join Date
    Oct 2013
    Posts
    3

    Re: Charging System

    We spent the day working on this!! We took it back to have everything tested. The battery is new- January 2013. I do not recall the make of it but it wasn't the cheap one- we made sure we purchased a good one that they recommended. The cleaned all the posts again with a scrub brush, replaced the battery cables (positive and negative), tested the alt again and it's still good. We hooked up the code reader hoping something would show up... nothing. It literally showed no codes.

    On the way home we got a new message that said "Battery No Charge". I find this strange because the volts still jump around between 11.2 and 13.8. It spiked up to 14.3 when we cleaned the posts but quickly returned to the lower ranges.

    Could this be ground wire issues?

  7. #6
    Caddy96Deville is offline Cadillac Owners Member
    Automobile(s): 1996 Cadillac Deville
    Join Date
    Oct 2013
    Posts
    3

    Re: Charging System

    duralast gold battery, but ultima alternator

  8. #7
    reppinshadyvill is offline Cadillac Owners Fanatic
    Automobile(s): 2003 DTS
    Join Date
    Nov 2012
    Location
    Central FL
    Age
    31
    Posts
    163
    Sounds like a loose/intermittent connection to an alternator or a dying alternator to me. I would check your connections to the alternator. Did you install it yourself?

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting