'99 DeVille Sound system not working correctly/ Remote unlock control not working
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 17
Cadillac DeVille 1985 to 2005 including:
1985-1992 Fleetwood, 1993 Sixty Special, All FWD Forum Discussion, '99 DeVille Sound system not working correctly/ Remote unlock control not working in Past Cadillac Vehicle Discussion; Hello all. I am new here and have just bought a 1999 Cadillac DeVille d'Elegance about 5 months ago. I ...
  1. #1
    FabodaReal's Avatar
    FabodaReal is offline Cadillac Owners Member
    Automobile(s): 1999 Cadillac DeVille d'Elegance
    Join Date
    Aug 2013
    Location
    Tucson AZ
    Age
    23
    Posts
    8

    Unhappy '99 DeVille Sound system not working correctly/ Remote unlock control not working

    Hello all. I am new here and have just bought a 1999 Cadillac DeVille d'Elegance about 5 months ago. I have been trying to get it working as good as possibable. It belonged to a young couple who had bought it off a old lady. The old lady hardly used it and the dude I bought it off of had like 5 kids who kind of messed up the back area of the car(not too much though, It still looks really new for the year other then a few things broken, ig the AC vent grill in the back, the fold down mirrors the lights do not work right) Anyways, I have been having problems with my sound system. As I am new to owning a Cadillac I do not know much about them, but I do not think i have a Bose sound system... The speakers in the back say Delco electronics on the magnets. It does have the middle dashboard speaker though and it is the only one that works as well as the two back speakers by the back window. The door speakers do not work at all, although when I first got the car they would turn on and work perfectly after the car had been driven around for about 30 min and then once the car was turned off and the key removed they would not work anymore untill the car was driven again for a while. I have even took the back panel in the trunk off and unpluged all the wires off the BCM and the Audio amp in the car and checked all the fuses and relays. They are all fine. I've checked for broken wires and none of them are messed up. I cannot for the life of me find out the probelm. I have even taken the stereo out and unpluged it and blew in the connections and still just the middle speaker in the top of the dash and the two back speakers work. Money is kinda tight so I cant just take it in somewhere to have it fixed. I am not really good with cars but I can work my way around if i need to. And another thing is my remote unlock does not work. I have changed batterys multiple times and once in a while the gas cap button opens it up and the trunk but only when it wants will it unlock or lock the doors. I dont know if its the remote function actuation module (I didnt see one in the car but I know the Seville has one in the trunk) works or it is something else. How can I get all my door speakers working and my doors unlocking all the time with the key beeper? Any help would help me. Thank you.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    SUPER LAC DEVILLE's Avatar
    SUPER LAC DEVILLE is offline Cadillac Owners Enthusiast
    Automobile(s): 1998 Cadillac Deville
    Join Date
    Aug 2012
    Location
    Tampa Florida
    Age
    36
    Posts
    822

    Re: '99 DeVille Sound system not working correctly/ Remote unlock control not working

    Quote Originally Posted by FabodaReal View Post
    Hello all. I am new here and have just bought a 1999 Cadillac DeVille d'Elegance about 5 months ago. I have been trying to get it working as good as possibable. It belonged to a young couple who had bought it off a old lady. The old lady hardly used it and the dude I bought it off of had like 5 kids who kind of messed up the back area of the car(not too much though, It still looks really new for the year other then a few things broken, ig the AC vent grill in the back, the fold down mirrors the lights do not work right) Anyways, I have been having problems with my sound system. As I am new to owning a Cadillac I do not know much about them, but I do not think i have a Bose sound system... The speakers in the back say Delco electronics on the magnets. It does have the middle dashboard speaker though and it is the only one that works as well as the two back speakers by the back window. The door speakers do not work at all, although when I first got the car they would turn on and work perfectly after the car had been driven around for about 30 min and then once the car was turned off and the key removed they would not work anymore untill the car was driven again for a while. I have even took the back panel in the trunk off and unpluged all the wires off the BCM and the Audio amp in the car and checked all the fuses and relays. They are all fine. I've checked for broken wires and none of them are messed up. I cannot for the life of me find out the probelm. I have even taken the stereo out and unpluged it and blew in the connections and still just the middle speaker in the top of the dash and the two back speakers work. Money is kinda tight so I cant just take it in somewhere to have it fixed. I am not really good with cars but I can work my way around if i need to. And another thing is my remote unlock does not work. I have changed batterys multiple times and once in a while the gas cap button opens it up and the trunk but only when it wants will it unlock or lock the doors. I dont know if its the remote function actuation module (I didnt see one in the car but I know the Seville has one in the trunk) works or it is something else. How can I get all my door speakers working and my doors unlocking all the time with the key beeper? Any help would help me. Thank you.
    to me

    this sounds like the HU has some issues with its audio board
    but dont quote me on that... if all speakers work at some point, i say it the HU
    You may need to get another and have it "flashed" with ur VIN

  4. #3
    FabodaReal's Avatar
    FabodaReal is offline Cadillac Owners Member
    Automobile(s): 1999 Cadillac DeVille d'Elegance
    Join Date
    Aug 2013
    Location
    Tucson AZ
    Age
    23
    Posts
    8
    Thread Starter

    Re: '99 DeVille Sound system not working correctly/ Remote unlock control not working

    The HU is in the trunk correct? I unpluged everything in the trunk in back of the black panel and re-pluged everything in, I took out every fuse and checked it and put it back as well and now my car will not start. It makes a clicking sound when i try to start it. I dont know it this has anything to do with the fact that i unpluged everything and pluged it back in but I cannot get my car started now for nothing. I even changed the battery and it is still not starting. The lights in the inside are dim and they turn off after about 30 seconds. I think i might of messed up the Body control module PZM of something? Can that be possible? I have a BCM from a 97(i think) Seville. Can they be switched out just like that or will I need to call up a service center or something. Please help because I have Drs appointments tomorrow and all next week and I cant get my car started.

    ----------

    I have been having problems with my sound system in my 99 Cadillac DeVille so I took the liberty of going in the trunk and unplugging all the wires and fuses from behind the black panel, blew the connections to make sure there was no dust in them, then repluged them in after a couple minutes and I left my car on in accessory with the radio on while I went inside for about 5 min and when I went outside I tried to start the car to go somewhere and it would not start at all. It just makes a clicking sound and the lights dim. My stereo wont even turn on, or if it does it just lights up but without sound to the speakers. I'm not sure if I messed up the Body control module PZM or something else. All the fuses are good and I suspect all the relays are as well. Please help me!

  5. #4
    SUPER LAC DEVILLE's Avatar
    SUPER LAC DEVILLE is offline Cadillac Owners Enthusiast
    Automobile(s): 1998 Cadillac Deville
    Join Date
    Aug 2012
    Location
    Tampa Florida
    Age
    36
    Posts
    822
    Everything u describe sounds normal except your battery is dead

    the "H.U." (Head Unit) is your Radio... But what u jus described indicates a dead battery so ur gonna have issues with electrical systems when there's low voltage

    Check your battery terminals n make sure they're tight.
    Charge your battery or get a jump from someone.
    U may need a new battery but check ur volts by pressing the info button on the IC (instrument cluster) til u see volts, I think it should say 12.5 with the car Not running and around 14.4 Running

    Bad positive and ground connections can cause many problems so make sure they're good

    Also, ur gonna have a whole lot of history codes bc u were disconnecting and reconnecting fuses and stuff... So when u check for codes ur gonna want to Clear all of them then recheck them for Current ones... That's gonna have to be after u get a new battery or get the one u have charged up

    If u have an aftermarket HU, ur gonna have issues bc these Devilles don't like there electrical systems to be messed with

  6. #5
    FabodaReal's Avatar
    FabodaReal is offline Cadillac Owners Member
    Automobile(s): 1999 Cadillac DeVille d'Elegance
    Join Date
    Aug 2013
    Location
    Tucson AZ
    Age
    23
    Posts
    8
    Thread Starter

    Re: '99 DeVille Sound system not working correctly/ Remote unlock control not working

    Well my battery was working just perfect (correct readings and everything) just before I started messing with the wires and fuses in the trunk. The last I noticed was the volts 9.5 then went down to 8 then 6 then the car shut off (It never fully started though, just in accessory) I've even changed battery's with one of my other cars and nothing seems to work. I'm thinking that maybe I messed up the Body control module? Is that possible? I did unplug it as well as everything else in the trunk then re-plug it without first unplugging the battery... Will that cause the BCM to reset or not work? I cant seem to roll the windows down ether.. My HU is factory original theft lock, I don't understand the process of changing it due to the fact I've read I still need to keep the factory installed one in the car somehow... but I did remove it yesterday and unplugged it while the car was in accessory, then remembered the car was on so I turned it off and reconnected the stereo.i did that to see if there was any wires loose back there so my door speakers would work but no, the wires were fine. Can it be both batterys are dead or is there something we're both missing on this? I just need to know if its my battery or something else in the trunk..

  7. #6
    SUPER LAC DEVILLE's Avatar
    SUPER LAC DEVILLE is offline Cadillac Owners Enthusiast
    Automobile(s): 1998 Cadillac Deville
    Join Date
    Aug 2012
    Location
    Tampa Florida
    Age
    36
    Posts
    822
    Without a KNOWN good battery, we can't go any further and really I don't know where else u can go... 9.5volts is a DEAD battery, I can't say about the other one

    The Battery is more often than not supposed to be disconnected before working on electrical systems bc Yes u can fry stuff,,, BUT with a dead battery, not to sure u could do much damage

    You need to get a Battery U Know is Good FULLY CHARGED bc u can't do anything as far as diagnosing without it

    U can run ur codes but again, without a good battery you Could get a lot of false positives

    Ur built in Code Scanner is the IC (instrument cluster) get a pen and paper for this...

    Hold your warm and off buttons for 4seconds
    Everything will flash and look crazy
    It will begin to scroll codes out to u
    Write them down and postm here with definitions

    go here to learn how to get codes and definitions
    http://www.cadillacforums.com/forums...odes-dtcs.html

  8. #7
    FabodaReal's Avatar
    FabodaReal is offline Cadillac Owners Member
    Automobile(s): 1999 Cadillac DeVille d'Elegance
    Join Date
    Aug 2013
    Location
    Tucson AZ
    Age
    23
    Posts
    8
    Thread Starter

    Re: '99 DeVille Sound system not working correctly/ Remote unlock control not working

    Thank you very much for telling me how to get the codes. I have to wait till my neighbor comes home so I can ask for a ride to the local autozone. Until then Im stuck with the dead car (Battery) The thing that confuses me and makes me think maybe I messed something up is the fact that the battery was working perfectly fine before. But I guess it can die just like that. Thank you and when I get it charged I will pull codes and post them.

  9. #8
    SUPER LAC DEVILLE's Avatar
    SUPER LAC DEVILLE is offline Cadillac Owners Enthusiast
    Automobile(s): 1998 Cadillac Deville
    Join Date
    Aug 2012
    Location
    Tampa Florida
    Age
    36
    Posts
    822

    Re: '99 DeVille Sound system not working correctly/ Remote unlock control not working

    Quote Originally Posted by FabodaReal View Post
    Thank you very much for telling me how to get the codes. I have to wait till my neighbor comes home so I can ask for a ride to the local autozone. Until then Im stuck with the dead car (Battery) The thing that confuses me and makes me think maybe I messed something up is the fact that the battery was working perfectly fine before. But I guess it can die just like that. Thank you and when I get it charged I will pull codes and post them.
    you prolly used its last bit of juice when it was working... thats why i say get a jump from someone to see if the car will start AND if the battery is getting a charge when running... Remember to hit the info button to select battery volts when u Go to Start the car... U will see it increase if the alternator is charging the battery... But remember that doesn't mean the battery will stay charged... if the cells are dead, th,th,that's all folks

    Don't know where ur at but Walmart caries the 78s series battery and may be cheaper the your local Advance or Auto Zone... if ur in cold climates u need the 750cca(cold cranking amps) battery but the 78s 650cca will be fine if ur typically in warmer climates

    .....................
    edit,

    jus checked ur profile, ur in Arizona so the 650cca battery will work fine for u

  10. #9
    FabodaReal's Avatar
    FabodaReal is offline Cadillac Owners Member
    Automobile(s): 1999 Cadillac DeVille d'Elegance
    Join Date
    Aug 2013
    Location
    Tucson AZ
    Age
    23
    Posts
    8
    Thread Starter

    Re: '99 DeVille Sound system not working correctly/ Remote unlock control not working

    Alright thank you. Matter of fact I took in my old batt from my old non running car and they replaced it. The Caddy batt and the other one were both bad. So they replaced the one from my old car for free (I had warranty still) So I came back home right now and pluged it in RUNNING CAR!!! Now I'm going to pull codes. I will post them as soon as I get them. Thank for your help. BTW The volts read 13.8 running and 12.4 off. Its a brand new battery so looks like I'ma be good for a while and + its still covered under warranty if it dies again.

    ----------

    Alright I pulled the codes and there were no current codes being displayed. Only History codes. I cleared them all and Will be checking again tomorrow or the next day to see if any new ones appear. Everything seems to be working fine and the car is starting and everything just fine. Hopefully it stays that way. I will keep you updated. I still havnt resolved my first problems though... ONly the middle dashboard speakers and the two back dash speakers work and my remote unlock beeper is still not working despite having changed the batterys. I thought my caddy had a remote function actuation module but I didnt fine one. Any help on those topics would be greatly appreciated. Thanks once again for everythnig else you helped me solve.

  11. #10
    SUPER LAC DEVILLE's Avatar
    SUPER LAC DEVILLE is offline Cadillac Owners Enthusiast
    Automobile(s): 1998 Cadillac Deville
    Join Date
    Aug 2012
    Location
    Tampa Florida
    Age
    36
    Posts
    822
    Ok good

    U may have a bad HU

    The remote needs to be reprogrammed by a dealership unless ur IC will let u program it thru the RFA section in the IC... I haven't ever read any success with that option so you'll probably have to take it to the dealership

  12. #11
    FabodaReal's Avatar
    FabodaReal is offline Cadillac Owners Member
    Automobile(s): 1999 Cadillac DeVille d'Elegance
    Join Date
    Aug 2013
    Location
    Tucson AZ
    Age
    23
    Posts
    8
    Thread Starter

    Re: '99 DeVille Sound system not working correctly/ Remote unlock control not working

    It never seemed to give me problems. I think it was just all the messing around I was doing with the wires and fuses that killed the batt. But I will keep my eye on it. So far its not giving me any codes so thats great. I'm not really familiar with the terms Ic or RFA could you elaborate a little more on those subjects please?

    ----------

    I misunderstood your last post. Maybe the HU is bad... But could it also be the Audio Amplifier in the trunk that has gone bad? If I want to say, put in a non factory stereo in my car (I have the wire and dash kit, the wire kit is just the adapter and the dash kit is just the double DIN converter to Single DIN) Will it affect my car and the ability to drive it normally daily or is there other things that will need to be purchased in order to make it work? I don't want to just do it and have it mess up my car or something, I'd rather ask first. Thanks again.

  13. #12
    SUPER LAC DEVILLE's Avatar
    SUPER LAC DEVILLE is offline Cadillac Owners Enthusiast
    Automobile(s): 1998 Cadillac Deville
    Join Date
    Aug 2012
    Location
    Tampa Florida
    Age
    36
    Posts
    822
    Yes it will affect your car

    The radio is "married" to the car

    But u can make an aftermarket work

    I will post a link to the thread later... I'm at work

    You can remove the amp
    Mine was removed and my speakers work fine so that's an option to Consider

  14. #13
    SUPER LAC DEVILLE's Avatar
    SUPER LAC DEVILLE is offline Cadillac Owners Enthusiast
    Automobile(s): 1998 Cadillac Deville
    Join Date
    Aug 2012
    Location
    Tampa Florida
    Age
    36
    Posts
    822

    Re: '99 DeVille Sound system not working correctly/ Remote unlock control not working

    this thread has been around for a while... unfortunately the pics were recently removed
    http://www.cadillacforums.com/forums...ll-photos.html

    heres another, tho i dont remember ever reading this all the way thru
    http://www.cadillacforums.com/forums/cadillac-audio-video-security-systems/198172-1999-deville-aftermarket-stereo-installation.html

    T
    his wont be an easy undertaking if u decide to install an aftermarket radio... i personally use a cassette adapter hooked to my ipad or iphone and stream music via my clear wireless hotspot... i had an aftermarket radio... but took it out due to the side effects

    "I'm not really familiar with the terms Ic or RFA could you elaborate a little more on those subjects please?"

    Somewhat,

    IC is your Instrument Cluster, or DIC (Driver Information Center) thats where u see all your info and where u can run your codes...
    RFA (Remote Function Actuation) is a section u can select to run those specific codes on your IC... from what ive read, some people have had luck programming their own remote, but it didnt work for me so i doubt it will for u ...http://www.cadillacforums.com/forums...ob-1998-a.html

    h
    ate to not have all the easy answers but youll soon learn that the Cadillac you own isnt an easy machine

  15. #14
    FabodaReal's Avatar
    FabodaReal is offline Cadillac Owners Member
    Automobile(s): 1999 Cadillac DeVille d'Elegance
    Join Date
    Aug 2013
    Location
    Tucson AZ
    Age
    23
    Posts
    8
    Thread Starter

    Re: '99 DeVille Sound system not working correctly/ Remote unlock control not working

    Thanks, But I've realized that unless I get a professional to install the aftermarket HU I'ma just leave it alone. I've had it working with all door speakers working when I drove the car yesterday for about an hour and it lasted until last night even when I would turn off the car. I think it only works when the amp gets hot or something. This morning was not successful. It went back to just the middle speaker again.... HOW TO FIX THIS... Its starting to make me want to rip the stereo out and just sing or rap when I'm driving. (NOT LITERALLY LOL)
    And about trying to program the fob, it does not show the option to override the settings like it shows on the '97 DeVille. I read farther on to different websites and even called a locksmith and they told me there is no way at all for me to program it by myself unless I had about $700 of tolls and a code programmer to do it myself. I called around and the lowest I found to have it programmed was about $30. So I'm going to just have to shell out the money to have that done.

  16. #15
    SUPER LAC DEVILLE's Avatar
    SUPER LAC DEVILLE is offline Cadillac Owners Enthusiast
    Automobile(s): 1998 Cadillac Deville
    Join Date
    Aug 2012
    Location
    Tampa Florida
    Age
    36
    Posts
    822

    Re: '99 DeVille Sound system not working correctly/ Remote unlock control not working

    Quote Originally Posted by FabodaReal View Post
    Thanks, But I've realized that unless I get a professional to install the aftermarket HU I'ma just leave it alone. I've had it working with all door speakers working when I drove the car yesterday for about an hour and it lasted until last night even when I would turn off the car. I think it only works when the amp gets hot or something. This morning was not successful. It went back to just the middle speaker again.... HOW TO FIX THIS... Its starting to make me want to rip the stereo out and just sing or rap when I'm driving. (NOT LITERALLY LOL)
    And about trying to program the fob, it does not show the option to override the settings like it shows on the '97 DeVille. I read farther on to different websites and even called a locksmith and they told me there is no way at all for me to program it by myself unless I had about $700 of tolls and a code programmer to do it myself. I called around and the lowest I found to have it programmed was about $30. So I'm going to just have to shell out the money to have that done.
    "they told me there is no way at all for me to program it by myself unless I had about $700 of tools and a code programmer to do it myself."

    Don't go to them to have it done,,, they obviously have no idea what they're talking about except for maybe the scanner/programmer which is called a GM Tech2, and yeah, they're expensive... ive seen them as high as $3,000 but as low as $350/$400; my friend Basscatt http://www.cadillacforums.com/forums/member.php?u=7515
    gave me these links sometime ago

    $389 with free shipping - -http://www.aliexpress.com/item/2012-....html#feedback

    $374 with free shipping - http://www.dhgate.com/product/gm-tec...127774219.html
    be sure you get the GM - ENGLISH chip -

    "HOW TO FIX THIS"

    im not really sure what the problem is with the speakers, but i think we've narrowed it down to either the amp or head unit... personally i would take the amp out of the equasion but im not sure that will work... i would suggest you start the car, turn on the radio and "play" with the amp wires to see if there's a bad ground or other wire leading to or from the amp, if the rear dash 6x9's come on or off while you're playing with the wires then try and fix those wires or remove the amp and use just the head unit, which has enough power to push those speakers... if its the HU, which i really doubt, you'll have to get a replacement and have it programmed with your cars VIN, Another trip to the dealership and about $45... u can find one on ebay or in the junk yard but if u have to go that route then u might be interested in the cd/cassette version http://www.ebay.com/itm/Cadilac-1998...42b9b7&vxp=mtr

    "But I've realized that unless I get a professional to install the aftermarket HU I'ma just leave it alone."

    Dont waste your time, or Money, its rare that any "Pro" Installer has any experience with the Deville, tho they'll certainly tell you they do... its unlikely they have any knowledge about its Link to the security and electrical systems... They can do a chop it up install and "Make" it work, but i can promise you, you'll start to have other issues within a day or a week and youll wanna jus Rip it back out

    "Its starting to make me want to rip the stereo out and just sing or rap when I'm driving."
    Sometimes i just listen to my car while driving...

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting