Need Help ASAP! Dont wanna send it to the crusher!!
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 27
Like Tree1Likes
Cadillac DeVille 1985 to 2005 including:
1985-1992 Fleetwood, 1993 Sixty Special, All FWD Forum Discussion, Need Help ASAP! Dont wanna send it to the crusher!! in Past Cadillac Vehicle Discussion; 99 deville 160k cranks and will only start every once in a while but doesnt stay running back fires sometimes ...
  1. #1
    POS-DEVILLE is offline Cadillac Owners Member
    Automobile(s): 99 Deville
    Join Date
    Mar 2013
    Age
    29
    Posts
    10

    Need Help ASAP! Dont wanna send it to the crusher!!

    99 deville 160k

    cranks and will only start every once in a while but doesnt stay running back fires sometimes out of intake pressure valve
    already tried:
    new battery
    new fuel pressure regulator
    new fuel filter
    new fuel pump
    new maf sensor
    new air temp sensor
    new plugs/wires
    new fuel relay
    different ecu/pcm
    holding gas pedal to floor
    clearing history codes
    checked all wiring
    checked all vacuum lines
    timing chains are good
    timing is on mark
    all ground are good




    has thrown codes for MAF when it does run for 30 sec even after checking wiring/new sensor/ and new air temp

    what else am i missing?!

    any help is appreciated

    cars way too clean to just throw away but $1000000 later its taking a toll on me!

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    98eldo32v's Avatar
    98eldo32v is offline Cadillac Owners Connoisseur
    Automobile(s): 98 eldo/KD54 w/N37,T96,QA1,D55,DS3,U1Z. U3R next
    Join Date
    Apr 2010
    Posts
    1,882

    Re: Need Help ASAP! Dont wanna send it to the crusher!!

    check 02 sensors...........

  4. #3
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,533
    Bad O2 sensors aren't going to keep the engine from starting.

    What codes are you getting?

  5. #4
    98eldo32v's Avatar
    98eldo32v is offline Cadillac Owners Connoisseur
    Automobile(s): 98 eldo/KD54 w/N37,T96,QA1,D55,DS3,U1Z. U3R next
    Join Date
    Apr 2010
    Posts
    1,882

    Re: Need Help ASAP! Dont wanna send it to the crusher!!

    Bad O2 sensor will keep an engine from running.......

    "cranks and will only start every once in a while but doesnt stay running"

  6. #5
    SGWORLDWIDE's Avatar
    SGWORLDWIDE is offline Cadillac Owners Enthusiast
    Automobile(s): 04 Deville DTS (Sold)
    Join Date
    Dec 2012
    Age
    26
    Posts
    734

    Re: Need Help ASAP! Dont wanna send it to the crusher!!

    I would not junk it after all that money put in
    98eldo32v and 98eldo32v like this.

  7. #6
    POS-DEVILLE is offline Cadillac Owners Member
    Automobile(s): 99 Deville
    Join Date
    Mar 2013
    Age
    29
    Posts
    10

    Re: Need Help ASAP! Dont wanna send it to the crusher!!

    Quote Originally Posted by MoistCabbage View Post
    Bad O2 sensors aren't going to keep the engine from starting.

    What codes are you getting?
    No codes on crank, when it does start (every few days or so after cranking for what seems to be hours) it says check MAF performance only code that shows up

  8. #7
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,533
    Bad O2 sensors won't cause a no start, or stalling.

    How thorough were you when checking for vacuum leaks?

    When it doesn't start, is it when hot, cold, or no difference?

    Are the CKP sensors original?

    ----------

    If the MAF is good, and you're still getting codes, the problem is either in the wiring between the MAF and PCM, or the PCM itself.

  9. #8
    POS-DEVILLE is offline Cadillac Owners Member
    Automobile(s): 99 Deville
    Join Date
    Mar 2013
    Age
    29
    Posts
    10

    Re: Need Help ASAP! Dont wanna send it to the crusher!!

    Im not possitive on the ckp sensors i have not changed them myself but this car was a 1 owner dealer queen when i bought it. Would the crank sensors throw a CEL if they were bad?
    Did a full front back side to side vacuum leak test including the intake gasket area with carb cleaner when it did run good.
    It does not matter if its hot cold or anywhere inbetween.
    I have replaced the MAF with 3 different NEW replacements and 1 new to car PCM all wiring from maf plug to pcm is intact and test good with test light.

  10. #9
    SGWORLDWIDE's Avatar
    SGWORLDWIDE is offline Cadillac Owners Enthusiast
    Automobile(s): 04 Deville DTS (Sold)
    Join Date
    Dec 2012
    Age
    26
    Posts
    734

    Re: Need Help ASAP! Dont wanna send it to the crusher!!

    Once u get past a level with the amount of money u put in a car and thats alot u spent (U sure its a million dollars (could of had the engine rebuilt for that and a bugatti ) its a tough call, but if the body and interor are in good shape for me its go all the way or go home but how much u put in makes u think because if your buying another used car your still buying a car with everything old where your car has many new things, thats how i treat my car ill replace everything and anything because i already put more then shes worth in her, and because if i bought another used caddy it would not even compare to mine

  11. #10
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,533
    CKPs should throw codes, but they don't always do.

    Have the injectors been tested? Firing correctly, none sticking or leaking?

  12. #11
    POS-DEVILLE is offline Cadillac Owners Member
    Automobile(s): 99 Deville
    Join Date
    Mar 2013
    Age
    29
    Posts
    10

    Re: Need Help ASAP! Dont wanna send it to the crusher!!

    Injectors were all inspected/cleaned around 150k at the dealer. No excessive fuel in cylinders or on the plugs. Could a weak spark cause it to act this way? The coils are all marked with numbers so im assuming they are original.( i havent seen any replacement ones with the numbers) i could be wrong though.

  13. #12
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,482

    Re: Need Help ASAP! Dont wanna send it to the crusher!!

    With all you have done and all the parts you threw at it, I think it may be time to go back to the basics. Have you verified spark at the plug? Have you verified fuel pressure? if so, what is it?

  14. #13
    POS-DEVILLE is offline Cadillac Owners Member
    Automobile(s): 99 Deville
    Join Date
    Mar 2013
    Age
    29
    Posts
    10

    Re: Need Help ASAP! Dont wanna send it to the crusher!!

    Yes spark on all 8 and fuel pressure with new pump is at 42 psi key on

    ----------

    Decided to go the bad route and tried some starting fluid and still nothing...

  15. #14
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,482

    Re: Need Help ASAP! Dont wanna send it to the crusher!!

    If it will not start with starting fluid it's definitely not fuel related. Either you have no spark, no compression (doubtful) or it's sparking at the wrong time. The only thing missing (and related) from your list of replaced parts is an ICM.

    Oh yeah, CKP and CMP sensors.
    No CKP or CMP sensor codes?

    This might be worth reading if you haven't already.
    http://www.cadillacforums.com/forums...odule-icm.html

  16. #15
    CadillacLuke24's Avatar
    CadillacLuke24 is offline Cadillac Owners Connoisseur
    Automobile(s): Alexandra - 96 SDV
    Join Date
    Jul 2010
    Location
    Middle of Nowhere
    Age
    23
    Posts
    4,841

    Re: Need Help ASAP! Dont wanna send it to the crusher!!

    If you're getting codes for the MAF make damn sure the plug for the MAF (and the plug ON the MAF) are good, clean, and snug. Round up some electrical parts cleaner and double check.

    Could it be the ignition coils? Make sure all 8 are clean. Did you connect the plugs in the right order??

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting