93 Deville acceleration problem
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 17
Cadillac DeVille 1985 to 2005 including:
1985-1992 Fleetwood, 1993 Sixty Special, All FWD Forum Discussion, 93 Deville acceleration problem in Past Cadillac Vehicle Discussion; Hello everyone, I'm having a problem with my Deville. Sometimes it runs great and then it will start to chunk ...
  1. #1
    jeffyjeff is offline Cadillac Owners Member
    Automobile(s): 1993 Sedan Deville
    Join Date
    Dec 2009
    Location
    Detroit, MI
    Age
    61
    Posts
    38

    93 Deville acceleration problem

    Hello everyone,

    I'm having a problem with my Deville. Sometimes it runs great and then it will start to chunk on me. (Feels like some of the cylinders aren't fireing) Then it will run fine again. Doesn't matter how much gas is in the tank or the temperature outside. Sometimes it runs great when I first start it, and at other times it acts up right from the get go. It will also stall once in awhile, and when it does, the gas guage will read a few gallons less then just before it stalls, then the guage will gradually increase as I drive after restarting it. It always starts again after it stalls and seems to run better for awhile, then developes the same problem again. Any ideas people?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    basscatt's Avatar
    basscatt is offline Cadillac Owners Master
    Automobile(s): 89 Coupe DeVille, 95 Sedan DeVille, 03 SLS, two 02 DHS's
    Join Date
    Feb 2004
    Location
    Minnesota
    Age
    63
    Posts
    9,368

    Re: 93 Deville acceleration problem

    Quote Originally Posted by jeffyjeff View Post
    Hello everyone,

    I'm having a problem with my Deville. Sometimes it runs great and then it will start to chunk on me. (Feels like some of the cylinders aren't fireing) Then it will run fine again. Doesn't matter how much gas is in the tank or the temperature outside. Sometimes it runs great when I first start it, and at other times it acts up right from the get go. It will also stall once in awhile, and when it does, the gas guage will read a few gallons less then just before it stalls, then the guage will gradually increase as I drive after restarting it. It always starts again after it stalls and seems to run better for awhile, then developes the same problem again. Any ideas people?
    -------------------
    check for Diagnostic Trouble Codes -

    if you don't know how - go here and read the ENTIRE post -

    http://www.cadillacforums.com/forums...odes-dtcs.html

    if you have any codes - post them here -
    ALONG WITH THEIR DEFINITIONS -
    -------------------
    yours is the OBD - or OBD1 system -

  4. #3
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    72,351

    Re: 93 Deville acceleration problem

    Clogged CAT or low fuel pressure (though neither would affect the fuel gauge)?

  5. #4
    jeffyjeff is offline Cadillac Owners Member
    Automobile(s): 1993 Sedan Deville
    Join Date
    Dec 2009
    Location
    Detroit, MI
    Age
    61
    Posts
    38

    Re: 93 Deville acceleration problem

    Hello viewers,

    I am having my codes viewed on Wed. I will let you know. I'm looking at the fuel pressure angle.

  6. #5
    13ir14314's Avatar
    13ir14314 is offline Cadillac Owners Fanatic
    Automobile(s): 2002 DHS, 1967 Eldorado
    Join Date
    Jan 2012
    Location
    MN, ND
    Age
    19
    Posts
    422
    Why have the codes read when you can do it yourself. Read the sticky at the top of the Deville forum telling you how to pull your own codes.

  7. #6
    basscatt's Avatar
    basscatt is offline Cadillac Owners Master
    Automobile(s): 89 Coupe DeVille, 95 Sedan DeVille, 03 SLS, two 02 DHS's
    Join Date
    Feb 2004
    Location
    Minnesota
    Age
    63
    Posts
    9,368

    Re: 93 Deville acceleration problem

    Quote Originally Posted by jeffyjeff View Post
    Hello viewers,

    I am having my codes viewed on Wed. I will let you know. I'm looking at the fuel pressure angle.
    --------------------
    pulling your own codes takes less than 2 minutes -
    and you don't need anything but the car -

  8. #7
    jeffyjeff is offline Cadillac Owners Member
    Automobile(s): 1993 Sedan Deville
    Join Date
    Dec 2009
    Location
    Detroit, MI
    Age
    61
    Posts
    38

    Re: 93 Deville acceleration problem

    Ok. Thank you very much. I'll try pulling them myself. Do I just turn the ignition to on, or do I start the engine?

  9. #8
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    72,351

    Re: 93 Deville acceleration problem

    Either way will work.

  10. #9
    jeffyjeff is offline Cadillac Owners Member
    Automobile(s): 1993 Sedan Deville
    Join Date
    Dec 2009
    Location
    Detroit, MI
    Age
    61
    Posts
    38

    Re: 93 Deville acceleration problem

    Man they go by fast. I got all kind of P codes. 13, 14, 16, 18, 20, 21, 22, 23, 24, 43, E30, E90, 111, 112, 507 and probably more. How scewed am I?

  11. #10
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    72,351

    Re: 93 Deville acceleration problem

    Help us help you and always post the code definitions along with the codes. No one has them memorized.
    http://myweb.accessus.net/~090/dtcobd1.html

  12. #11
    jeffyjeff is offline Cadillac Owners Member
    Automobile(s): 1993 Sedan Deville
    Join Date
    Dec 2009
    Location
    Detroit, MI
    Age
    61
    Posts
    38

    Re: 93 Deville acceleration problem

    Sorry about that. Will do.

    ----------

    Ok, Here we go. Theses are all P (E) codes 13-right oxygen sensor not ready, 14-shorted coolant temp sensor, 16-voltage out of range (all SOL), 20-open fuel pump circuit, 21-shorted TPS signal, 22-open TPS signal, 23-electronic spark timing (EST) signal problem [EGR], 24-vehicle speed sensor signal to TCC, 30-ISC RPM out of range, 43-left oxygen sensor signal rich, 90-VCC/TCC brake switch/park/neutral switch input circuit problem, and 112-PCM PROM EPROM error. Don't know if all these need to be addressed, I justwant to get it running smooth again. Hope you can help me. I'm still taking it in on Wednesday to have some of the issues addressed. Thank you.

  13. #12
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    72,351

    Re: 93 Deville acceleration problem

    I'd get that voltage issue straightened out first. Low voltage can cause false codes and wreak havoc with the electrical system.

  14. #13
    basscatt's Avatar
    basscatt is offline Cadillac Owners Master
    Automobile(s): 89 Coupe DeVille, 95 Sedan DeVille, 03 SLS, two 02 DHS's
    Join Date
    Feb 2004
    Location
    Minnesota
    Age
    63
    Posts
    9,368

    Re: 93 Deville acceleration problem

    I agree with Ranger -
    have the battery and alternator tested -

    our cars do some mighty strange things if the battery and charging system aren't prefect -

    clear the codes - and see what comes back -

  15. #14
    jeffyjeff is offline Cadillac Owners Member
    Automobile(s): 1993 Sedan Deville
    Join Date
    Dec 2009
    Location
    Detroit, MI
    Age
    61
    Posts
    38

    Re: 93 Deville acceleration problem

    I tested the output from the alternator when I replaced the battery last summer, and I was still having the same problem, but will check again and clear the codes.

  16. #15
    jeffyjeff is offline Cadillac Owners Member
    Automobile(s): 1993 Sedan Deville
    Join Date
    Dec 2009
    Location
    Detroit, MI
    Age
    61
    Posts
    38

    Re: 93 Deville acceleration problem

    To Ranger and Basscatt, I'm having a new ECM put in tomorrow, was causing low voltage to two of the injectors. Hope that is all it's going to need.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting