Finally~ - Page 4
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 4 of 4 FirstFirst 1 2 3 4
Results 46 to 51 of 51
Cadillac DeVille 1985 to 2005 including:
1985-1992 Fleetwood, 1993 Sixty Special, All FWD Forum Discussion, Finally~ in Past Cadillac Vehicle Discussion; Yesterday I jumped in, turned the key and click, just as i was about to get out the car, i ...
  1. #46
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,309

    Re: Finally~

    Yesterday I jumped in, turned the key and click, just as i was about to get out the car, i just turned the key again, it started.
    So now I'm thinking, the fuse pulling was just exercise, the starter is doing the exact same thing the old one did. Multiple key turns to get it to catch. Once it catches it always turns over so how could this be a starter issue?
    Has anyone considered the ignition switch? Not the key cylinder, but the switch on the column farther down.

  2. #47
    97Purlwhyte's Avatar
    97Purlwhyte is offline Cadillac Owners Member
    Automobile(s): 97 Deville N*, 2005 CTS V6
    Join Date
    Feb 2009
    Location
    Miami, FL
    Posts
    97

    Re: Finally~

    Quote Originally Posted by Ranger View Post
    Has anyone considered the ignition switch? Not the key cylinder, but the switch on the column farther down.

    I'm taking it to an electrician today. last night after I picked my son up from school we went to the grocery store... DAMMITT!

    Came out and couldn't start the car... had to ride the damn grocery cart home...LOL!

    My 1st car(t) jacking!

    I have to do soemthing this is breaking my heart... feels like my girl didnt come home lastnight!

    I'll keep ya posted

    Thanks

  3. #48
    99Classillac's Avatar
    99Classillac is offline Cadillac Owners Enthusiast
    Automobile(s): Ex-99 Deville owner, Now-04 DTS and 05 DTS. ZX6R Pilot too.
    Join Date
    Nov 2005
    Location
    Upper Marlboro, MD
    Age
    31
    Posts
    822

    Re: Finally~

    Might be ignition switch. Good catch ranger. My dad's s-10 had that problem.

  4. #49
    97Purlwhyte's Avatar
    97Purlwhyte is offline Cadillac Owners Member
    Automobile(s): 97 Deville N*, 2005 CTS V6
    Join Date
    Feb 2009
    Location
    Miami, FL
    Posts
    97

    Re: Finally~

    Well guess what.. compound problem!

    There was a short in the fuse box (which ignited one morning b4 work) AND a bad starter from EBAY. (Remind me never to do that again...)

    Anyway, the galloping ghost is back on the move..

    Sweet!

    thanks guys for all your input


  5. #50
    OlHump's Avatar
    OlHump is offline Cadillac Owners Member
    Automobile(s): 98 Fleet Limited, 94 Sedan Deville, 78 Fleet, 86 Fleet
    Join Date
    May 2008
    Location
    Richmomd, VA.
    Posts
    18

    Re: Finally~

    Continuing with an added statement; Ranger you really are on top of things. I just repaired my 94 deville which was doing the same exact thing. It was the ignition switch. I finally had it replaced and they also replaced the cylinder. Now, with Purlwhyte's problem; they may have told him it was the fuse box, but I think they replaced the ignition switch which eventually goes to the fuse box. I think this thread should be tagged, because I've read many people having same or simular problems and it would eliminate frustrations to end up with the same solution. Agreed, good catch Ranger.

  6. #51
    97Purlwhyte's Avatar
    97Purlwhyte is offline Cadillac Owners Member
    Automobile(s): 97 Deville N*, 2005 CTS V6
    Join Date
    Feb 2009
    Location
    Miami, FL
    Posts
    97

    Re: Finally~

    Quote Originally Posted by OlHump View Post
    Continuing with an added statement; Ranger you really are on top of things. I just repaired my 94 deville which was doing the same exact thing. It was the ignition switch. I finally had it replaced and they also replaced the cylinder. Now, with Purlwhyte's problem; they may have told him it was the fuse box, but I think they replaced the ignition switch which eventually goes to the fuse box. I think this thread should be tagged, because I've read many people having same or simular problems and it would eliminate frustrations to end up with the same solution. Agreed, good catch Ranger.

    I was there... the fuse box had white smoke coming from it. I had been saying all along that something in the fuse box wasnt right.
    Everytime I pulled fuses the car would work again.. my ignition is untouched and i waitied at the shop for the fuse box and starter to be repaired there was no ignition switch replacement. similar issues.. different fixes.


Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting