Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Page 2 of 2 FirstFirst 12
Results 16 to 22 of 22

Thread: Pinging

  1. #16
    Join Date
    Jan 2003
    Location
    Newtown, PA
    Age
    58
    Posts
    6,472
    Sounds like you found the vacuum reservoir.
    As for the Top-Engine Cleaner, if you did it right, you can rule out carbon build-up as the cause of the "pinging". The timing chain is possible but you should also look into anything that could be causing a "lean" condition, and make sure your EGR system is functional.


  2. #17
    elwesso's Avatar
    elwesso is offline Cadillac Owners Master
    Automobile(s): 2005 CTS-V, 1994 Infiniti Q45
    Join Date
    Jan 2003
    Location
    Indiana
    Posts
    7,661
    Could be possible that none of that stuff was ever checked..... It would be something that needs to be done, but may not change the ping.... I just replaced the air filter FOR THE FIRST TIME today on the fleetwood, it had NEVER been changed after 36k!!! It was black and icky.. Thats what they get for letting a private shop take care of all the maintenance....

    Kat, can i get this TOP ENGINE CLEANER at any cadillac dealership???

  3. #18
    Join Date
    Jan 2003
    Location
    Newtown, PA
    Age
    58
    Posts
    6,472
    Yes sir, you can.

  4. #19
    elwesso's Avatar
    elwesso is offline Cadillac Owners Master
    Automobile(s): 2005 CTS-V, 1994 Infiniti Q45
    Join Date
    Jan 2003
    Location
    Indiana
    Posts
    7,661
    Then I may have to go pick up a can before i take things apart for cleaning . I assume it would effectively clean the plenum and intake manifold too....

  5. #20
    Stoneage_Caddy's Avatar
    Stoneage_Caddy is offline Cadillac Owners 10000+ Posts
    Automobile(s): 01 frontier , 89 Shelby CSX vnt
    Join Date
    May 2003
    Location
    Undisclosed location in FL
    Posts
    14,607
    shoot . did the o2 sensors , i no longer get the intermiottent "service engine soon light" now i get a "service vehicle soon " message on the scrolling display in addition to the "service suspension system" message

    im about give up at this point , im keeping the radio way up and trying find a way to turn off all warnings and drive it , im trying my best to maintin it but im fighting what appears to be a looseing battle..i miss my infiniti

  6. #21
    elwesso's Avatar
    elwesso is offline Cadillac Owners Master
    Automobile(s): 2005 CTS-V, 1994 Infiniti Q45
    Join Date
    Jan 2003
    Location
    Indiana
    Posts
    7,661
    Have you taken it to the dealer yet??? I think, its time

  7. #22
    Stoneage_Caddy's Avatar
    Stoneage_Caddy is offline Cadillac Owners 10000+ Posts
    Automobile(s): 01 frontier , 89 Shelby CSX vnt
    Join Date
    May 2003
    Location
    Undisclosed location in FL
    Posts
    14,607
    yah , im almost at that point , no code for the engine tho , just the damned torque converter ,and a keep alive memory loss

    since id think the torque converter would need replaced ill wait untill the damned converter is laying under the car in two peices

    im kinda thinking it might be the soleniod for it but im not even gonna pull the pan off to do that yet , maybe in a few months when im ready to mess with it again

    i just wish i could resolve the pinging issue

Page 2 of 2 FirstFirst 12

Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum