Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 8 of 8

Thread: Hesitation when put into drive

  1. #1
    simkofab is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Dec 2006
    Location
    Northwest Indiana
    Posts
    50

    Hesitation when put into drive

    Whenever I put the car in drive there is a 2 second delay until the gear is engaged. No problem with reverse. From either park or neutral this happens. It doesn't happen between drive gears. I always wait with my foot on the brake to feel it engage first. My only concern is letting someone else drive it and they hit the gas before it engages. I don't need anyone doing neutral drops, thank you. Any ideas as to what might be causing this?


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Teedoe's Avatar
    Teedoe is offline Cadillac Owners Enthusiast
    Automobile(s): 2003 CTS Base and 2014 Cadillac CTS VSport Premium
    Join Date
    Dec 2009
    Location
    Central Florida
    Posts
    528
    I'm working on the same thing

  4. #3
    Red Dwarf is offline Cadillac Owners Fanatic
    Automobile(s): 2014 SRX
    Join Date
    Feb 2005
    Location
    Sonoma, Calif
    Posts
    136

    Re: Hesitation when put into drive

    Me too. 04 CTS.

  5. #4
    Teedoe's Avatar
    Teedoe is offline Cadillac Owners Enthusiast
    Automobile(s): 2003 CTS Base and 2014 Cadillac CTS VSport Premium
    Join Date
    Dec 2009
    Location
    Central Florida
    Posts
    528

    Re: Hesitation when put into drive

    Anybody know what's causing this delay?

  6. #5
    simkofab is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Dec 2006
    Location
    Northwest Indiana
    Posts
    50

    Re: Hesitation when put into drive

    So does anyone out there know what is causing this?

  7. #6
    Argent1's Avatar
    Argent1 is offline Cadillac Owners Connoisseur
    Automobile(s): '07 CTS 3.6
    Join Date
    Nov 2010
    Posts
    2,937

    Re: Hesitation when put into drive

    Low fluid ? What car, miles etc. etc. Give some details.

  8. #7
    simkofab is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Dec 2006
    Location
    Northwest Indiana
    Posts
    50

    Re: Hesitation when put into drive

    2003 3.2 Base, 1st run. 80,000 miles. ECM replaced. Radiator replaced. Possibly there was enough tranny fluid put back in? Wouldn't I have a problem going into reverse too? Unfortunately I don't recall when this started. I did notice that it goes into gear a little faster when it's cold, but it still hesitates. Obviously I can live with it. My concern is when I let someone use it. I don't want them hitting the gas too soon.

  9. #8
    Teedoe's Avatar
    Teedoe is offline Cadillac Owners Enthusiast
    Automobile(s): 2003 CTS Base and 2014 Cadillac CTS VSport Premium
    Join Date
    Dec 2009
    Location
    Central Florida
    Posts
    528
    It's the tranny. I have an 03 that started with that, then hard shifting, and finally no reverse. I would suggest looking into getting it fixed or replaced.
    I replaced mine with a new tranny and now no symptoms.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum