I Am Having Strange Electrical Maladies - Please Help!
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 12 of 12
Cadillac CTS First Generation Forum - 2003 - 2007 Discussion, I Am Having Strange Electrical Maladies - Please Help! in Cadillac CTS Coupe, Sport Sedan and Sport Wagon Forums; This will be the first actual problem I've had so far with this car, but it's one that concerns me ...
  1. #1
    Chris 78 is offline Cadillac Owners Member
    Automobile(s): '95 Seville SLS 4.6L, '05 CTS 3.6L
    Join Date
    Apr 2013
    Location
    Midwest US
    Age
    36
    Posts
    33

    I Am Having Strange Electrical Maladies - Please Help!

    This will be the first actual problem I've had so far with this car, but it's one that concerns me very greatly. The other night doing some around-town errands I noticed the dash, interior and headlights beginning to rapidly flicker or strobe. This was immediately following stopping to get my neices something at a drive-through (The employee dumped a whole soda in my lap and down into the door, over the controls. Considering the timing, it's worth mentioning although it could be coincidence.) The next time I started the car however, things were much worse... I got Traction Control and Security System warnings on the dash and DIC. I pulled over and stopped to take a look. I decided to take it back to the driveway since I'd only gone about a hundred yards; however I found that on re-starting, the entire dashboard, DIC and nearly all the electrical accessories were dead. I could not take the car out of Park, nor could I extract the key from the ignition! (I should add that the engine did start and idle, perfectly normally) I was completely stuck... even my tools weren't accessible, since I couldn't operate the electric boot-release. I've done some research on these cars and knew about the ECM, so I tried swapping the under-hood fuses (ECM Relay <-> Fog Lamp Relay) and things operated again right away. I still drove directly to a mechanic and had them take a look to see if they could find any evident problems. Unfortunately, they couldn't, although there were a great many error codes (I will post these soon: I forgot to bring the printout to work with me) which they reset. Everything on the car -seems- to be functioning perfectly normally, but needless to say my confidence is badly shaken. Because I have to drive through very heavy city/highway traffic and some extremely dangerous neighborhoods, I'm borrowing a car to commute until I can give the Caddy a thorough round-town test drive. Even still, without at least a rough idea of what's wrong, I worry it will simply happen again and perhaps at a much more dangerous moment.

    My battery is about a year old and as far as I can tell it seems pretty healthy. The car itself is absolutely factory-stock - I don't even use the power ports - so the electrical system shouldn't have any unusual loads placed on it. The only out-of-ordinary things to report are that (1) a fast-food worker dumped soda down into the driver door, though again I do not know if this is related, (2) I am using a new key. However I had this made and programmed at the local Cadillac dealership and it's worked perfectly for over a week now. And finally (3) I had left the boot lid open for a couple of hours immediately before this happened. I'd forgotten to close it after taking some large boxes out... though I have a hard time imagining that this could do much harm to the battery. I frequently operate the radio/DVD with the engine off and it's never been an issue.

    The car is running perfectly again and all codes are cleared (and I will post the ones the mechanic found, when I get home!).

    Any ideas what could cause this kind of trouble? I checked the obvious - loose or corroded terminals, damaged wires, bad relays or evidence of burnt-insulation smell. The battery is eleven months old and looks pristine, as do the terminals. Nothing at all seems out of the ordinary. Could I have a bad ground somewhere? A short in the driver-door electrics? Are ECM failures intermittent or do they simply go down and stay down? The flickering interior/exterior lights mystify me too, as I've not read any cases of that while going through the forum reading up on ECM issues. Could that have triggered the trouble, maybe confused the ECM? I'm afraid I am (no pun intended) very much in the dark when it comes to issues like these. Any advice would be hugely appreciated as I really don't know where to start looking.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    cabletech is offline Cadillac Owners Fanatic
    Automobile(s): 2004 CTS 3.2L M35 LtPt
    Join Date
    May 2010
    Posts
    220

    Re: I Am Having Strange Electrical Maladies - Please Help!

    Soda can do nasty things to electronics. My wife dumped a Diet Coke in her car stereo (I don't ask, I just smile and fix and continue to stay married to her because she's cute). It actually ate away the legs of the amplifier IC inside. That surprised me. I soldered new wiring on to what was left of the amplifier IC and got the front channels working (and that's where it stood until we sold the car).

    So yes, since the door panel contains electronics (there's a door computer in there), I could see how dumping a soda in there could cause shenanigans on either a power circuit or a communications bus. Pull the panel and check everything and clean the gunk out of there. That, and possibly check any wiring under the carpet if possible. That same car had some wiring under the carpet get corroded and cause strange stuff.

  4. #3
    Chris 78 is offline Cadillac Owners Member
    Automobile(s): '95 Seville SLS 4.6L, '05 CTS 3.6L
    Join Date
    Apr 2013
    Location
    Midwest US
    Age
    36
    Posts
    33
    Thread Starter

    Re: I Am Having Strange Electrical Maladies - Please Help!

    I appreciate the reply.

    I didn't expect that there would actually be a computer in the door - odd place for it I would have thought. I've checked the error codes that I mentioned in the original post and they do suggest that perhaps it was a communications failure. I was forced to use the car today because of a family medical emergency and so I couldn't service the door - still getting flickering lights so I'm sure the problem still exists. Hopefully I won't cause additional damage, and the car will get me home so I can clean things out!

    Oh, and for completeness, here are those codes I promised to post:

    P0261 Injector 1 Control Circuit Low Voltage (ECM)
    P0264 Injector 2 Control Circuit Low Voltage (ECM)
    P0267 Injector 3 Control Circuit Low Voltage (ECM)
    P0270 Injector 4 Control Circuit Low Voltage (ECM)
    P0273 Injector 5 Control Circuit Low Voltage (ECM)

    P0458 Evaporative Emission (EVAP) Purge Solenoid Control Circuit Low Voltage (ECM)

    P0628 Fuel Pump Relay Control Circuit Low Voltage (ECM)
    P0691 Cooling Fan Relay 1 Control Circuit Low Voltage (PCM)
    P0693 Cooling Fan Relay 2 Control Circuit Low Voltage (PCM)

    U1000 Class 2 Data Link Malfunction (AMP, ARS, DDM, DDSA, DIM, EBCM, FPDM, HV)

    U1016 Lost Communication With Engine/Powertrain Control Module (ECM/PCM) (AMP, ARS, DDM, DDSA, DIM, EBCM, FPDM, HV)
    U1040 Lost Communication With Electronic Brake Control Module (EBCM) (ECM, IPC, RIM, SDM)
    U1064 Lost Communication With Dash Integration Module (DIM) (AMP, ARS, DDM, DDSA, EBCM, ECM, FPDM, HV)
    U1066 Lost Communication With Rear Integrating Module (RIM) (DDM, FPDM, HVAC, IPC)
    U1088 Lost Communication With Sensing and Diagnostic Module (SDM)

    Thanks again!

  5. #4
    cabletech is offline Cadillac Owners Fanatic
    Automobile(s): 2004 CTS 3.2L M35 LtPt
    Join Date
    May 2010
    Posts
    220

    Re: I Am Having Strange Electrical Maladies - Please Help!

    When you pull the door panel you'll notice a multi-pin connector that goes between the panel and the door itself. I'd almost wager that this connector has gunk in it. Get some q-tips and rubbing alcohol and clean everything well, and then take a look around for anything else.

  6. #5
    Chris 78 is offline Cadillac Owners Member
    Automobile(s): '95 Seville SLS 4.6L, '05 CTS 3.6L
    Join Date
    Apr 2013
    Location
    Midwest US
    Age
    36
    Posts
    33
    Thread Starter

    Re: I Am Having Strange Electrical Maladies - Please Help!

    Sorry for not getting back earlier to say thanks. I got in there, but things looked pretty tidy and so I just ended up cleaning what I could and checking connections. Everything was fine until today - unfortunately it's happening again! This time I was enormously lucky and it broke down right by my house, so I was able to get home... but again, Service Theft System and Traction Control warnings, and no key release. (I saw it coming, so I left it in Neutral and set the brake and chocked the wheels to avoid getting locked in park ) This time something new... I had no power steering! I always just thought that was a purely mechanical bit... obviously not, considering the situation. I've got the car sitting outside and just hoping it sort of clears on its own so I can take it in... but I work an hour away, out of state, in a city. If this thing breaks there (seems inevitable now) I'll really be screwed. There's a dealership around here, but I'm not particularly fond of going there and I'm sure they will really rake me over the monetary coals for something like this.

    I'm flat broke this week, but I absolutely need this car running soon! Is there any way I can diagnose / fix this this kind of problem on my own? As of now there seem to be few options... not sure even what exactly is broken or how I'd begin to troubleshoot such a thing. Any help or advice would be much appreciated.

  7. #6
    Chris 78 is offline Cadillac Owners Member
    Automobile(s): '95 Seville SLS 4.6L, '05 CTS 3.6L
    Join Date
    Apr 2013
    Location
    Midwest US
    Age
    36
    Posts
    33
    Thread Starter

    Re: I Am Having Strange Electrical Maladies - Please Help!

    Update - got it running long enough to take it in. They had a GM-tech there who said the PCM was toast... $980, ouch! Here's hoping that fixed the problem, whatever it was...

  8. #7
    CaptSoloNJ is offline Cadillac Owners Member
    Automobile(s): 2004 CTS and 2014 ATS
    Join Date
    Oct 2012
    Location
    Somerset NJ
    Posts
    58

    Re: I Am Having Strange Electrical Maladies - Please Help!

    Don't rule out a problem with the battery. I previously had another car which started to have strange electrical issues, such as all the warning lights coming on and off while driving down the highway. The computer suddenly reset, all the readouts flashing, the odometer moving forward when the car was standing still, etc.

    One day the car just didn't start, but after the tow truck shoed up, it started. Battery was only 8 months old. It was determined that battery was defective and the plates inside were banging together and separating. Still don't know what that did to cause all the strange electrical issues. However, they replaced the battery under warranty and all the strange actions went away.

  9. #8
    Chris 78 is offline Cadillac Owners Member
    Automobile(s): '95 Seville SLS 4.6L, '05 CTS 3.6L
    Join Date
    Apr 2013
    Location
    Midwest US
    Age
    36
    Posts
    33
    Thread Starter

    Re: I Am Having Strange Electrical Maladies - Please Help!

    To CaptSoloNJ:

    Thanks, I'll look into that. I assume I can go to most parts stores and they'll check it for me? Now that I've gotten a new PCM in there I definitely want to protect this very painful investment. The current battery is 3 years old and seems strong, but I agree with you from experience that sometimes they can be persnickety things.

    Tentatively, things seem better... Right before it failed my interior lights flickered and my DIC battery voltage readings were changing 2/3 times per second, all over the place from ~12 - 15 v. Now at least, the lights shine steadily and the voltage readout stays rock-steady at about 13.8 or so.

  10. #9
    CaptSoloNJ is offline Cadillac Owners Member
    Automobile(s): 2004 CTS and 2014 ATS
    Join Date
    Oct 2012
    Location
    Somerset NJ
    Posts
    58

    Re: I Am Having Strange Electrical Maladies - Please Help!

    Glad to help. With a bad battery, it may short out the new PCM. Having the battery tested to make sure is a small insurance policy. Almost any mechanic can run the test for a cost, and will not charge you if the battery is bad and you need to buy a new one.

  11. #10
    Chris 78 is offline Cadillac Owners Member
    Automobile(s): '95 Seville SLS 4.6L, '05 CTS 3.6L
    Join Date
    Apr 2013
    Location
    Midwest US
    Age
    36
    Posts
    33
    Thread Starter

    Re: I Am Having Strange Electrical Maladies - Please Help!

    Thanks again. I'm going to pop into a local parts place to have it checked and if it's suspect, replaced.

    One more issue! (Since I got the PCM-swap I'm watching everything like a hawk, but I am almost absolutely positive this is a brand-new issue)

    When I'm driving along at night, I can catch the screen for the climate-control flickering. It's rare, perhaps every three minutes or so, and not easy to catch. I parked and waited for it, and it's definitely flickering... just a quick, single blink. All the board's functions work and none of the rest of the lights seem to flicker, and they were -bad- before, so I'm pretty sure that's not it. I'm hoping it's minor (researched source http://www.cadillacforums.com/forums...l-display.html ) as my symptoms are precisely identical. I also read somewhere here that a software fix was out for oil-life, and mine is indeed reset to 100% life remaining. Possible that the mechanic (non-dealership) just used an older software version?

    Basically I'm just scared that the car's computer is threatening to go kaput again. The last thing I want is for whatever blew the first one, to start damaging the new one! The mechanic did mention that he had to remove part of the dashboard and gear-selector to do his checks / repairs and I wonder if it's simply a result of being jostled around.


    Has anyone else who's had ECM/PCM troubles noticed flicker in their climate-control? I'd feel a thousand percent better if I knew this was coincidental or simply something that I hadn't noticed until now.

    Also, if it turns out that a software update really is in order, any ideas what that might cost me?

    Thanks!

  12. #11
    Dominion is offline Cadillac Owners Member
    Automobile(s): 2014 CTS 2.0T
    Join Date
    Jun 2009
    Age
    37
    Posts
    55

    Re: I Am Having Strange Electrical Maladies - Please Help!

    I haven't had any ECM/PCM issues with my '06 but I do notice the occasional flicker of the climate control light. Never really paid much attention to it really. Been like that since I bought it almost 5 years ago.

  13. #12
    Chris 78 is offline Cadillac Owners Member
    Automobile(s): '95 Seville SLS 4.6L, '05 CTS 3.6L
    Join Date
    Apr 2013
    Location
    Midwest US
    Age
    36
    Posts
    33
    Thread Starter

    Re: I Am Having Strange Electrical Maladies - Please Help!

    Cool, thanks Dominion.

    Basically I'm just playing 'better safe than sorry'. If the PCM blew on its own, I'm okay, but I'm just keeping an eye out. If something else -did- blow it out I'd hate for the same thing to get me again.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting