help! power seat issue!
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 3 of 3
Cadillac CTS First Generation Forum - 2003 - 2007 Discussion, help! power seat issue! in Cadillac CTS Coupe, Sport Sedan and Sport Wagon Forums; OK guys I'm new to the site discovered it when I had a timing belt issue, lots of great info! ...
  1. #1
    streetglidecody07's Avatar
    streetglidecody07 is offline Cadillac Owners Member
    Automobile(s): 03 cts
    Join Date
    Aug 2013
    Location
    Norwalk, Ohio
    Posts
    3

    help! power seat issue!

    OK guys I'm new to the site discovered it when I had a timing belt issue, lots of great info! But now I'm having problems with power seat on drivers side. The car is an 03 CTS manual. Everything worked great until two days ago my girlfriend got in to move seat and nothing. When I looked at it the switches have power and I checked fuses under back seat. Problem is when u hit any switch for any seat function u just hear a clicking sound. I looked under seat for pinched wire but can't find anything. However the clicking sound comes from the yellow box under seat which I believe is the memory module. Has any one experienced this or have an idea whats goin on?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    TomV is offline Cadillac Owners Fanatic
    Automobile(s): Cadillac CTS 2003
    Join Date
    Aug 2006
    Location
    Annapolis, MD
    Posts
    144

    Re: help! power seat issue!

    When my 2003 had a seat issue it was the forward-backward direction that was stuck in the far back position. The seatback worked OK as well as the height adjustment. I isolated it to the motor by measuring voltage to the motor. In your case I would venture that it was the mem module since none of the functions are working. You can measure voltages to make sure. Pinched wiring, loose connectors and the like are all reasonable things to look for prior to a mem module replacement. I would even remove power to the module to reset it and then try it again.

  4. #3
    eldoman47 is offline Cadillac Owners Member
    Automobile(s): 99 Eldo ETC & 04 CTS Sport
    Join Date
    Aug 2004
    Location
    Ma.
    Posts
    33
    I have an 04 with same problem.
    Removed seat cushion and taped on forward/reverse motor with small hammer while holding switch in forward,started working again and that was over a year ago.
    Good luck.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting