Motor mount problem? Video included
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 7 of 7
Cadillac CTS First Generation Forum - 2003 - 2007 Discussion, Motor mount problem? Video included in Cadillac CTS Coupe, Sport Sedan and Sport Wagon Forums; Been hearing a clicking noise for a long time and I could never figure it out. It only happens when ...
  1. #1
    hey8you's Avatar
    hey8you is offline Cadillac Owners Fanatic
    Automobile(s): 2005 CTS
    Join Date
    Aug 2009
    Location
    Roseville, Ca
    Age
    36
    Posts
    319

    Motor mount problem? Video included

    Been hearing a clicking noise for a long time and I could never figure it out. It only happens when going over uneven pavement turning left but sometimes makes noise when going over bumps going straight or turning right. Sound is coming from the driver side. Based on searching here, I replaced front driver side upper control arm, driver side lower control arm, front sway bar bushings, front sway bar end links. Unfortunately it did not fix the problem. Lately its been getting worse so after closer inspection, the noise is coming from somewhere between the driver side fender and engine. Please see video below let me know what you think.



    I realize in the video that I rev it higher going into drive than I did in reverse but should the engine move than much?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    ham4864 is offline Cadillac Owners Fanatic
    Join Date
    Feb 2012
    Age
    38
    Posts
    286

    Re: Motor mount problem? Video included

    have you checked all of your mounts and differential bushing

  4. #3
    hey8you's Avatar
    hey8you is offline Cadillac Owners Fanatic
    Automobile(s): 2005 CTS
    Join Date
    Aug 2009
    Location
    Roseville, Ca
    Age
    36
    Posts
    319
    Thread Starter

    Re: Motor mount problem? Video included

    Don't know about the trans mount but the last time I took my CTS in, the dealer said my diff bushing is worn out. I do hear it clunk back there when I change gears sometimes.

  5. #4
    CSTech's Avatar
    CSTech is offline Cadillac Owners Member
    Automobile(s): 04 CTSV
    Join Date
    Jul 2013
    Posts
    26

    Re: Motor mount problem? Video included

    Does the engine "diesel"(Shake back and forth) when you turn off the car? That would be a sign of worn Motor Mounts.
    Jordan @ Creative Steel Inc.

    503-316-1811
    Open M-F 8:00-5:00 PST
    Jordan@creative-steel.com

    Check us out at: http://www.creative-steel.com
    We're on Facebook! https://www.facebook.com/pages/Creat...39612609499435

  6. #5
    hey8you's Avatar
    hey8you is offline Cadillac Owners Fanatic
    Automobile(s): 2005 CTS
    Join Date
    Aug 2009
    Location
    Roseville, Ca
    Age
    36
    Posts
    319
    Thread Starter

    Re: Motor mount problem? Video included

    Quote Originally Posted by CSTech View Post
    Does the engine "diesel"(Shake back and forth) when you turn off the car? That would be a sign of worn Motor Mounts.
    It does.

  7. #6
    arw1510 is offline Cadillac Owners Enthusiast
    Automobile(s): 2004 CTS 3.6, 2004 SRX 4.6 AWD, 2012 CTS 3.6 DI AWD
    Join Date
    Oct 2008
    Posts
    976
    Quote Originally Posted by hey8you View Post

    It does.
    Replace the motor mounts then!

    The other way to check is to open the hood and have someone look while you hold down the brake and hit the gas both in park and then reverse. Then you can see which side is bad, if not both mounts

  8. #7
    arw1510 is offline Cadillac Owners Enthusiast
    Automobile(s): 2004 CTS 3.6, 2004 SRX 4.6 AWD, 2012 CTS 3.6 DI AWD
    Join Date
    Oct 2008
    Posts
    976

    Re: Motor mount problem? Video included

    My 04 engine was jumping higher than yours, I ended up replacing both motor mounts, and the trans mount. I haven't put it through the tests yet, but it seems smoother. The trans moutn was in worse shape then the motor mounts. Neither mount had failed yet, but i doubt they would of lasted through the winter. The trans mount the rubber one torn on one side. who knows. For 200 in parts and 300 in labor I cant really complain, it was twice that to do the SRX

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting