Cts 2003 v6 3.2 changed csp sensor still wont start and code reads po336
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 10 of 10
Cadillac CTS First Generation Forum - 2003 - 2007 Discussion, Cts 2003 v6 3.2 changed csp sensor still wont start and code reads po336 in Cadillac CTS Coupe, Sport Sedan and Sport Wagon Forums; I had a leak in my valve cover gasket so i took care of it. after replacing everything back the ...
  1. #1
    GMASH is offline Cadillac Owners Member
    Automobile(s): 2003 cadillac cts
    Join Date
    Oct 2012
    Location
    MIAMI
    Age
    30
    Posts
    10

    Cts 2003 v6 3.2 changed csp sensor still wont start and code reads po336

    I had a leak in my valve cover gasket so i took care of it. after replacing everything back the way it should be my car wouldnt start! i put it on the computer and it read the code PO336. i've changed my crankshaft position sensor and it still says code PO336 and my car won't start. Im kind of puzzled and stressed at this point. Just before my car was running fine. what should i do now? any suggestions?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    dkozloski's Avatar
    dkozloski is offline Cadillac Owners 10000+ Posts
    Automobile(s): 2006 STS V8 AWD, '95 Ford Ranger
    Join Date
    Jul 2004
    Location
    Fairbanks, Ak
    Age
    74
    Posts
    26,719

    Re: Cts 2003 v6 3.2 changed csp sensor still wont start and code reads po336

    Check for damaged or unplugged wiring in the position sensor circuitry.

    ----------

    Check for damaged or unplugged wiring in the position sensor circuitry. It sounds like mechanic induced damage associated with the gasket replacement.
    Don't mess with Binky Bear!


  4. #3
    wmillar is offline Cadillac Owners Fanatic
    Automobile(s): 2008 CTS DI F3 Sport Suspension
    Join Date
    Aug 2003
    Location
    North Texas
    Age
    70
    Posts
    103
    I'm thinking the same thing you have pulled one of the wires loose or didn't get it in place quite right. I would be looking for the coil pack wiring on the back of the motor just because it looks like that it is plugged in it may not be making proper contact.

  5. #4
    GMASH is offline Cadillac Owners Member
    Automobile(s): 2003 cadillac cts
    Join Date
    Oct 2012
    Location
    MIAMI
    Age
    30
    Posts
    10

    Re: Cts 2003 v6 3.2 changed csp sensor still wont start and code reads po336

    that's exactly what i will do today....

  6. #5
    GMASH is offline Cadillac Owners Member
    Automobile(s): 2003 cadillac cts
    Join Date
    Oct 2012
    Location
    MIAMI
    Age
    30
    Posts
    10

    Re: Cts 2003 v6 3.2 changed csp sensor still wont start and code reads po336

    after checking everything I realized I have oil leaking into the timing case... im trying to remove the cover but have no idea on how to take off the crankshaft pulley.... the star bolt that's there I have no idea how to take off or what tool to use,, do you know?

  7. #6
    stoveguyy is offline Cadillac Owners Connoisseur
    Automobile(s): 03 STS
    Join Date
    Aug 2007
    Location
    mpls mn
    Posts
    2,494
    Star bolt? You mean Torx? You need a Torx socket I assume. I just got a Torx socket set. They are referred too as E-sockets. I think my crank bolt was E20 but that is big. About .700" across flats. My balancer on 3.0 motor which is Opel variant has 6 smaller Torx bolts you removed. Like taking the lugnuts of a wheel. They are smaller. E12 or E14.

  8. #7
    CTSUK's Avatar
    CTSUK is offline Cadillac Owners Enthusiast
    Automobile(s): 2005 Cadillac CTS 3.6 Sport Luxury
    Join Date
    May 2012
    Location
    United Kingdom
    Age
    33
    Posts
    737

    Re: Cts 2003 v6 3.2 changed csp sensor still wont start and code reads po336

    Potential causes of a P0336 code include:
    Bad crank sensor (cant be this if you bought new)
    Broken reluctor ring (missing teeth, debris lodged in ring) (possible)
    Reluctor ring dislodged/stripped from it's stationary location (also possible)
    Wiring harness chafing causing short (worth doing a continuity test between the pins, do not have the battery connected when you do this, if you wiggle the wire and it changes from infinite to 1 and back again (depending on your meter that is whatever it shows when nothing is connected)
    Wiring open in CKP circuit (again continuity test should tell you this, if the figure does not move from its start point before connecting, the wiring is open, test both pins and also to ground of chassis to be sure which one it might be that is open)

  9. #8
    big fern is offline Cadillac Owners Member
    Join Date
    Feb 2012
    Posts
    2
    What you Ned to do is get your Carr worm then tern it off for 30 sec then turn the key with out turning on the Carr for 1 min turn the key back of then turn the Carr on and remove the trovel cod. You must re program the trotel body and this is how

    ----------

    To tell you the troth I think that u didn't sit your coil pack right one of your rubbers if not all did not go in strait with your spark plugs

  10. #9
    cabletech is offline Cadillac Owners Fanatic
    Automobile(s): 2004 CTS 3.2L M35 LtPt
    Join Date
    May 2010
    Posts
    220

    Re: Cts 2003 v6 3.2 changed csp sensor still wont start and code reads po336

    If you look back through my posts, you'll see I had no end of Crank Position Sensor codes. (I put 3 sensors in over the span of a year). It wasn't the crank position sensor.

    I ended up changing the cam position sensor and the timing belt. Once I did that, I have not seen any more Crank Position Sensor codes. You might try the cam position sensor first... it's easy to change (drivers' side head, right on top) and cheap.

  11. #10
    GMASH is offline Cadillac Owners Member
    Automobile(s): 2003 cadillac cts
    Join Date
    Oct 2012
    Location
    MIAMI
    Age
    30
    Posts
    10

    Re: Cts 2003 v6 3.2 changed csp sensor still wont start and code reads po336

    Well after trying everything I finally found out the car wasn't getting any GAS! How do I know this? I check the Schrader valve and none came out. so I replaced the fuel filter, FPR, and still no gas in the line... Being too fast I jumped str8 to dropping the fuel tank and replaced the pump, Still no GAS... I checked all electrical wires and relays and found out that my fuel pump is not getting any power from the relay but I can hear the relay clicking... I've swapped out relays and still no power! the wires have continuity so I see nothing wrong there. My last result before taking it to the dealer is to swap out the ignition switch and hope its my problem hoping my computer isn't damaged.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting