Bank 1 Emission problems, Techies please help!!!
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 6 of 6
Cadillac CTS First Generation Forum - 2003 - 2007 Discussion, Bank 1 Emission problems, Techies please help!!! in Cadillac CTS Coupe, Sport Sedan and Sport Wagon Forums; 2006 CTS w/2.8 automatic. 124000 miles. About 8 months ago it was throwing a P0420 code and I was looking ...
  1. #1
    Freeflyer is offline Cadillac Owners Member
    Automobile(s): 2000 Escalade, 2006 CTS, 2008 SRX
    Join Date
    Jan 2010
    Location
    Georgetown Texas
    Posts
    26

    Bank 1 Emission problems, Techies please help!!!

    2006 CTS w/2.8 automatic. 124000 miles.

    About 8 months ago it was throwing a P0420 code and I was looking at bank 1(passenger side) with Torque app on my phone. Saw the downstream O2 sensor going crazy so I ordered one and replaced it. No change. I then ordered the upstream O2 sensor and replaced it. It is no longer throwing the P0420 code but now I am getting a P2231 AND P0036 code.

    I am not sure if it was happening before all the work but I just noticed that the Commanded Air/Fuel Ratio and the Measured Air/Fuel Ratio has a split of about 13:1.
    And I am getting NO readings from the Long Term Fuel Trim or Short Term Fuel Trim Bank 1 but I am getting readings from the Bank 2.

    Cat temperatures are good.
    Attached Images

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    sandalet's Avatar
    sandalet is offline Cadillac Owners Enthusiast
    Automobile(s): CTS-2003, 3.2 automatic
    Join Date
    Nov 2011
    Location
    Chechnya, Grozny-City
    Age
    37
    Posts
    578

    Re: Bank 1 Emission problems, Techies please help!!!

    In vain you trust Elm-327, this thing is very often gives non-existent error codes. If the "check engine" does not signal - enjoy your ride.

  4. #3
    Freeflyer is offline Cadillac Owners Member
    Automobile(s): 2000 Escalade, 2006 CTS, 2008 SRX
    Join Date
    Jan 2010
    Location
    Georgetown Texas
    Posts
    26
    Thread Starter

    Re: Bank 1 Emission problems, Techies please help!!!

    Well I have never once had a problem using Torque to diagnose and repair any of my cars or my friends cars. The codes are legitimate and the "check engine" light does come on.

    So I am curious, with your disdain for elm-327 can you enlighten me with the alternative?

  5. #4
    sandalet's Avatar
    sandalet is offline Cadillac Owners Enthusiast
    Automobile(s): CTS-2003, 3.2 automatic
    Join Date
    Nov 2011
    Location
    Chechnya, Grozny-City
    Age
    37
    Posts
    578

    Re: Bank 1 Emission problems, Techies please help!!!

    Most recently, Elm-327 issued to my friend the error code P0043 HO2S Heater Control Circuit Low (Bank 1 Sensor 3). However, the list DTС no such code for the 2006 CTS. However, the dealership scanner Teсh2 determined the complete absence of errors in the ECM. However, my friend spent a lot of money trying to fix this error code. Russian motorists have a saying, "Do not disturb the machine to work")))

  6. #5
    Freeflyer is offline Cadillac Owners Member
    Automobile(s): 2000 Escalade, 2006 CTS, 2008 SRX
    Join Date
    Jan 2010
    Location
    Georgetown Texas
    Posts
    26
    Thread Starter

    Re: Bank 1 Emission problems, Techies please help!!!

    Well thanks for trying to help. But its a real problem with a real code.

  7. #6
    Freeflyer is offline Cadillac Owners Member
    Automobile(s): 2000 Escalade, 2006 CTS, 2008 SRX
    Join Date
    Jan 2010
    Location
    Georgetown Texas
    Posts
    26
    Thread Starter

    Re: Bank 1 Emission problems, Techies please help!!!

    Well its looking like everything on bank 1 is not working correctly.

    Anyone have any advice or help?

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting