Not the alternator?....
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 5 of 5
Cadillac CTS First Generation Forum - 2003 - 2007 Discussion, Not the alternator?.... in Cadillac CTS Coupe, Sport Sedan and Sport Wagon Forums; Hello all, new to the forums here and hoping someone can provide some insight for me. The other month I ...
  1. #1
    Thomask is offline Cadillac Owners Member
    Automobile(s): 2003 CTS sport/lux.
    Join Date
    May 2013
    Posts
    2

    Exclamation Not the alternator?....

    Hello all,

    new to the forums here and hoping someone can provide some insight for me.

    The other month I was driving my 2003 cts (sport/lux pkg) and the warning for "low voltage" poped up on my screen. Now, in january I just had a brand new battery put in the car when I had my inspection done and as well I only have 73K miles on the car.

    My bro-in-law is a mechanics teacher at a tech school in my area so I let him take the car to have him look in to it (always works on my cars, has over 15 yrs of mechanic experience).

    He thought it was the alternator so we swapped mine out for a brand new one.

    I picked the car up and from the school went straight to Home depot, and then walmart with no issues. After walmart I was on my way home (trip so far since pick up was maybe 5 miles) and while sitting at a red light, out of nowhere I noticed my car lost power steering and had the car turned off). I tried to restart but had no luck. Fortunately a couple of people got out of their cars and help me push the car into a parking lot (I was on a very, very busy road).

    Immediately I thought that my bro-in-laws class had messed something up with the install of the alternator but I didnt loose ALL POWER, my radio still worked and what not, just the car would not start.

    While I waited for AAA to come pick me up and take back to the shop I figured Id give it one more try (the car had been off for approx 15-20 minutes) and suprisingly the car started right up. Now, I was highly skeptical so I drove it maybe 10 yards in the parking lot and of course, it died again.

    It has been two weeks now and my bro-in-law and all of his co-workers/technicians CAN NOT get the problem to duplicate.

    For the 2 weeks theyve had it since, everytime they turn the key it turns on, theyve left it running for almost an hour (several times) and have driven it around a bunch and still the car is running like brand new.

    They even had the new alternator exchanged for another new alternator. Had Autozone (or wherever they got it from) test it before they sent it, and then they tested it as well.

    the code reader is showing nothing, and the car has not died since I have had it so I plan to pick it up today, but I know in the back of my mind that it will either die on me again when I drive it today, or it will wait a few days for me to get comfortable again and then die on me, which if (when) that happens, I am just having it taken to the dealership and having the full diagnostics run on it.

    The only other thing that I have had replaced on this is the NAV unit - it failed back in july 2012 - I had to have the dealership put a brand new one in and it has been fine since then, but could this be whats behind this mistery car die problem I had??


    Any thoughts/info would be greatly apprecaited!

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Sotex is offline Cadillac Owners Member
    Automobile(s): 2007 CTS/3.6
    Join Date
    Dec 2010
    Posts
    89

    Re: Not the alternator?....

    Did the "Low Voltage" show up when the car died after you had the alternator replaced? If not, then my first suspect would be the crankshaft position sensor (CPS). This is a known problem with the 2003. Do a search and see if any of the threads seem relevant to your problem. Relatively easy fix for less than $100 part. I'm sure some 2003 experts will chime in.

  4. #3
    Thomask is offline Cadillac Owners Member
    Automobile(s): 2003 CTS sport/lux.
    Join Date
    May 2013
    Posts
    2

    Re: Not the alternator?....

    Yes, the low voltage warning was the first thing that occured - which prompted me to get the alternator swapped out.


    and could the CPS have caused the car to die, and then start up...and eventually die again???

    I ask bc when my bro-in-law got the car right back after I broke down he said one code did pop up and it was for the CPS, however, it has not come back up since.

  5. #4
    Sotex is offline Cadillac Owners Member
    Automobile(s): 2007 CTS/3.6
    Join Date
    Dec 2010
    Posts
    89

    Re: Not the alternator?....

    I have a 2007 so any info I have is from this forum. But the instances seem to be intermittent and random unless it take a dump. Rarely does a code seem to pop up, so if your brother-in-law saw one, that would be a red flag. Do a quick search and see if the other folks have had similar occurrences. There was one just the other day one of the guys told how to hold the wire with a string to keep it handy. Lots of good info on here.

  6. #5
    danielfilteau is offline Cadillac Owners Member
    Automobile(s): cts 2003
    Join Date
    Dec 2012
    Location
    montreal
    Posts
    12

    Re: Not the alternator?....

    I have the same problem with 03 cts 3,2 l. Mine wont start before an hour. It would crank, have the right voltage but wont start. there is no code on the ecm related to the problem. I am thinking more of a fuel problem than electrical.I ran out of gas a mount ago . since I have this peroblem. could be a coincidence but now I am desperate...

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting