Antifreeze smell ?
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 24
Cadillac CTS First Generation Forum - 2003 - 2007 Discussion, Antifreeze smell ? in Cadillac CTS Coupe, Sport Sedan and Sport Wagon Forums; I think it's antifreeze, not sure. I have no leaks that I can see but I do have to add ...
  1. #1
    H2K's Avatar
    H2K
    H2K is offline Cadillac Owners Member
    Automobile(s): 2004 CTS 3.6
    Join Date
    Oct 2011
    Location
    Florida
    Age
    37
    Posts
    23

    Antifreeze smell ?

    I think it's antifreeze, not sure. I have no leaks that I can see but I do have to add freeze to the system, not much maybe a qt. a month. I can smell it in the cockpit all the time, but if I use the recycle switch on the dash no smell inside. I can smell it with the windows down coming from the engine at a stop light, it kinda comes and goes

    I was thinking heater core, but like I said no leaks in the car

    any help would be great

    Thanks, Justin

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    H2K's Avatar
    H2K
    H2K is offline Cadillac Owners Member
    Automobile(s): 2004 CTS 3.6
    Join Date
    Oct 2011
    Location
    Florida
    Age
    37
    Posts
    23
    Thread Starter

    Re: Antifreeze smell ?

    anyone ?

  4. #3
    kellerk23's Avatar
    kellerk23 is offline Cadillac Owners Member
    Automobile(s): 2008 Cadillac CTS 3.6 DI AWD
    Join Date
    Nov 2012
    Location
    Winder, GA
    Age
    32
    Posts
    16
    I have the same problem in my 08 3.6 DI. It comes and goes.

  5. #4
    H2K's Avatar
    H2K
    H2K is offline Cadillac Owners Member
    Automobile(s): 2004 CTS 3.6
    Join Date
    Oct 2011
    Location
    Florida
    Age
    37
    Posts
    23
    Thread Starter

    Re: Antifreeze smell ?

    I'm starting to think it's not the HC. there is no smell in the car when using heat with the recycle switch on, only if it's open do I get the smell, so it's coming from the engine somewhere on the passenger side closes to the windsheild

  6. #5
    Blayne's Avatar
    Blayne is offline Cadillac Owners Connoisseur
    Automobile(s): 2006 CTS sport model/package
    Join Date
    Sep 2012
    Location
    Sudbury, Ontario Canada
    Posts
    1,058
    Quote Originally Posted by H2K
    I'm starting to think it's not the HC. there is no smell in the car when using heat with the recycle switch on, only if it's open do I get the smell, so it's coming from the engine somewhere on the passenger side closes to the windsheild
    A typical sign of a bad heater core is a greasy type film on the inside of the windshield. 90% of the time you will get it. Also, check your oil, if you have to add coolant it may be going into your oil.

  7. #6
    H2K's Avatar
    H2K
    H2K is offline Cadillac Owners Member
    Automobile(s): 2004 CTS 3.6
    Join Date
    Oct 2011
    Location
    Florida
    Age
    37
    Posts
    23
    Thread Starter
    I recently changed the oil didn't notice any liquids in the oil

  8. #7
    VaderWS6's Avatar
    VaderWS6 is offline Cadillac Owners Fanatic
    Automobile(s): 05 CTS
    Join Date
    Dec 2012
    Posts
    179
    Quote Originally Posted by H2K
    I think it's antifreeze, not sure. I have no leaks that I can see but I do have to add freeze to the system, not much maybe a qt. a month. I can smell it in the cockpit all the time, but if I use the recycle switch on the dash no smell inside. I can smell it with the windows down coming from the engine at a stop light, it kinda comes and goes

    I was thinking heater core, but like I said no leaks in the car

    any help would be great

    Thanks, Justin
    Same thing happened to me for the first time a couple days ago. Popped the hood and the smell was really strong. Everything looked fine though, hasn't happened since.

  9. #8
    Bluehaze07's Avatar
    Bluehaze07 is offline Cadillac Owners Connoisseur
    Automobile(s): 05 CTS
    Join Date
    Apr 2009
    Location
    Honolulu, HI
    Posts
    1,380
    Quote Originally Posted by VaderWS6

    Same thing happened to me for the first time a couple days ago. Popped the hood and the smell was really strong. Everything looked fine though, hasn't happened since.
    Have you considered your timing chain components as an issue to include the water pump. The Copland could be getting into your oil. Is your car loud like a diesel engine?

  10. #9
    H2K's Avatar
    H2K
    H2K is offline Cadillac Owners Member
    Automobile(s): 2004 CTS 3.6
    Join Date
    Oct 2011
    Location
    Florida
    Age
    37
    Posts
    23
    Thread Starter
    Quote Originally Posted by Bluehaze07

    Have you considered your timing chain components as an issue to include the water pump. The Copland could be getting into your oil. Is your car loud like a diesel engine?
    Mine always sounded like a diesel on Start up for about two seconds I thought that would be normal since the oil filter sitting on the top of the motor
    I think I'm going to take it to Cadillac and let them flush the motor and doing oil change

  11. #10
    kellerk23's Avatar
    kellerk23 is offline Cadillac Owners Member
    Automobile(s): 2008 Cadillac CTS 3.6 DI AWD
    Join Date
    Nov 2012
    Location
    Winder, GA
    Age
    32
    Posts
    16
    I just took mine to a dealer and they said my water pump went out and they replaced it!

  12. #11
    Bluehaze07's Avatar
    Bluehaze07 is offline Cadillac Owners Connoisseur
    Automobile(s): 05 CTS
    Join Date
    Apr 2009
    Location
    Honolulu, HI
    Posts
    1,380
    Quote Originally Posted by H2K

    Mine always sounded like a diesel on Start up for about two seconds I thought that would be normal since the oil filter sitting on the top of the motor
    I think I'm going to take it to Cadillac and let them flush the motor and doing oil change
    My car was sounding like that consistently until I replaced my timing components and the water pump. (I did it as preventative maintenance). It may be the water pump just as stated and hopefully not signs of a failing timing chain or component.

  13. #12
    H2K's Avatar
    H2K
    H2K is offline Cadillac Owners Member
    Automobile(s): 2004 CTS 3.6
    Join Date
    Oct 2011
    Location
    Florida
    Age
    37
    Posts
    23
    Thread Starter

    Re: Antifreeze smell ?

    Quote Originally Posted by kellerk23 View Post
    I just took mine to a dealer and they said my water pump went out and they replaced it!
    was u getting the smell I described?
    my smell is coming from the passenger side, near the firewall...but I still have no water spot anywhere

    ----------

    we should start a sticky of repair costs and hours given for the repairs, so we can have an idea of expecting cost for reference

  14. #13
    kellerk23's Avatar
    kellerk23 is offline Cadillac Owners Member
    Automobile(s): 2008 Cadillac CTS 3.6 DI AWD
    Join Date
    Nov 2012
    Location
    Winder, GA
    Age
    32
    Posts
    16
    Yes and it came from the all of the vents up front.

    Now it doesn't since it got fixed

  15. #14
    CadillacAsAlways's Avatar
    CadillacAsAlways is offline Cadillac Owners Enthusiast
    Automobile(s): 2003 CTS 3.2L, Luxury Sport, Diamond White
    Join Date
    Aug 2012
    Location
    Pittsburgh, PA
    Posts
    660
    FYI I've had the exact same symptoms as what the OP wrote in the first post, except it sorta comes and goes. Haven't smelled it in a while...really since winter began...but I was noticing it a ton during the summer and warm months.

    Coolant still leaks...probably at a rate where I gotta re-fill the expansion tank every 2 weeks to stop the notifications. The leak never really increases or decreases...
    Anyway, yeah probably the water pump. I'm going to have a trusted mechanic replace it (if he confirms that its the issue) and the timing chain as a preventive measure hopefully next week. I would myself, but I've got no garage, it's snowing, 25 degrees, and very few tools to get it done. So...

  16. #15
    Argent1's Avatar
    Argent1 is online now Cadillac Owners Connoisseur
    Automobile(s): '07 CTS 3.6
    Join Date
    Nov 2010
    Posts
    2,885

    Re: Antifreeze smell ?

    You don't have a Timing Chain, BTW.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting