2003 CTS MAF Sensor Problems

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 4 of 4
Cadillac CTS First Generation Forum - 2003 - 2007 Discussion, 2003 CTS MAF Sensor Problems in Cadillac CTS Coupe, Sport Sedan and Sport Wagon Forums; Hello, I recently came up with an error code (p0102C) -Mass Air Flow Sensor Circuit Low Frequency. I ordered the ...
  1. #1
    RobertMcc is offline Cadillac Owners Member
    Automobile(s): 2003 Cadillac CTS
    Join Date
    Apr 2012
    Lake Charles, La

    2003 CTS MAF Sensor Problems

    Hello, I recently came up with an error code (p0102C) -Mass Air Flow Sensor Circuit Low Frequency. I ordered the new MAF sensor from autozone and replaced it, but the car is still running like garbage; slow acceleration, rough idle, sluggish response. I've replaced the crankshaft position sensor, spark plugs (no misfires) and air filter.I'm still getting the p0102C error, any ideas on what to do? Why is it still saying low freq on the maf circuit? Thanks

  2. Remove Advertisements

  3. #2
    CTSUK's Avatar
    CTSUK is offline Cadillac Owners Enthusiast
    Automobile(s): 2005 Cadillac CTS 3.6 Sport Luxury
    Join Date
    May 2012
    United Kingdom

    Re: 2003 CTS MAF Sensor Problems


    Could be that you have an air leak somewhere, check all piping, I have had a pipe pop off close to the throttle body tunnel before, surprisingly this didn't bring up any codes though.
    Also worth checking the wiring to the sensor make sure its not damaged at all.

    Seems like the 2003 guys are having a bit of a rough deal with ECM failure of late.

  4. #3
    Kik is offline Cadillac Owners Member
    Automobile(s): CTS
    Join Date
    Jul 2012

    Re: 2003 CTS MAF Sensor Problems

    What you're describing sounds like either having a problem with your IAC as CTSUK stated an air problem.Ifit's an air problem I would look at the intake manifold gasket first. I believe these are rubber and plastic gaskets. I know chevy guys that have had a heck of time with these going bad.

  5. #4
    jran0823's Avatar
    jran0823 is offline Cadillac Owners Connoisseur
    Automobile(s): 2003 CTS 1SC Luxury Sport
    Join Date
    Apr 2011
    GB, WI
    When you have an electronic throttle body you don't have IAC. Computer controls the idle with the throttle body instead. Might have a throttle body issue.

  6. Remove Advertisements
    Cadillac Forums

+ Reply to Thread
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

What Cadillac(s) do you own? (Or type NONE)

Please select your insurance company (Optional)

Your date of birth and age are displayed in several places on the forum. Only the administrator will have access to your date of birth should you choose to hide it via the privacy option below.


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts