instrument cluster malfunction
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 8 of 8
Cadillac CTS First Generation Forum - 2003 - 2007 Discussion, instrument cluster malfunction in Cadillac CTS Coupe, Sport Sedan and Sport Wagon Forums; My 03 CTS cluster stopped working on me last night. It is stuck at 2,000rpm, 35mph, and a quarter tank ...
  1. #1
    jeff0101 is offline Cadillac Owners Fanatic
    Automobile(s): 2003 Cadillac cts luxury sport, with slotted rotors
    Join Date
    Feb 2010
    Location
    Fredericksburg, Virginia, Unit
    Age
    22
    Posts
    194

    instrument cluster malfunction

    My 03 CTS cluster stopped working on me last night. It is stuck at 2,000rpm, 35mph, and a quarter tank of gas. Also it doesn't light up anymore. The only thing that lights up is left, right, and hazard turn signals. Also the red gear selector light isn't on. I tried the easy route and disconnected the battery and checked my fuses and nothing happened. Anyone have any idea whats going on.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    CTSUK's Avatar
    CTSUK is offline Cadillac Owners Enthusiast
    Automobile(s): 2005 Cadillac CTS 3.6 Sport Luxury
    Join Date
    May 2012
    Location
    United Kingdom
    Age
    33
    Posts
    732

    Re: instrument cluster malfunction

    First thing I would try is disassembling around the cluster to remove it and check for any connectors popping off then work back from there, you might find a loose connection and then when you put it back in place it works again, depends how its plugged in at the back.

  4. #3
    josney's Avatar
    josney is offline Cadillac Owners Connoisseur
    Automobile(s): 2003 CTS
    Join Date
    Dec 2006
    Location
    South Carolina
    Age
    47
    Posts
    1,981

    Re: instrument cluster malfunction

    huh, never heard of anyone having trouble like that. i have the old cluster from my 03 (with the stupid ass clock) sitting in the garage. let me know if you need it.

  5. #4
    jeff0101 is offline Cadillac Owners Fanatic
    Automobile(s): 2003 Cadillac cts luxury sport, with slotted rotors
    Join Date
    Feb 2010
    Location
    Fredericksburg, Virginia, Unit
    Age
    22
    Posts
    194
    My main question, is there another power supply for the cluster? Like a capacitor or something of that nature. And are there any special fuses that I might have missed?

  6. #5
    josney's Avatar
    josney is offline Cadillac Owners Connoisseur
    Automobile(s): 2003 CTS
    Join Date
    Dec 2006
    Location
    South Carolina
    Age
    47
    Posts
    1,981

    Re: instrument cluster malfunction

    KOT should be able to help with something like that. i am sure he will be lurking around at some point. maybe he can shed so light.

  7. #6
    CTSUK's Avatar
    CTSUK is offline Cadillac Owners Enthusiast
    Automobile(s): 2005 Cadillac CTS 3.6 Sport Luxury
    Join Date
    May 2012
    Location
    United Kingdom
    Age
    33
    Posts
    732

    Re: instrument cluster malfunction


    Check the fuses under the hood one is labeled ELEC PRNDL, also worth checking any other fuses in that block.
    Have you checked fuses also in both rear under seat blocks both left and right?, if not check them all one at a time.

  8. #7
    Kingoftypos is offline Cadillac Owners Master
    Automobile(s): 06 CTS Sport/Luxury package
    Join Date
    Apr 2009
    Location
    Ledyard, CT
    Age
    35
    Posts
    7,560

    Re: instrument cluster malfunction

    And there are more in the fuse boxes under the rear seat.

    I've read this a couple times but kept on having the brain fart of the century. I have seen this problem before, so I thought, but I couldn't figure out what the fix was.

    With the previous problems with the IC, for some it was the connection on the back. While for other's it was the IC itself, or either they couldn't figure it the connection out. Some who could, said there was a cold-solder joint on the board for the IC, hence the connection. So if you are able to solder, then I suggest removing the IC and re-solder the solder joints.

    Check out ghettomike's DIY to remove the IC...

    http://www.cadillacforums.com/forums...r-removal.html

    KOT

  9. #8
    jeff0101 is offline Cadillac Owners Fanatic
    Automobile(s): 2003 Cadillac cts luxury sport, with slotted rotors
    Join Date
    Feb 2010
    Location
    Fredericksburg, Virginia, Unit
    Age
    22
    Posts
    194
    Im going to give it a try and check each fuse, then if I can't find anything I will pull out the cluster

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting