Service Electrical System & Charging System Problem - Page 3
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 31 to 45 of 46
Like Tree2Likes
Cadillac CTS First Generation Forum - 2003 - 2007 Discussion, Service Electrical System & Charging System Problem in Cadillac CTS Coupe, Sport Sedan and Sport Wagon Forums; Originally Posted by odthetruth You should pull the alternator and have it replaced. I had to search thru my phone ...
  1. #31
    mickeydog's Avatar
    mickeydog is offline Cadillac Owners Member
    Automobile(s): Cadillac CTS 2003
    Join Date
    Nov 2007
    Location
    Michigan
    Posts
    79
    Quote Originally Posted by odthetruth

    You should pull the alternator and have it replaced.

    I had to search thru my phone for a video just now but:


    If this is what you are getting (and as you can see, my battery voltage was 13.8), its alternator.
    Have you had any problems since replacing the alternator?

  2. #32
    odthetruth's Avatar
    odthetruth is offline Moderator
    Automobile(s): 2006 CTS-V
    Join Date
    Feb 2010
    Location
    NYC
    Posts
    4,979

    Re: Service Electrical System & Charging System Problem

    Quote Originally Posted by mickeydog View Post
    Have you had any problems since replacing the alternator?
    Yeah, someone rear ended me into another car.
    But prior to that incident, no. The alternator was what fixed it. lol

    [2006 CTS-V - "The Vee Baby Seamus"] - 372rwhp / 361rwtq
    Pacesetters | Off Road Adapters | Cutouts | Stock Airbox | Stock Catback
    BMR AWK | CS Diff Block | Short Shifter | UMI MM | Revshift TM

  3. #33
    mickeydog's Avatar
    mickeydog is offline Cadillac Owners Member
    Automobile(s): Cadillac CTS 2003
    Join Date
    Nov 2007
    Location
    Michigan
    Posts
    79
    I replaced the alternator today so far so good I will post back after a couple days of driving. Thanks

  4. #34
    RoyalFlush's Avatar
    RoyalFlush is offline Cadillac Owners Enthusiast
    Automobile(s): 2004 3.6L v6 cts lux
    Join Date
    Jul 2005
    Location
    Queens NY
    Age
    31
    Posts
    868

    Re: Service Electrical System & Charging System Problem

    looks like i might have to do the same. I'm gonna put in a HO alt in mine. I keep getting the flickering of lights when my bass hits or when i press the window button at night. Got the car pc with the 8 in touchscreen, 2 amps feeding off the battery which is being charged by the original alt at 98k miles. I think it's about that time. Denso has some pretty inexpensive 250amp ones on the web.

  5. #35
    X Rolls-Royce is offline Cadillac Owners Connoisseur
    Join Date
    Sep 2011
    Age
    58
    Posts
    4,210

    Re: Service Electrical System & Charging System Problem

    Flush, haven't you ever rebuilt an alternator ? Its easy. Whatever the brushes cost, Under $20.

  6. #36
    RoyalFlush's Avatar
    RoyalFlush is offline Cadillac Owners Enthusiast
    Automobile(s): 2004 3.6L v6 cts lux
    Join Date
    Jul 2005
    Location
    Queens NY
    Age
    31
    Posts
    868

    Re: Service Electrical System & Charging System Problem

    Nope havent done it yet. Looks tempting from what I've researched just wish i had the time to spare with work & school(both full time) it's hectic.

  7. #37
    X Rolls-Royce is offline Cadillac Owners Connoisseur
    Join Date
    Sep 2011
    Age
    58
    Posts
    4,210

    Re: Service Electrical System & Charging System Problem

    Quote Originally Posted by RoyalFlush View Post
    Nope havent done it yet. Looks tempting from what I've researched just wish i had the time to spare with work & school(both full time) it's hectic.
    Yeh, time, time, time. The only difficulty I've ever had was getting the case open. Sometimes they're sealed and you have to drill them out and replace the fasteners with fresh nuts and bolts. Once the case is open, I take sandpaper or emory cloth to the copper plate and get all the black residue from the brushes off, then polish it with wet or dry. Remove the remnants of the old brushes and pop in the new ones. Its simple, and it saves a bundle.

  8. #38
    mickeydog's Avatar
    mickeydog is offline Cadillac Owners Member
    Automobile(s): Cadillac CTS 2003
    Join Date
    Nov 2007
    Location
    Michigan
    Posts
    79
    After driving for a week or so I do not have any problems volts are constantly over 14 when driving with seats,radio and headlights all on so pretty sure it must have been the alternator. When I returned the core to Autozone the machine was down to check it but they still gave me my $47 back so thanks to everyone for their input.
    odthetruth and odthetruth like this.

  9. #39
    X Rolls-Royce is offline Cadillac Owners Connoisseur
    Join Date
    Sep 2011
    Age
    58
    Posts
    4,210

    Re: Service Electrical System & Charging System Problem

    Another happy ending !!!

  10. #40
    fullo06 is offline Cadillac Owners Fanatic
    Automobile(s): 06 3.6L CTS w/sports package
    Join Date
    Jun 2010
    Location
    Houston, Tx
    Age
    22
    Posts
    115

    Re: Service Electrical System & Charging System Problem

    Didnt want to create another thread, so I'll hijack this one...

    My car didnt start yesterday, it wouldnt even crank as a matter of fact. After failed attemps of jump starting it, I just disconnected the battery and left as is overnight. My theft service lock (I think thats what its called) light came on, and I wasnt able to remove the key from the ignition. Tried again today to start it, but didnt work. Lights and everything work fine, my voltage from the radio reads 11.8 with the key in the "on" position. Can anybody chime in with how I can probably get this fixed? Im hoping its nothing major because I need the car tonight

    ----------

    Forgot to add that I doubt that its the battery, being that I bought a brand new one a month ago

  11. #41
    simple2me's Avatar
    simple2me is offline Cadillac Owners Fanatic
    Automobile(s): Black 06/08 Satillac CTS-O
    Join Date
    Nov 2011
    Location
    Southwest Louisiana
    Posts
    398

    Re: Service Electrical System & Charging System Problem

    when you turn the key to the ON position does the amber engine symbol light up on the dash and when you try to crank you get absolutely nothing? If so, your ECM might be taking a crap like mine. I usually know when my car will not start before shutting it off. The Avg MPG's get to acting up and goes down to like 11MPG AVG while driving so I keep clearing it until it reads correctly and I don't have any problem starting usually. Open the under hood fuse box and the wiring harness that plugs in on the right side towards the front of the car has a yellow wire I jump to a ground and the car cranks up. I usually have the codes U0100 & P0700 which I clear before driving or my transmission will act up (harsh, hard shifting)IMG-20120314-00426.jpg

  12. #42
    fullo06 is offline Cadillac Owners Fanatic
    Automobile(s): 06 3.6L CTS w/sports package
    Join Date
    Jun 2010
    Location
    Houston, Tx
    Age
    22
    Posts
    115

    Re: Service Electrical System & Charging System Problem

    Thanks for the help, but I managed to get it started. I got the key out of the ignition pushing the spring under steering wheel.
    Then, I locked the car with the key fob and I opened the driver side door with the key.
    After that, I disconnected the battery and left it for about 30 mins.
    Then I reconnected it and it started right up. The car started idling pretty rough and eventually smoothed out.

    However, I now have the check engine light on so theres that..

  13. #43
    X Rolls-Royce is offline Cadillac Owners Connoisseur
    Join Date
    Sep 2011
    Age
    58
    Posts
    4,210

    Re: Service Electrical System & Charging System Problem

    Gibbs, here you go. I didn't read the whole thing but maybe it will help you.

    Once again I spent half an hour finding something for someone.

  14. #44
    odthetruth's Avatar
    odthetruth is offline Moderator
    Automobile(s): 2006 CTS-V
    Join Date
    Feb 2010
    Location
    NYC
    Posts
    4,979

    Re: Service Electrical System & Charging System Problem

    Quote Originally Posted by X Rolls-Royce View Post
    Gibbs, here you go. I didn't read the whole thing but maybe it will help you.

    Once again I spent half an hour finding something for someone.
    LOL Next time you should tell 'em to search. That function is there for everyone.

    [2006 CTS-V - "The Vee Baby Seamus"] - 372rwhp / 361rwtq
    Pacesetters | Off Road Adapters | Cutouts | Stock Airbox | Stock Catback
    BMR AWK | CS Diff Block | Short Shifter | UMI MM | Revshift TM

  15. #45
    X Rolls-Royce is offline Cadillac Owners Connoisseur
    Join Date
    Sep 2011
    Age
    58
    Posts
    4,210

    Re: Service Electrical System & Charging System Problem

    Quote Originally Posted by odthetruth View Post
    LOL Next time you should tell 'em to search. That function is there for everyone.
    I was searching for the thread where the guy here in my county wanted to trade his aftermarket wheels for factory wheels. I stumbled across this thread and it matches up with Gibbs. He changed his ECM and alternator today at the dealer and was getting the service electrical system message afterwards. Not a big deal.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting