Service Electrical System & Charging System Problem - Page 2
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 2 of 4 FirstFirst 1 2 3 4 LastLast
Results 16 to 30 of 46
Like Tree2Likes
Cadillac CTS First Generation Forum - 2003 - 2007 Discussion, Service Electrical System & Charging System Problem in Cadillac CTS Coupe, Sport Sedan and Sport Wagon Forums; I changed mine in my 03 at around 70+k, right before the accident. Check the connectors, plugs, etc. Clean it, ...
  1. #16
    odthetruth's Avatar
    odthetruth is offline Moderator
    Automobile(s): 2006 CTS-V
    Join Date
    Feb 2010
    Location
    NYC
    Posts
    4,983

    Re: Service Electrical System & Charging System Problem

    I changed mine in my 03 at around 70+k, right before the accident.
    Check the connectors, plugs, etc. Clean it, and then replug everything back in... same issue, I'd change Alternator.

    [2006 CTS-V - "The Vee Baby Seamus"] - 372rwhp / 361rwtq
    Pacesetters | Off Road Adapters | Cutouts | Stock Airbox | Stock Catback
    BMR AWK | CS Diff Block | Short Shifter | UMI MM | Revshift TM

  2. #17
    X Rolls-Royce is offline Cadillac Owners Connoisseur
    Join Date
    Sep 2011
    Age
    58
    Posts
    4,210

    Re: Service Electrical System & Charging System Problem

    Quote Originally Posted by odthetruth View Post
    I changed mine in my 03 at around 70+k, right before the accident.
    Check the connectors, plugs, etc. Clean it, and then replug everything back in... same issue, I'd change Alternator.
    Only 70,000 miles, good to know. I hadn't seen any threads so I assumed it wasn't common; that's why I went with phantom warning and beginning of ECM failure. I'll know better next time. Alternators are easy to repair. I ran an 81 Plymouth up to 193,000 and changed the brushes three times. About $6 each time. Open, sand the armature plate, wipe clean, install new brushes, tighten up and reinstall. About an hour.

  3. #18
    mickeydog's Avatar
    mickeydog is offline Cadillac Owners Member
    Automobile(s): Cadillac CTS 2003
    Join Date
    Nov 2007
    Location
    Michigan
    Posts
    79

    Re: Service Electrical System & Charging System Problem

    Checked alternator connections and the volt check fuse all good then disconnected the battery for 15 minutes so far the message has not reappered nor has the battery light.

  4. #19
    X Rolls-Royce is offline Cadillac Owners Connoisseur
    Join Date
    Sep 2011
    Age
    58
    Posts
    4,210

    Re: Service Electrical System & Charging System Problem

    Quote Originally Posted by mickeydog View Post
    Checked alternator connections and the volt check fuse all good then disconnected the battery for 15 minutes so far the message has not reappered nor has the battery light.
    Well, that's good, and mysterious. If everything is smooth sailing on the battery front, I might be right about signs of ECM failure. Codes that pop up saying something is wrong and nothing actually being wrong...that's the ECM failing. Lets hope it was just the solar flare messing with you.

  5. #20
    mickeydog's Avatar
    mickeydog is offline Cadillac Owners Member
    Automobile(s): Cadillac CTS 2003
    Join Date
    Nov 2007
    Location
    Michigan
    Posts
    79

    Re: Service Electrical System & Charging System Problem

    AHH Yess doing it again now the volts are going crazy low when driving down to as low as 9 volts,drove home pulled into garage shut it off and restarted fine then shut it off pulled the key out and tested the battery with multimeter and reading 11.78 I then started the car again and did not get any warning lights or messages and volts were 14.2 without radio,heater,headlights on then only dropped to 13.4 with all on.Do you think it is the ECM going bad should I pull the alternator and have it tested? Thanks

  6. #21
    carrnuttdave is offline Cadillac Owners Connoisseur
    Automobile(s): 2007 CTS
    Join Date
    Aug 2010
    Location
    Layton, Utah
    Age
    50
    Posts
    1,572

    Re: Service Electrical System & Charging System Problem

    IMO your alternator is gone! Alternators that are bad can still put out the prper voltage but not enough AMP's to run everything

  7. #22
    odthetruth's Avatar
    odthetruth is offline Moderator
    Automobile(s): 2006 CTS-V
    Join Date
    Feb 2010
    Location
    NYC
    Posts
    4,983

    Re: Service Electrical System & Charging System Problem

    Quote Originally Posted by mickeydog View Post
    AHH Yess doing it again now the volts are going crazy low when driving down to as low as 9 volts,drove home pulled into garage shut it off and restarted fine then shut it off pulled the key out and tested the battery with multimeter and reading 11.78 I then started the car again and did not get any warning lights or messages and volts were 14.2 without radio,heater,headlights on then only dropped to 13.4 with all on.Do you think it is the ECM going bad should I pull the alternator and have it tested? Thanks
    You should pull the alternator and have it replaced.

    I had to search thru my phone for a video just now but:


    If this is what you are getting (and as you can see, my battery voltage was 13.8), its alternator.

    [2006 CTS-V - "The Vee Baby Seamus"] - 372rwhp / 361rwtq
    Pacesetters | Off Road Adapters | Cutouts | Stock Airbox | Stock Catback
    BMR AWK | CS Diff Block | Short Shifter | UMI MM | Revshift TM

  8. #23
    mickeydog's Avatar
    mickeydog is offline Cadillac Owners Member
    Automobile(s): Cadillac CTS 2003
    Join Date
    Nov 2007
    Location
    Michigan
    Posts
    79

    Re: Service Electrical System & Charging System Problem

    OK Thanks for the video thats whats it doing but started it this morning and all is good nothing on the display no warning battery light even with seats,radio,heat and headlights on it showed 14.2 volts.Should I just go to Autozone and have them check the battery and alternator?

  9. #24
    carrnuttdave is offline Cadillac Owners Connoisseur
    Automobile(s): 2007 CTS
    Join Date
    Aug 2010
    Location
    Layton, Utah
    Age
    50
    Posts
    1,572

    Re: Service Electrical System & Charging System Problem

    That would be a good start. However if your battery is failing a load test could drain it to where it wont start. Hopefully they have a jumper box to get you going again

  10. #25
    X Rolls-Royce is offline Cadillac Owners Connoisseur
    Join Date
    Sep 2011
    Age
    58
    Posts
    4,210

    Re: Service Electrical System & Charging System Problem

    Quote Originally Posted by mickeydog View Post
    OK Thanks for the video thats whats it doing but started it this morning and all is good nothing on the display no warning battery light even with seats,radio,heat and headlights on it showed 14.2 volts.Should I just go to Autozone and have them check the battery and alternator?
    Have I got this right, the car performs perfectly, but this message pops up ?

    I'll go along with the calls to rebuild the alternator, but if you don't mind getting stuck, or if you have one of those instant jumpstart devices they sell, you might just want to ride things out until the battery gets sluggish, which will happen if its really the alternator. Otherwise you just have an annoying messaage.

    The battery symbol on the instrument panel is supposed to come on when the alternator output is lower than the drain on the battery.
    You could have an intermittant short causing a temporary drain while you're driving.

    There's no harm in having a free electrical test done, but I haven't found them to be very reliable.

  11. #26
    carrnuttdave is offline Cadillac Owners Connoisseur
    Automobile(s): 2007 CTS
    Join Date
    Aug 2010
    Location
    Layton, Utah
    Age
    50
    Posts
    1,572

    Re: Service Electrical System & Charging System Problem

    I di have an old chevy truck that the alternator would charge fine at idle but at highway speed it would stop charging. I tell you it was a pita. When I bought it I drove it from salt lake to Las Vegas at night. About every 30 miles I had to stop let it Idle a while to charge back up then I could go another 30 miles stop and let it charge again. I was the alternator. Luckily back then they had all night auto parts stores in Vegas. Bought a new alternator and never had a problem again.

  12. #27
    mickeydog's Avatar
    mickeydog is offline Cadillac Owners Member
    Automobile(s): Cadillac CTS 2003
    Join Date
    Nov 2007
    Location
    Michigan
    Posts
    79

    Re: Service Electrical System & Charging System Problem

    Autozone tested the battery and alternator both checked out good they said to bring the car back next time it is acting crazy.I am just going to drive it I guess until I am stranded lol

    ----------

    I am half tempted just to replace the alternator from "odthetruths" posting.

    ----------

    When you got the dash read out did it just do it sometimes before you replaced the alternator?

  13. #28
    carrnuttdave is offline Cadillac Owners Connoisseur
    Automobile(s): 2007 CTS
    Join Date
    Aug 2010
    Location
    Layton, Utah
    Age
    50
    Posts
    1,572

    Re: Service Electrical System & Charging System Problem

    How did they check the alternator? Did they hook it up to a macine that tests it at idle and at high RPM? Ive seen some of those autozone guys just take out a volt meter and check yup, 13 volts it's good!

  14. #29
    mickeydog's Avatar
    mickeydog is offline Cadillac Owners Member
    Automobile(s): Cadillac CTS 2003
    Join Date
    Nov 2007
    Location
    Michigan
    Posts
    79

    Re: Service Electrical System & Charging System Problem

    Just at idle

    ----------

    I think I am just going to pull it tomorrow and replace it looks like it would be a lot easier to go from the bottom was thinking of jacking the car up removing the right front tire and wheel well plastic liner,anyone else have a good way to remove it?Thanks All, Love this Forum

  15. #30
    X Rolls-Royce is offline Cadillac Owners Connoisseur
    Join Date
    Sep 2011
    Age
    58
    Posts
    4,210

    Re: Service Electrical System & Charging System Problem

    Mickey, you might be spending money that you don't need too. There honestly was a massive solar flare a couple of weeks ago that triggered at least two problems. And ECM's go bad too often to count. For twenty dollars you can get a quick jump machine to keep in your trunk, it a miniature battery with clamps, light to carry and easy to use. I'd wait it out, the alternator is $157.25 online for the cheapest rebuilt one for 2003 at the first place I checked and $261.80 for remanufactured by OEM.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting