Cts stalls and wont start back up!!! Please help!!
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 12 of 12
Cadillac CTS First Generation Forum - 2003 - 2007 Discussion, Cts stalls and wont start back up!!! Please help!! in Cadillac CTS Coupe, Sport Sedan and Sport Wagon Forums; OK, car just had valve covers replaced, and I replaced the tensioner pulley. Before doing so the car unexplained stalled ...
  1. #1
    twotonius is offline Cadillac Owners Member
    Join Date
    Apr 2011
    Posts
    4

    Cts stalls and wont start back up!!! Please help!!

    OK, car just had valve covers replaced, and I replaced the tensioner pulley.
    Before doing so the car unexplained stalled a about 8 times, until the last three stalls it started right back up, the last three it hasn't. First two times the car was towed and immediately started upon arrival. I got the car back from the shop a few days ago from the valve cover replacement and everything seemed fine. Tonight I was cleaning it and decided to drive it around my street to see if I could get it to stall so I could pull the codes, just when I was giving up I pulled it in to my garage and sure enough it stalled, and wont start back up. I checked the codes and was pulling:

    U1000 h Loss of Seriel communications for class 2/ class 2 malfunction etc.
    P0335c Crankshaft Position [CKP] Sensor A Circuit
    P0700 Transmission Control System (MIL Request)

    I am concerned with all three but my assumptions are that the U1000 is my starting issue.

    I want to get this fixed and go back to enjoying my CTS, Any insight and help is Welcome....Thank You in advance

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    catch is offline Cadillac Owners Fanatic
    Automobile(s): 2003 CTS
    Join Date
    Apr 2007
    Posts
    396

    Re: Cts stalls and wont start back up!!! Please help!!

    crank position sensor?

    Sounds like it

  4. #3
    twotonius is offline Cadillac Owners Member
    Join Date
    Apr 2011
    Posts
    4

    Re: Cts stalls and wont start back up!!! Please help!!

    I have been reading some other threads and that is one of my best options. I am going to clean some wiring connections tomorrow and attempt replacing the Cps and see if that fixes it, any info on replacing the cps would be helpful for I have never changed it on this before

  5. #4
    Sammy Z's Avatar
    Sammy Z is offline Cadillac Owners Connoisseur
    Automobile(s): CTS 03
    Join Date
    Jan 2008
    Location
    Chicago, IL
    Posts
    1,758

    Re: Cts stalls and wont start back up!!! Please help!!

    They are about $60. Its locatated by the oil filter. You will neeed a torx socket to remove it. there are a few zip ties holding the wire, clip those. Tie a string to the CPS to pull the new connector through. For the connector, its at the top of the engine in the rear on the fire wall. Lay on the engine with a flash light and you will see it back there. it took me about 40 min to replace, I didn't run the wire exactly like the factory did, just keep it away from the hot manifold.

  6. #5
    odthetruth's Avatar
    odthetruth is offline Moderator
    Automobile(s): 2006 CTS-V
    Join Date
    Feb 2010
    Location
    NYC
    Posts
    4,979

    Re: Cts stalls and wont start back up!!! Please help!!

    What year / engine?

    03? If so, its most likely CPS

  7. #6
    txbest1980's Avatar
    txbest1980 is offline Cadillac Owners Master
    Automobile(s): 2003 CTS "Ebony Maria" 2005 Cadillac STS "Grace"
    Join Date
    Dec 2008
    Location
    Wherever Uncle Sam sends me
    Age
    34
    Posts
    6,439

    Re: Cts stalls and wont start back up!!! Please help!!



    you will get much more help if you state what year and engine...if it isnt an 03, then you have other issues

  8. #7
    twotonius is offline Cadillac Owners Member
    Join Date
    Apr 2011
    Posts
    4

    Re: Cts stalls and wont start back up!!! Please help!!

    Yes it is a 2003 cts 3.2v6

    Does anyone have any pictures or any more advice? I think I can probably figure it out. Also, you said to clip the zip ties, did you replace them when you were done? And just so I am not assuming wrong the best way to get the cps is from underneath correct?

  9. #8
    twotonius is offline Cadillac Owners Member
    Join Date
    Apr 2011
    Posts
    4

    Re: Cts stalls and wont start back up!!! Please help!!

    Also what size torx socket?

    And it is the luxury sport model if makes any difference.
    Both my Snow mode and sport mode stopped working about 6 months ago also, anybody have repair ideas?

  10. #9
    ghettomike's Avatar
    ghettomike is offline Cadillac Owners Master
    Automobile(s): 03 CTS 3.2L (Sold) / 09 CBR 600rr /2014 GMC Sierra
    Join Date
    Apr 2008
    Location
    off the grid.
    Age
    30
    Posts
    7,870

    Re: Cts stalls and wont start back up!!! Please help!!

    ive had that U1000 code before, pop the cover on your fuse box and make sure they are all good. one of mine blew.
    also the stalling is likely the CPS.

  11. #10
    Kingoftypos is online now Cadillac Owners Master
    Automobile(s): 06 CTS Sport/Luxury package
    Join Date
    Apr 2009
    Location
    Ledyard, CT
    Age
    35
    Posts
    7,498

    Re: Cts stalls and wont start back up!!! Please help!!

    Consider your self lucky to get a crank shaft position sensor code. 95% of the 3.2 CTS don't produce a code for the CPS. So people/dealers start to replace high dollar items when it's actually a $60 item.

    KOT

  12. #11
    Sammy Z's Avatar
    Sammy Z is offline Cadillac Owners Connoisseur
    Automobile(s): CTS 03
    Join Date
    Jan 2008
    Location
    Chicago, IL
    Posts
    1,758

    Re: Cts stalls and wont start back up!!! Please help!!

    Quote Originally Posted by twotonius View Post
    Yes it is a 2003 cts 3.2v6

    Does anyone have any pictures or any more advice? I think I can probably figure it out. Also, you said to clip the zip ties, did you replace them when you were done? And just so I am not assuming wrong the best way to get the cps is from underneath correct?
    Yes, I zip tied the new wire, but not exactly like the factory. It helps if the engine is not hot. Yes, you have to get under the car to change the actual sensor. The Torx socket is about 10mm, I can't remember the number on it, I had to buy a full set when I needed it.

  13. #12
    ericaabadie is offline Cadillac Owners Member
    Join Date
    Sep 2013
    Posts
    1

    Re: Cts stalls and wont start back up!!! Please help!! we just replase the serpentine

    Re: Cts stalls and wont start back up!!! Please help!! we just replase the serpentine

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting