04 CTS 3.2 making an engine noise that I cannot ID - Page 2
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 18 of 18
Cadillac CTS First Generation Forum - 2003 - 2007 Discussion, 04 CTS 3.2 making an engine noise that I cannot ID in Cadillac CTS Coupe, Sport Sedan and Sport Wagon Forums; Well, finally got the blessed bolts off for the computer cover today (weather and travel have been rediculus). Everything seems ...
  1. #16
    gsnickle is offline Cadillac Owners Member
    Automobile(s): 04 cts 3.2
    Join Date
    Jan 2011
    Age
    43
    Posts
    7
    Thread Starter

    Re: 04 CTS 3.2 making an engine noise that I cannot ID

    Well, finally got the blessed bolts off for the computer cover today (weather and travel have been rediculus). Everything seems fine with the cams, no unusual wear, front to back play is non-existant, and the lifters all are tight to the lobes on the back side of the cam. The oil is coming out when I spin it over, and all lifters appear to be getting enough (or at least the same amount) of oil. Did an old small block trick to see if the lifters would colapse, and none did, and aside from the off chance of a broken spring I could not find a thing wrong with the top end. I ran a compression check with the intake off and the plugs out, and I read between 260-280 on all the cylinders. I did notice that the plugs on the passenger side of the engine are significantly darker than the ones on the drivers side. The only other observation that I could make at this time was that I could not hear the noise while spining the engine over with the starter. This kinda leads me to believe that the noise is coming from a rod or crank problem. Anybody have any ideas on this one?

  2. #17
    Quickbird02 is offline Cadillac Owners Member
    Join Date
    Feb 2013
    Age
    23
    Posts
    2

    Re: 04 CTS 3.2 making an engine noise that I cannot ID

    Any news on this? Mine is doing the same thing, sounded like something wanted out of the cover. took it off and nothing. but it seems like the cam timing is off because at tdc compression on cyl1 the marks are like 4 teeth advanced

  3. #18
    Quickbird02 is offline Cadillac Owners Member
    Join Date
    Feb 2013
    Age
    23
    Posts
    2

    Re: 04 CTS 3.2 making an engine noise that I cannot ID

    Fixed it! The crank went almost a full turn around on the timing belt making the cams 4 teeth advanced of the crank. The serp belt had shredded when the tensions broke. so it was a mess of issues. But i retimed and fired and absolutely no noise!!! Hope this helps people down the road!

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting