Questions about O2 sensor codes P0160 & P0161 - Page 2
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 25 of 25
Cadillac CTS First Generation Forum - 2003 - 2007 Discussion, Questions about O2 sensor codes P0160 & P0161 in Cadillac CTS Coupe, Sport Sedan and Sport Wagon Forums; Replacing the ECM didn't work. The codes came right back. Also, the car did need the anti-theft relearn after swapping ...
  1. #16
    vwguy is offline Cadillac Owners Member
    Join Date
    Aug 2010
    Age
    36
    Posts
    10

    Re: Questions about O2 sensor codes P0160 & P0161

    Replacing the ECM didn't work. The codes came right back.

    Also, the car did need the anti-theft relearn after swapping out the ECM. Also the crank angle sensor does need to be replaced as the car shut down while my mom was driving it yesterday. Luckily it was close to home and the insurance company towed it for free.

  2. #17
    akeinc is offline Cadillac Owners Member
    Automobile(s): CTS
    Join Date
    Mar 2007
    Location
    Phh-O-Nee-X
    Posts
    35

    Re: Questions about O2 sensor codes P0160 & P0161

    Quote Originally Posted by vwguy View Post
    Replacing the ECM didn't work.
    Man that's a bummer. Well at least you got a backup ecm ready to plug and play. Did ya check for an open heater circuit at the O2 sensor itself (both white wires)?

    My B2S2 heater broke on at least two other sensors - I don't know why but I'm guessing it may have had something to do with jump starting the car (we do that a lot here in the desert) which may also have broken my ECM.

  3. #18
    thoed.essay is offline Cadillac Owners Member
    Automobile(s): 03 Diamond White CTS Lux/Sports PKG
    Join Date
    Jul 2010
    Location
    West TX
    Posts
    69

    Re: Questions about O2 sensor codes P0160 & P0161

    haha sounds like we have the exact same car cuz i have these problems as well
    i dont remember if those were my codes but i know it had to do with the same o2 sensors because the other day i had a diagnostic test ran it said bank 2 sensor 1 & 2 were bad , catalytic converter bank 2 bad it showed nothing wrong with the crank shaft position sensor but he told me to try and change that to see if that was the problem with my car having trouble starting and turning off. i asked my mechanic who i always take my car to about the problems with my car starting he said more then likely it was my ignition switch and not the crank sensor but thats because my car turns off while im driving unless yours does the same i would try the crank sensor first and see how it does after that.

  4. #19
    thoed.essay is offline Cadillac Owners Member
    Automobile(s): 03 Diamond White CTS Lux/Sports PKG
    Join Date
    Jul 2010
    Location
    West TX
    Posts
    69

    Re: Questions about O2 sensor codes P0160 & P0161

    just read your car turned off while your mother was driving

    if its your ignition switch try wiggling it after you turn on the car

    if your cts is like mine it has a mind of its on and sometimes moving the ignition switch will cause it to turn off and other times it wont

  5. #20
    txbest1980's Avatar
    txbest1980 is offline Cadillac Owners Master
    Automobile(s): 2003 CTS "Ebony Maria" 2005 Cadillac STS "Grace"
    Join Date
    Dec 2008
    Location
    Wherever Uncle Sam sends me
    Age
    34
    Posts
    6,439

    Re: Questions about O2 sensor codes P0160 & P0161

    vwguy...that is interesting that the ECM didnt fix the proble. i wonder if you have the same problem chevyhighperformance had. he had the same codes and i believe he had two wires that ended up shorting out, and he replaced his wiring harness. and if i am correct, that cost him like $134, but i may be wrong. hopefully he logs in and reads this thread

  6. #21
    jbf28 is offline Cadillac Owners Member
    Automobile(s): 2003 cts sport
    Join Date
    Nov 2008
    Location
    north jersey
    Posts
    51

    Re: Questions about O2 sensor codes P0160 & P0161

    im having this same problem replacd ecm and codes still there, so did you ever fix this problem and if so how

  7. #22
    jermainmarley is offline Cadillac Owners Member
    Automobile(s): 2003 cadillac cts sport luxury
    Join Date
    Apr 2013
    Posts
    2

    Re: Questions about O2 sensor codes P0160 & P0161

    I'm getting the same codes the car is misfiring like crazy in all 6 cylinders and now I'm losing reverse sometimes the transmission is not giving any codes and reading as working properly could the ecm cause the loss or reverse or if i replace the oxygen sensors will that do the trick? PLEASE HELP ASAP

  8. #23
    temo93 is offline Cadillac Owners Member
    Automobile(s): cts
    Join Date
    Jun 2013
    Age
    20
    Posts
    1

    Re: Questions about O2 sensor codes P0160 & P0161

    hey i have the same problem on my car ..but is there any way i can buy the ECM flashed to my vin?

  9. #24
    vwguy is offline Cadillac Owners Member
    Join Date
    Aug 2010
    Age
    36
    Posts
    10

    Re: Questions about O2 sensor codes P0160 & P0161

    Sorry that I never came back with any answers. My mom ended up selling the car shortly after it started stalling out.

    I really want to say that it had something to do with the engine harness. The valve cover gasket was leaking oil all into the harness loom all the way down to the O2 sensors. All of the wiring was saturated with oil. I really didn't feel like wrestling with the harness and she was done with all of the little issues that the car had given her so it was sold.

    Wish I could have been more helpful. I really hate those common codes that don't have a definite fix. Good luck to all that have it.

  10. #25
    Beatdown Z is online now Cadillac Owners Member
    Automobile(s): 03 CTS
    Join Date
    Mar 2013
    Posts
    3

    Re: Questions about O2 sensor codes P0160 & P0161

    I had the p0160/p0161 codes and the ECM did NOT fix the problem. I wound up running new wires from the PCM to the sensor and now all is well.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting