Problem at the Gas Pump!!Car wont start on first Crank - Page 2
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 16 to 30 of 43
Cadillac CTS First Generation Forum - 2003 - 2007 Discussion, Problem at the Gas Pump!!Car wont start on first Crank in Cadillac CTS Coupe, Sport Sedan and Sport Wagon Forums; as i am a noob here can someone tell me how to locate a member?...
  1. #16
    MaxFloss is offline Cadillac Owners Fanatic
    Automobile(s): 2004 EXT
    Join Date
    Jul 2010
    Posts
    305

    Re: Problem at the Gas Pump!!Car wont start on first Crank

    as i am a noob here can someone tell me how to locate a member?

  2. #17
    txbest1980's Avatar
    txbest1980 is offline Cadillac Owners Master
    Automobile(s): 2003 CTS "Ebony Maria" 2005 Cadillac STS "Grace"
    Join Date
    Dec 2008
    Location
    Wherever Uncle Sam sends me
    Age
    34
    Posts
    6,439

    Re: Problem at the Gas Pump!!Car wont start on first Crank

    here you go...just click the link and post a thread in there

    http://www.cadillacforums.com/forums/lindsay-cadillac/

  3. #18
    BlackCadillac91 is offline Cadillac Owners Connoisseur
    Automobile(s): 06 Cadillac CTS 3.6L [Sold :( ] 02 Mustang GT 5Spd
    Join Date
    Jul 2010
    Location
    New Jersey, US
    Age
    23
    Posts
    1,178

    Re: Problem at the Gas Pump!!Car wont start on first Crank

    Quote Originally Posted by ewill3rd View Post
    Yeah, just think of it as someone turning the lights on and off real fast to control how bright they are.
    The longer they leave them on the brighter they are.
    There is a plunger that moves and as it is cycled on and off, it clicks shut.
    Holy crap, excellent description! seriously that clears it up perfectly for me

  4. #19
    Sammy Z's Avatar
    Sammy Z is offline Cadillac Owners Connoisseur
    Automobile(s): CTS 03
    Join Date
    Jan 2008
    Location
    Chicago, IL
    Posts
    1,758

    Re: Problem at the Gas Pump!!Car wont start on first Crank

    Has anyone replaced this on a 2003? I got the part, 214-2230 and spent a couple hours looking for it on the back of the engine with no success. If anyone has a better description location, let me know. Sammy

  5. #20
    ewill3rd is offline Cadillac Technician
    Automobile(s): none
    Join Date
    Nov 2005
    Location
    WOODBRIDGE, VA
    Age
    46
    Posts
    11,062

    Re: Problem at the Gas Pump!!Car wont start on first Crank

    I think I sent you a message back.

    The 3.2 is a bit different but it is in a similar location.
    Post up some pics of the right rear engine area if you can and we'll see if we can spot it for you.

  6. #21
    Sammy Z's Avatar
    Sammy Z is offline Cadillac Owners Connoisseur
    Automobile(s): CTS 03
    Join Date
    Jan 2008
    Location
    Chicago, IL
    Posts
    1,758

    Re: Problem at the Gas Pump!!Car wont start on first Crank

    The Part that I got, 214-2230, I think is located in the rear under the car by the gas tank. It's the Purge solenoid and to get to it I have to drop the rear frame. I think that's more than a DIY job.

  7. #22
    ewill3rd is offline Cadillac Technician
    Automobile(s): none
    Join Date
    Nov 2005
    Location
    WOODBRIDGE, VA
    Age
    46
    Posts
    11,062

    Re: Problem at the Gas Pump!!Car wont start on first Crank

    The part under the car is called a VENT solenoid.
    That isn't your problem.

    I think maybe you have the wrong part.
    Pictures would answer a lot of questions here.

  8. #23
    Sammy Z's Avatar
    Sammy Z is offline Cadillac Owners Connoisseur
    Automobile(s): CTS 03
    Join Date
    Jan 2008
    Location
    Chicago, IL
    Posts
    1,758

    Re: Problem at the Gas Pump!!Car wont start on first Crank

    Ewill, thanks for your help on this, here are some pics of the 03 engine

    Right side engine 2003.jpg
    Rt Close up .jpg
    Left side.jpg
    rear top engine.jpg

    and the part the I have is the 214-2230 just like Smilydog has:
    http://www.cadillacforums.com/forums...g_0007_opt.jpg

  9. #24
    Kingoftypos is offline Cadillac Owners Master
    Automobile(s): 06 CTS Sport/Luxury package
    Join Date
    Apr 2009
    Location
    Ledyard, CT
    Age
    35
    Posts
    7,507

    Re: Problem at the Gas Pump!!Car wont start on first Crank

    I believe this is the device that eWill is talking about y'all. This is located on the passenger side near the fire wall. It has two hose connections and one electronic connection. This was taken from an 06 2.8 liter engine. The device that you two have, is of course totally different looking.

    My question is ewill, it's it possible that they don't have it because they have the 3.2 liter engine. There fore they have an actual PVC system, where as the 2.8 and the 3.6 does not? I don't know if those two system are interlinked or not.

    KOT


  10. #25
    ewill3rd is offline Cadillac Technician
    Automobile(s): none
    Join Date
    Nov 2005
    Location
    WOODBRIDGE, VA
    Age
    46
    Posts
    11,062

    Re: Problem at the Gas Pump!!Car wont start on first Crank

    Okay that helps a lot.

    1. See that bright green cap guys? That is the EVAP service port, it is in the EVAP line that goes straight to the purge solenoid.
    Start at the green cap and follow the line and you will end up at the solenoid. KOT's pic is a perfect illustration of this part on a 3.6/2.8
    2. That part you got is the wrong one Sammy, that is the vent solenoid and it actually goes into the side of the EVAP canister which is located above the rear suspension inside the canister itself. You need the PURGE solenoid. Not surprising that you got the wrong one, when I went looking it was confusing.

    The 3.2 has this solenoid buried back there, but it is there.

  11. #26
    Smileydawg's Avatar
    Smileydawg is offline Cadillac Owners Fanatic
    Automobile(s): Cadillac Cts
    Join Date
    Jul 2008
    Location
    Bahamas
    Posts
    189

    Re: Problem at the Gas Pump!!Car wont start on first Crank

    Ok thanks ewill but can you please give us the right name and number or even a pic of it so we can try get the correct one because I usually have to get it sent to me to the Bahamas so thats usually a long wait.

  12. #27
    ewill3rd is offline Cadillac Technician
    Automobile(s): none
    Join Date
    Nov 2005
    Location
    WOODBRIDGE, VA
    Age
    46
    Posts
    11,062

    Re: Problem at the Gas Pump!!Car wont start on first Crank

    Your best bet is to post a question in the Lindsay Cadillac Vendor area or PM Luke.
    He checks the vendor area regularly for requests.
    He should be able to get you the GM number and/or the AC Delco number.
    Give him the last 8 of the VIN so that he can look it up.
    I don't have access to the parts catalog.

  13. #28
    Smileydawg's Avatar
    Smileydawg is offline Cadillac Owners Fanatic
    Automobile(s): Cadillac Cts
    Join Date
    Jul 2008
    Location
    Bahamas
    Posts
    189

    Re: Problem at the Gas Pump!!Car wont start on first Crank

    ok thanks for your help

  14. #29
    Sammy Z's Avatar
    Sammy Z is offline Cadillac Owners Connoisseur
    Automobile(s): CTS 03
    Join Date
    Jan 2008
    Location
    Chicago, IL
    Posts
    1,758

    Re: Problem at the Gas Pump!!Car wont start on first Crank

    E-will, you are right, I have the 3.2 and saw that part way in the back of the engine. I had to take a lot of parts off just to see it. BTW, is there any way to test if that is the problem? The car runs fine except after you fill it up, it takes a long time to start.

  15. #30
    ewill3rd is offline Cadillac Technician
    Automobile(s): none
    Join Date
    Nov 2005
    Location
    WOODBRIDGE, VA
    Age
    46
    Posts
    11,062

    Re: Problem at the Gas Pump!!Car wont start on first Crank

    One line goes to the engine, the other goes to the fuel tank.
    If you disconnect the line on the side of the fuel tank, start the engine and check for the presence of engine vacuum with the solenoid electrical connector unplugged.
    If there is vacuum it is leaking.
    If not it is okay.
    That is the easiest way.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting