Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 4 of 4

Thread: blinker and tranny problems

  1. #1
    zigzagcaddy is offline Cadillac Owners Member
    Automobile(s): 1998 catera
    Join Date
    Jul 2014
    Age
    33
    Posts
    12

    blinker and tranny problems

    My blinker fuse is blowing about once a day. Thats the first issue. My second one is now my tranny seems to shut down when that happens. And before the tranny goes into limp mode the cruise ontrol quits. Help pleaae. Ive only owned my caddy for about a month. I like it. Bit little gremlins keep popping up


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    investor74 is offline Cadillac Owners Enthusiast
    Automobile(s): '97 Forest Green Catera
    Join Date
    Nov 2005
    Posts
    674

    Re: blinker and tranny problems

    *********Kaustein Alert!*****************Kaustein Alert!*******************Kaustein Alert!*******************Kaustein Alert!*******************

    Look at the voltmeter on the dash. It should read a pretty steady 13.5 volts. A little higher after a cold start. I can tell you from experience that the transmission in the Catera is very sensitive to voltage. When the trans starts acting up, it is usually the alternator. Check that battery terminals are clean and tight. Fuses blow either because the voltage is too high (bad alternator) or there is a path to ground, either one causes more current than the fuse is rated at. Since you have two different fuses blowing, the path to ground is the less likely.

  4. #3
    elvin315's Avatar
    elvin315 is offline Cadillac Owners Connoisseur
    Automobile(s): Platinum 2001 Cadillac Catera Sport
    Join Date
    Jan 2007
    Location
    Warwick, NY
    Age
    63
    Posts
    1,840

    Re: blinker and tranny problems

    I don't mean to hijack the thread but since we're talking alternators...........

    I have a ScanGauge 2 in my car and when the engine is running it reads between 11.8 - 12.7 volts and rarely breaks 13.0 v. A new Diehard in January made no difference. The battery terminals and cable ends are clean. I had the charging system tested at Advanced Auto Parts and it checked out OK.

    The car has refused to start (dash lights, but no cranking) a few times. A jump start gets her going with no drama on the way back home, but lately every start is a guessing game. Usually it starts but it only takes that one time it doesn't to spoil my day. I suspect the cables but still not convinced it's not the alternator.

    Any ideas before I throw money at the problem?

  5. #4
    zigzagcaddy is offline Cadillac Owners Member
    Automobile(s): 1998 catera
    Join Date
    Jul 2014
    Age
    33
    Posts
    12

    Re: blinker and tranny problems

    Voltage reads correct and battery tight. The fog lights are missing and the wire harness is hanging for them. Can that contribute? Ive tied them up. Is there a way to remove just the harness for the for lights?


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum