01 Catera air vent blower issue
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 6 of 6
Cadillac Catera and Cimarron Forum Discussion, 01 Catera air vent blower issue in Past Cadillac Vehicle Discussion; Hi all, This is on my in laws catera. The air vent was working fine, then with the A/C turned ...
  1. #1
    retho78 is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac
    Join Date
    Sep 2007
    Posts
    1,003

    01 Catera air vent blower issue

    Hi all,

    This is on my in laws catera. The air vent was working fine, then with the A/C turned on later this afternoon the fan blew super fast for few seconds then it slowed down. With the radio out and changing the modes I can see the metal shaft below / behind the climate control moving but not seeing much changes with the vent and air output. The fan speed goes up and down when I change it on the climate control but feel like the air is not coming out all the way, blows air equally from all vents

    Also, with the A/C turned on I can hear the compressor working but not cooling properly. Could it be that the blend door actuator is stuck in heat mode or could it be something related to the fan motor?


    Thanks.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    retho78 is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac
    Join Date
    Sep 2007
    Posts
    1,003
    Thread Starter

    Re: 01 Catera air vent blower issue

    well, the compressor kicks in when the A/C is turned on but does not cool so I'm guessing the vent / blend door actuator is stuck in heat mode.

  4. #3
    elvin315's Avatar
    elvin315 is offline Cadillac Owners Connoisseur
    Automobile(s): Platinum 2001 Cadillac Catera Sport
    Join Date
    Jan 2007
    Location
    Catskill, NY
    Age
    60
    Posts
    1,651

    Re: 01 Catera air vent blower issue

    Have you tried to recharge the refrigerant? Purge the system, add refrigerant and see if that fixes it. It did for me.

  5. #4
    retho78 is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac
    Join Date
    Sep 2007
    Posts
    1,003
    Thread Starter

    Re: 01 Catera air vent blower issue

    It was filled up last year and had no leaks so I think the system has enough refrigerant in it. If not,
    it wouldn't turn the compressor on.

  6. #5
    retho78 is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac
    Join Date
    Sep 2007
    Posts
    1,003
    Thread Starter

    Re: 01 Catera air vent blower issue

    Alright just a quick update. After messing around with the air issue, I noticed that the top motor doesn't move but the bottom one moves and changes some vent function while changing it on the climate control. The top motor gets hot and I can hear it clicking but no changes happening. The front defrost vent and center vents would always blow air in all modes and the only change I noticed was the air coming from bottom / foot vents, it would close and open. My guess is that top motor has slipped off since the mode is not changing for the center and window defrost area. I manually moved the lever and it increased air coming out of the center vents. Also, where are the heater blend doors located? Is it on both sides and could that be the problem?

    Another thing I noticed was that when I turn on the A/C the air blows way faster compared to when the A/C is off? What could be the problem here? Blend door actuator or motor are they related to the fan speed going up and down when A/C is ON?

    Also, how do I calibrate the climate control to get the vents to work properly after it's is all fixed up?

  7. #6
    retho78 is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac
    Join Date
    Sep 2007
    Posts
    1,003
    Thread Starter

    Re: 01 Catera air vent blower issue

    quick update - I checked the four motors / actuators for the vents and found out the top motor on the passenger side was not working right, the shaft came off the motor. I believe it's the one for the front defrost area. Anyways, I took the motor out and removed it from the black plastic casing and pushed back the shaft in to the motor housing and installed it back and now the vents are working but still the air only blows really high when the compressor is on.

    Could it be the motor resistor going bad or low refrigerant in the system causing the air to fluctuate when compressor is on?

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting