Code P0501
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 4 of 4
Cadillac Catera and Cimarron Forum Discussion, Code P0501 in Past Cadillac Vehicle Discussion; I'm getting code P0501 which is "Speed Sensor A/Range, Pergormance". Where is that located?...
  1. #1
    Al Leverick is offline Cadillac Owners Member
    Join Date
    Oct 2004
    Posts
    27

    Code P0501

    I'm getting code P0501 which is "Speed Sensor A/Range, Pergormance".

    Where is that located?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Vesicant's Avatar
    Vesicant is offline Cadillac Owners Connoisseur
    Automobile(s): None :(
    Join Date
    Nov 2003
    Location
    Jacksonville, FL
    Posts
    2,703

    Re: Code P0501

    P0501 - Vehicle Speed Sensor Range/Performance

    On the back of the transmission, that one I believe is on the output shaft.

    Is your speedometer still working? The speed correct? Go to an autozone and get the codes erased then see if it comes back.

    #17 on this photo. I hope theres just one sensor.

  4. #3
    Al Leverick is offline Cadillac Owners Member
    Join Date
    Oct 2004
    Posts
    27

    Re: Code P0501

    No, speedometer does not work when TC/ABS warning lights are lit. They go on an off from time to time.

  5. #4
    Enz
    Enz is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Jul 2007
    Posts
    25

    Re: Code P0501

    Yes this happened to my 1998 catera as well; fixed it myself:
    put the front-tires up on ramps, turn car off & lock emergency brake
    crawl approx. middle of the car- you'll see the drive column
    locate a deppressed area and look for a black wire attached to a sensor perched above the drive column- I think its a 10mm bolt head. Unloosen bolt-head and replace sensor. Start car- the speedo-neddle will return to normal.
    Sontov

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting