Catera Stalls.. starts/runs after sitting... then stalls again
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 8 of 8
Cadillac Catera and Cimarron Forum Discussion, Catera Stalls.. starts/runs after sitting... then stalls again in Past Cadillac Vehicle Discussion; Could somebody/ anybody PLEASE help me with this problem? My '99 Catera just turned 170,000 miles and aside from some ...
  1. #1
    gjinx is offline Cadillac Owners Member
    Automobile(s): Catera
    Join Date
    Oct 2004
    Location
    Cleveland, OH
    Posts
    12

    Catera Stalls.. starts/runs after sitting... then stalls again

    Could somebody/ anybody PLEASE help me with this problem? My '99 Catera just turned 170,000 miles and aside from some of the common Catera problems. Mine has seen very little time in the repair shop. Until recently. My Catera just spent three days in the repair shop/ I dropped it off there because my brakes were very soft (could barely stop the vehicle) so sa few days later; new brake lines installed; and several hundreds of dollars (of course). I was driving the car home when it stalled so I let the car sit for a few minutes before it would start. After driving it 1 mile it stalled again and it stalled again a third time just feet from the driveway so I pushed it the rest of the way. Now Im about to call a tow truck to take it BACK to the repair shop If anyone has any advice or remedy for this problem I would greatly appreciate some help

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,960
    The first step is to have the codes pulled.

    Next time it won't start, remove the gas cap, put your ear up to it, and have a helper turn the key to the ON position. See if you can hear the fuel pump running.

  4. #3
    marko69 is offline Cadillac Owners Fanatic
    Automobile(s): 2001 Catera Sport, 1990 Porsche 944 S2 cab
    Join Date
    Jun 2011
    Location
    Tampa
    Posts
    108

    Re: Catera Stalls.. starts/runs after sitting... then stalls again

    I'm curious, the shop replaced only the brake lines to fix the problem?

  5. #4
    kaustein is offline Cadillac Owners Enthusiast
    Automobile(s): Cadillac
    Join Date
    Jul 2008
    Posts
    691

    Re: Catera Stalls.. starts/runs after sitting... then stalls again

    Crankshaft positioning sensor may be the problem. VERY common issue your description is symptomatic of a CPS problem

  6. #5
    hgqguy's Avatar
    hgqguy is offline Cadillac Owners Fanatic
    Automobile(s): catera
    Join Date
    Nov 2009
    Location
    Rochester NY
    Age
    34
    Posts
    449

    Re: Catera Stalls.. starts/runs after sitting... then stalls again

    I was thinking CPS also. Odd that it restarted right away though.. or did it have to sit for a bit to cool off?

  7. #6
    JohnJJO's Avatar
    JohnJJO is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Mar 2012
    Location
    Wilmington, NC
    Posts
    421
    I wouldn't say that! In my case I just couldn't start engine right away. Engine was starting after like 3-5 cranks and then running just fine till I shut it off. Cam shaft position sansor failed same way but before crank sensor

  8. #7
    olddavid is offline Cadillac Owners Member
    Automobile(s): 93 Eldorado(sold)99 SLS(sold) 98Catera
    Join Date
    Mar 2007
    Location
    Depoe Bay, Oregon
    Posts
    58

    Re: Catera Stalls.. starts/runs after sitting... then stalls again

    My car had similar problems, but disconnecting the MAF allowed me to drive it until I got the O2 sensor it needed to operate correctly. I may be completely off base on this, but our cars require creative thinking to diagnose. Of course, the crank and/or cam sensors could also be faulty, but the disconnect of the MAF is quick and easy and if it doesn't help, you've eliminated one more possibility.

  9. #8
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,960
    Disconnecting the MAF will allow the car to run of the MAF is faulty, it has nothing to do with the O2 sensors. And faulty O2 sensors will not cause the OPs symptoms.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting