02 sensors
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 3 of 3
Cadillac Catera and Cimarron Forum Discussion, 02 sensors in Past Cadillac Vehicle Discussion; My '98 Catera's "check engine" light is coming on intermettantly. Had a diagnostic run, and was told that the 02 ...
  1. #1
    GarthSteever is offline Cadillac Owners Member
    Automobile(s): Catera
    Join Date
    Jan 2011
    Age
    52
    Posts
    5

    02 sensors

    My '98 Catera's "check engine" light is coming on intermettantly. Had a diagnostic run, and was told that the 02 sensor were not reading. Did not get an explanation as to why this is intermittent. Any advice? The Cat is running beautifully, the "check engine" light is annoying and concerning....when it's on. Which is just part of the time. Thoughts?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    22,058
    What were the codes?

    Sounds like the sensors are failing.

  4. #3
    98Catera_2010's Avatar
    98Catera_2010 is offline Cadillac Owners Fanatic
    Automobile(s): 1998 Cadillac Catera
    Join Date
    Oct 2010
    Location
    Cookstown, Ontario Canada
    Age
    26
    Posts
    177

    Re: 02 sensors

    Just the other day mine came on as well while during acceleration.so I pulled over and when I came to a stop the car was shaking like it does when the ignition coils go. Turned car off, waited a min turned it back on and it wasn't shaking or anything and it hasn't happened again . I know my cats are needing to be replaced, when I start it in the cold mornings and rev it the exhaust sounds like a ricers exhaust with that stupid tuner sound. Sounds like there something loose and rattles when revved but it all goes away after warmed up. Had the exhaust off while I did the engine swap at beginning of the month so could have loosened the glass or watever in there.? Any suggestions?

    ----------

    Haven't pulled codes yet if that's what ur gunna ask lol. I'm on a road trip as we speak 600 kms and change each way.

    ----------

    Putting the old girl to the test with new engine lol

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting