Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 11 of 11

Thread: Audio system problems?

  1. #1
    Stewie2395 is offline Cadillac Owners Member
    Automobile(s): cadillac catera
    Join Date
    Mar 2013
    Posts
    22

    Audio system problems?

    Okay I have a 2001 Cadillac Catera. i'm installing a new HU.

    The problem is that after I have it installed and hooked up it blows fuses, I've already been through a 10amp (which it is suppose to use), a 20 amp and 30 amp fuse..

    Does anyone have an idea why it is doing this?

    Last edited by Stewie2395; 03-14-13 at 05:34 PM.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    CadillacManny's Avatar
    CadillacManny is offline Cadillac Owners Member
    Automobile(s): 1999 Cadillac Catera
    Join Date
    Feb 2013
    Location
    Marietta, PA
    Posts
    55
    How hard is it to get the front door panels off to replace front speakers

  4. #3
    Stewie2395 is offline Cadillac Owners Member
    Automobile(s): cadillac catera
    Join Date
    Mar 2013
    Posts
    22

    Re: Audio system problems?

    why would i need to do that?

  5. #4
    CadillacManny's Avatar
    CadillacManny is offline Cadillac Owners Member
    Automobile(s): 1999 Cadillac Catera
    Join Date
    Feb 2013
    Location
    Marietta, PA
    Posts
    55
    No I just wanna no

  6. #5
    JohnJJO's Avatar
    JohnJJO is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Mar 2012
    Location
    Wilmington, NC
    Posts
    429
    Look at my video. Type " catera door noise" on youtube

  7. #6
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): 2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    29
    Posts
    26,323
    Quote Originally Posted by Stewie2395
    Okay I have a 2001 Cadillac Catera. i'm installing a new HU.

    The problem is that after I have it installed and hooked up it blows fuses, I've already been through a 10amp (which it is suppose to use), a 20 amp and 30 amp fuse..

    Does anyone have an idea why it is doing this?
    Is this a replacement stock HU, or after market?

    Either way DO NOT USE LARGER FUSES. The whole point of a fuse is to protect the wiring from higher amperage than it's rated for. Using a higher amperage fuse, defeats the purpose. You'll end up with a larger problem.

  8. #7
    Stewie2395 is offline Cadillac Owners Member
    Automobile(s): cadillac catera
    Join Date
    Mar 2013
    Posts
    22

    Re: Audio system problems?

    Its an aftermarket ... and yea.. so what now?

  9. #8
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): 2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    29
    Posts
    26,323
    When is it blowing the fuse? As soon as it's plugged in? When it's turned on? While it's on?
    Last edited by MoistCabbage; 03-15-13 at 11:25 PM.

  10. #9
    Stewie2395 is offline Cadillac Owners Member
    Automobile(s): cadillac catera
    Join Date
    Mar 2013
    Posts
    22

    Re: Audio system problems?

    no, i put a fuse in, when i turn the key to the on position thats when it blows

  11. #10
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): 2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    29
    Posts
    26,323
    Are you sure the harness was wired correctly?

  12. #11
    Stewie2395 is offline Cadillac Owners Member
    Automobile(s): cadillac catera
    Join Date
    Mar 2013
    Posts
    22

    Re: Audio system problems?

    I'm pretty sure I read the instructions very carefully... and even with everything unplugged for the car harness, it still pops.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum