High beam malfunction...annoying...
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 8 of 8
Cadillac Catera and Cimarron Forum Discussion, High beam malfunction...annoying... in Past Cadillac Vehicle Discussion; So, I'm driving on the freeway and my high beams go crazy and start blinking rapidly. The turn indicator stalk ...
  1. #1
    IvoryWhiteCatera's Avatar
    IvoryWhiteCatera is offline Cadillac Owners Fanatic
    Automobile(s): 1998 Catera (SOLD)
    Join Date
    Apr 2011
    Posts
    120

    High beam malfunction...annoying...

    So, I'm driving on the freeway and my high beams go crazy and start blinking rapidly. The turn indicator stalk is in the normal position when it happens, too. Any ideas? It gets annoying because it occurs at random and people in front of me think I'm flashing them.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    gvjv3 is offline Awaiting Email Confirmation
    Automobile(s): 97 forest Green catera
    Join Date
    May 2012
    Posts
    119

    Re: High beam malfunction...annoying...

    Check the blubs, did someone change them to HID?, look for the high beam relay, if anything you can remove the high beam blubs

  4. #3
    investor74 is offline Cadillac Owners Enthusiast
    Automobile(s): '97 Forest Green Catera
    Join Date
    Nov 2005
    Posts
    665

    Re: High beam malfunction...annoying...

    Quote Originally Posted by IvoryWhiteCatera View Post
    So, I'm driving on the freeway and my high beams go crazy and start blinking rapidly. The turn indicator stalk is in the normal position when it happens, too. Any ideas? It gets annoying because it occurs at random and people in front of me think I'm flashing them.
    I think our multifunction stalks are wearing out. The springs, the contacts, the detents, etc. I have a related problem where the high beams randomly come on when the lights are on. Usually after a turn where I used the turn signal. A bit of backpressure on the stalk turns it off again. I "fixed" it using a rubber band to keep the stalk in the correct position. Had to make sure the rubber band was applying just the right amount of backpressure, too much and the high beams also come on with the flash to pass feature.

    I guess our cars are now senior citizens and we can expect some quirkyness.

  5. #4
    kaustein is offline Cadillac Owners Enthusiast
    Automobile(s): Cadillac
    Join Date
    Jul 2008
    Posts
    689

    Re: High beam malfunction...annoying...

    Sadly the quirky from day one! Wait until you sunroof opens on it's own!

  6. #5
    IvoryWhiteCatera's Avatar
    IvoryWhiteCatera is offline Cadillac Owners Fanatic
    Automobile(s): 1998 Catera (SOLD)
    Join Date
    Apr 2011
    Posts
    120

    Re: High beam malfunction...annoying...

    Quote Originally Posted by kaustein View Post
    Sadly the quirky from day one! Wait until you sunroof opens on it's own!
    It's happened to me!

    ----------

    Quote Originally Posted by investor74 View Post
    I think our multifunction stalks are wearing out. The springs, the contacts, the detents, etc. I have a related problem where the high beams randomly come on when the lights are on. Usually after a turn where I used the turn signal. A bit of backpressure on the stalk turns it off again. I "fixed" it using a rubber band to keep the stalk in the correct position. Had to make sure the rubber band was applying just the right amount of backpressure, too much and the high beams also come on with the flash to pass feature.

    I guess our cars are now senior citizens and we can expect some quirkyness.
    Thanks for the suggestion. At least my car isn't the only one with the problem.

  7. #6
    TheCrimsonKing is offline Cadillac Owners Member
    Automobile(s): 2001 Cadillac Seville sls
    Join Date
    Feb 2013
    Posts
    2

    Re: High beam malfunction...annoying...

    I've been having the exact same issue! It only happens after making a right turn with signal. And applying back pressure usually turns them off until i have to make another turn. Get's really frustrating. I think I'll just take out the bulbs as I can go without them entirely.

  8. #7
    kaustein is offline Cadillac Owners Enthusiast
    Automobile(s): Cadillac
    Join Date
    Jul 2008
    Posts
    689

    Re: High beam malfunction...annoying...

    I used to have an older Escort that at night, right turns signaling would turn off headlights!

  9. #8
    TheCrimsonKing is offline Cadillac Owners Member
    Automobile(s): 2001 Cadillac Seville sls
    Join Date
    Feb 2013
    Posts
    2

    Re: High beam malfunction...annoying...

    So all i did as a quick fix was pull fuse #27 and problem solved. I can certainly go without the high beams.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting