Frozen? windshield wipers
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 4 of 4
Cadillac Catera and Cimarron Forum Discussion, Frozen? windshield wipers in Past Cadillac Vehicle Discussion; My wipers were left up during a snowstorm. Now they sound like theyre working but no action. what is going ...
  1. #1
    krkelly14 is offline Cadillac Owners Member
    Automobile(s): 2001 Cadillac Catera
    Join Date
    Feb 2013
    Posts
    1

    Frozen? windshield wipers

    My wipers were left up during a snowstorm. Now they sound like theyre working but no action. what is going on?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    98Catera_2010's Avatar
    98Catera_2010 is offline Cadillac Owners Fanatic
    Automobile(s): 1998 Cadillac Catera
    Join Date
    Oct 2010
    Location
    Cookstown, Ontario Canada
    Age
    26
    Posts
    175

    Re: Frozen? windshield wipers

    Check to see if they need to tightened up. If there tight then gunna have to just get a new motor. This happen to mine as well , the drivers side wiper stop working but passenger still wiped so I just went and got one from junkyard and replaced it. Its not a difficult job. If I remember correctly it took me & father in-law about half hour to 45 mins including removal off of the junk car. Haven't had problem since.

  4. #3
    investor74 is offline Cadillac Owners Enthusiast
    Automobile(s): '97 Forest Green Catera
    Join Date
    Nov 2005
    Posts
    665

    Re: Frozen? windshield wipers

    Are they frozen stuck to the windshield? Try some de-icer or move the car to a heated garage.

  5. #4
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,546
    Quote Originally Posted by krkelly14
    Now they sound like theyre working but no action.
    Sounds like the linkage is disconnected/damaged.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting