cooling problem again
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 6 of 6
Cadillac Catera and Cimarron Forum Discussion, cooling problem again in Past Cadillac Vehicle Discussion; i read allot of post here but never found one that can help my problem! just replace radiator! got one ...
  1. #1
    JohnJJO's Avatar
    JohnJJO is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Mar 2012
    Location
    Wilmington, NC
    Posts
    421

    cooling problem again

    i read allot of post here but never found one that can help my problem!
    just replace radiator! got one from junk yard, mine was creaked year ago due to overheat but was solved by jb welder glue but after year start to fail. after i replace radiator i used temperature switches that was already on the radiator when i got it from junk yard, now fan between radiator and engine dont work (i tested fan it self, it work!!!!). that could cost by upper switch that next to the battery, i will try to replace it with my old one tomorrow, to see whats gonna happened!
    but the biggest problem is in auxiliary water pump the one that next to the battery, it just dont work, i never notice if it was working before i replaced radiator or not. pump work it self when putting
    12v on it, but from wire it self no power coming to the pump. WHY????
    on passenger side pump working all the time (is it suppose to be like that ????) upper temperature switch related to that pump and please tell me how that crazy cooling system work step by step. like what start or stop to work in the order and with what temperature.
    Thank you

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    investor74 is offline Cadillac Owners Enthusiast
    Automobile(s): '97 Forest Green Catera
    Join Date
    Nov 2005
    Posts
    666

    Re: cooling problem again

    The operation of the cooling system, various fans and all the switches is too complicated to post here in text. Get yourself a shop manual and there are pages and pages that describe how it works.

    If you are fixing a leak in the radiator and replace the radiator with a used junk yard one with the switches already on it, you can introduce a problem that you didn't have before. Just replace one component at a time. A new generic radiator for my Catera only cost me $140 shipping included.

    Explain what is the problem your car is having now. Is it overheating? Voltage is only supplied to various components when it is necessary.

    If the auxilliary pump is not coming on when it is supposed to, it could be fuse #10 under the dash.

  4. #3
    JohnJJO's Avatar
    JohnJJO is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Mar 2012
    Location
    Wilmington, NC
    Posts
    421

    Re: cooling problem again

    ok just replaced upper switch with my old one and all fans are working now
    but auxiliary water pump that next to the battery still dont work ;(
    HELP
    im going to check all fuses and all so will check on what temperature that switch switching maybe i still need to just get new one

  5. #4
    JohnJJO's Avatar
    JohnJJO is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Mar 2012
    Location
    Wilmington, NC
    Posts
    421

    Re: cooling problem again

    Quote Originally Posted by investor74 View Post
    The operation of the cooling system, various fans and all the switches is too complicated to post here in text. Get yourself a shop manual and there are pages and pages that describe how it works.

    If you are fixing a leak in the radiator and replace the radiator with a used junk yard one with the switches already on it, you can introduce a problem that you didn't have before. Just replace one component at a time. A new generic radiator for my Catera only cost me $140 shipping included.

    Explain what is the problem your car is having now. Is it overheating? Voltage is only supplied to various components when it is necessary.

    If the auxilliary pump is not coming on when it is supposed to, it could be fuse #10 under the dash.
    thanks for respond but problem is the money i already spend on this CRAPTERA over 3500 and got car for 4900 with 126k on it. im still planing to spend more and get another new coil for cylinder 1.3.5, get new front arms and struts (due to crazy steering wheel shaking) also my muffler makes noise on cold start + planing to get new catalyst im not even talking about new set of tires that im dreaming to get after i replace front suspension (just keep getting used ones all the time )
    but i have all data and for some reason cant find that cooling diagram only like wiring thats it

  6. #5
    JohnJJO's Avatar
    JohnJJO is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Mar 2012
    Location
    Wilmington, NC
    Posts
    421

    Re: cooling problem again

    ok i just test my upper switch , its turn all fans "ON" at 206F and shut them of when temperature dropped to 192F. I dont know if its ok!!!!! , but auxiliary water pump that next to the battery still dont work ;( it just no power coming to it !!!!! i check all fuses, puled every single one of them !!!! and they are all GOOD
    in owners manual it says, that white relay is for auxiliary water pump when i opened that white relay on car running relay was closed (when car off circuit is open) so i opened circuit with flat thin screw driver but didnt saw NO changes, pump on passenger side still was running, on battery side pump still was not receiving power..........
    HELP

  7. #6
    JohnJJO's Avatar
    JohnJJO is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Catera Sport
    Join Date
    Mar 2012
    Location
    Wilmington, NC
    Posts
    421

    Re: cooling problem again

    ok i just test my upper switch , its turn all fans "ON" at 206F and shut them of when temperature dropped to 192F. I dont know if its ok!!!!! , but auxiliary water pump that next to the battery still dont work ;( it just no power coming to it !!!!! i check all fuses, puled every single one of them !!!! and they are all GOOD
    in owners manual it says, that white relay is for auxiliary water pump when i opened that white relay on car running relay was closed (when car off circuit is open) so i opened circuit with flat thin screw driver but didnt saw NO changes, pump on passenger side still was running, on battery side pump still was not receiving power..........
    HELP

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting