Radio Power
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 3 of 3
Cadillac Catera and Cimarron Forum Discussion, Radio Power in Past Cadillac Vehicle Discussion; I was looking for a busted Clamp 15 fuse when I came across something, the previous owner had used two ...
  1. #1
    AL Cool Dates is offline Cadillac Owners Member
    Automobile(s): 2000 Cadillac Catera Sport
    Join Date
    Aug 2010
    Location
    Bronx, New York, United States
    Posts
    91

    Radio Power

    I was looking for a busted Clamp 15 fuse when I came across something, the previous owner had used two cables to power the radio through fuses! Sound Confusing? I know, confused the hell out of me also so I included a picture. This can't be right, why would someone do this? My radio works fine actually, it just doesnt come on when you turn the key to position I (probably because the power isnt done right). I may pull the radio out in a few days to see if this can be done right because the way it is now can't be too safe.
    Attached Images

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    investor74 is offline Cadillac Owners Enthusiast
    Automobile(s): '97 Forest Green Catera
    Join Date
    Nov 2005
    Posts
    672

    Re: Radio Power

    The radio should be on fuse 14, which is the blue 15 amp in the middle of the middle row. That fuse also controllers the cigarette lighter and a number of other items.

  4. #3
    Lizzys Cat is offline Cadillac Owners Member
    Automobile(s): 2000 Catera!
    Join Date
    Aug 2013
    Posts
    10

    Re: Radio Power

    If you are having the radio issue where it won't power on in position 2 and only key position 1 upon shutdown, check fuse #10 for the aux water pump. This was our issue and not the K134 MF relay.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting