My car won't start. Can the problem be the crankshaft position sensor?
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 6 of 6
Cadillac Catera and Cimarron Forum Discussion, My car won't start. Can the problem be the crankshaft position sensor? in Past Cadillac Vehicle Discussion; Hello. I have a 2001 catera. In the last three months ive changed the radiator due to fluding of the ...
  1. #1
    julucadillac is offline Cadillac Owners Member
    Join Date
    Apr 2011
    Posts
    5

    My car won't start. Can the problem be the crankshaft position sensor?

    Hello. I have a 2001 catera. In the last three months ive changed the radiator due to fluding of the transmition, a radiator hose, the brake light sensor, car battery and once again i am having trouble with my car. For about two weeks the gas light cap has been coming on, a week later the car wouldn't start. I got a jump and it started fine. The following night the car wouldn't start for the second time. I played with the gas cap and the car started. The following night the car once again wouldn't start for the third time. I played with the gas cap and the battery wires and the car started. The following night for the fourth time it wouldn't start and has not started since. It is cranking and wants to start, but doesn't. I thought the problem may have been the crackshaft p sensor, so i changed it. That didn't work. I noticed when puting in the CPS that there is a slight oil leak from some where in the engine compartment. Also, when removing the old CPS, ther appeared to have been oil in the shaft were the CPS goes. Is that normal? Can the oil leak be the reason the car won't start? By the way, my car has a little less than 161,000 miles. Any additional info is greatly appreciated.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    elvin315's Avatar
    elvin315 is offline Cadillac Owners Connoisseur
    Automobile(s): Platinum 2001 Cadillac Catera Sport
    Join Date
    Jan 2007
    Location
    Catskill, NY
    Age
    60
    Posts
    1,608

    Re: My car won't start. Can the problem be the crankshaft position sensor?

    You don't specify if the engine won't turn over at all or if it fails to "catch". It's important to include as much detail as possible in your questions. The answer might already be in the sticky at the top of the page. The link to the whole thread is at the bottom of this post. The information there solved my CPS problem. The quote is my contribution to the thread.

    Well, it finally happened to me. I have never been afraid to jump in my Cat and ripoff a 400 mile day. Now I'm not so confident. Last night I went out for a bite and she dies while backing out of the parking spot. When I started her in the garage she stalled. I thought I just hadn't kept the starter on long enough. The engine caught quickly the second time and off we went. There were a few stops before the diner and she started fine each time.

    When she did die there was no CEL but the Sport light (s inside a cog) was flashing. I have a ScanGauge installed and immediately checked for codes. There were none. Still, from hanging out here and learning, I'm sure it was the CPS. The engine would crank strongly. I replaced the battery 2 months ago for an unrelated reason so I'm sure it wasn't that. I pushed the car back into the spot and checked under the hood for anything obvious. Not knowing which cable was the CPS I wiggled as many as I could. After 15 minutes I tried again and she fired right up. The Sport light was still flashing.

    Not wanting to tempt fate and try a restart I headed for home. The transmission was in limp-home mode and engaged only 3rd & 4th gears. Highway performance was normal. Once back in my garage I shut her off and back on again. The engine started fine, this time with no flashing Sport light. I took a lap around the neighborhood and everything was back to normal. I'll have my local mechanic change it. I know it's an easy job but it's too cold for me to lay on an unheated garage's floor. I'm due for a car inspection and oil change. The sensor mounts next to the oil filter so while the car is up on the lift he can change it easily.

    I hope my snap diagnosis is correct but I'll be renewing my AAA membership just in case. One more thing. As I checked old posts for CPS info I found a reference to the Fuel Cap Alarm being related to the CPS. I have been seeing the FCA intermittently for at least 6 months. I can't say for sure but if you get the Fuel Cap Alarm it could be a warning sign of a future CPS failure.
    http://www.cadillacforums.com/forums...ing-light.html (99 Catera "Fuel Cap" warning light comes on)

    UPDATE:

    I wanted to put an ending to this story. I just finished an 900 mile weekend with my new Crankshaft Position Sensor and the engine never skipped a beat. It started every time. No stalling. No codes. Nothing. Thanks to the information here I was able to save myself the frustration of dealing with clueless service techs. I ordered the part, handed it to the service manager, they installed it, and that was that. I was a little nervous during the first 30 miles of test drives before the weekend trip but after that I stopped staring at the gauges. Except for the speeding ticket I got (81 in a 65 zone) it was an uneventful trip.

    It just turned 68,000 miles this weekend. After rooting around the engine and tracing the CPS cable I don't think the sensor actually wears out. It's the cable itself that's the problem. It passes very close to the left hand exhaust pipe and the oil cooler lines. I think the heat damages the sheathing (either melts it or cracks it) and shorts the sensor leads. I forgot to ask for the old part so I don't know which. Even though the cable has heat shielding, the farther away from the those heat sources the better.

    GM/ACDelco PN= 90494182
    BOSCH PN= 0261210

    Elvin
    CPS Thread:
    http://www.cadillacforums.com/forums...placement.html

  4. #3
    julucadillac is offline Cadillac Owners Member
    Join Date
    Apr 2011
    Posts
    5

    Re: My car won't start. Can the problem be the crankshaft position sensor?

    Thank you elvin315 for your feedback. Recently i sent a cadillac specialist this:

    Hello. I have a 2001 catera. In the last three months ive changed the radiator due to fluding of the transmition, a radiator hose, the brake light sensor, car battery and once again i am having trouble with my car. For about two weeks the gas light cap has been coming on, a week later the car wouldn't start. I got a jump and it started fine. The following night the car wouldn't start for the second time. I played with the gas cap and the car started. The following night the car once again wouldn't start for the third time. I played with the gas cap and the battery wires and the car started. The following night for the fourth time it wouldn't start and has not started since. It is cranking and wants to start, but doesn't. I thought the problem may have been the crackshaft p sensor, so i changed it. That didn't work. I noticed when puting in the CPS that there is a slight oil leak from some where in the engine compartment. Can the oil leak be the reason the car won't start? By the way, my car has a little less than 161,000 miles. Any additional info is greatly appreciated.

  5. #4
    salata58 is offline Cadillac Owners Member
    Automobile(s): catera 2001
    Join Date
    Oct 2012
    Posts
    6

    Re: My car won't start. Can the problem be the crankshaft position sensor?

    hello,
    i just got my car back from the mechanic and what iam about to tell you will save you money and solve the problem.
    the s light flashing and causing the car to stall is caused by the camshaft, try disconnecting the camshaft sensor and see if the problem goes away. mine did so replacing the camshaft will solve the issue.
    camshaft sensor is located on the right side of the engin its easy to disconnect as its visable you cant miss it.

    goodluck

  6. #5
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,401
    A flashing "S" can mean a few things. Replacing the camshaft will NOT solve the problem.

  7. #6
    investor74 is offline Cadillac Owners Enthusiast
    Automobile(s): '97 Forest Green Catera
    Join Date
    Nov 2005
    Posts
    665

    Re: My car won't start. Can the problem be the crankshaft position sensor?

    The "S" light flashing usually means a problem with the transmission, but could also mean low voltage. The transmission controls are very sensitive to the car's voltage. You need a code reader that can read transmission codes.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting